17 responses

  1. Nikolay Nikolaev
    May 2, 2012

    That’s very useful, thanks for sharing the information.

    I use schroot for these things. It integrates perfectly in the environment (automatically mounts what’s needed – dev, proc etc.).
    Here’s an excerpt from my /etc/schroot/schroot.conf that shows 32bit chroot on my 64 bit box

    [precise32]
    description=Precise Pangolin 32
    directory=/chroots/precise32
    type=directory
    users=
    root-groups=root
    personality=linux32

    Then as a regular user:
    schroot -c precise32

  2. cnxsoft
    May 2, 2012

    @ Nikolay Nikolaev
    Thanks I did not know schroot.
    If somebody wants to know more, have a look at the manpage: http://manpages.ubuntu.com/manpages/hardy/man1/schroot.1.html

  3. Nikolay Nikolaev
    May 2, 2012

    @ cnxsoft
    And this is the ‘Precise” manpage (you gave the ‘Hardy’ one):

    http://manpages.ubuntu.com/manpages/precise/man1/schroot.1.html

    cheers

  4. Markus
    October 3, 2012

    Small nits in the description:

    **
    deb-src http://archive.ubuntu.com/ubuntu price main universe
    ->
    deb-src http://archive.ubuntu.com/ubuntu precise main universe

    **
    apt-get update apt-get install g++-arm-linux-gnueabi build-essential
    ->
    apt-get update
    apt-get install g++-arm-linux-gnueabi build-essential

  5. Aline
    April 30, 2013

    Hello

    can i install some packages for arm like broser chromium and libxml2 and after can i transfer this to the arm machine ???

    thank you

  6. cnxsoft
    April 30, 2013

    @Aline
    If your ARM machine runs the same distro I guess so, but then running apt-get install within the ARM device would be so much simpler.

  7. Aline
    May 3, 2013

    @cnxsoft

    i dont have a command apt-get to install in my machine ARM what is the solution ??

  8. cnxsoft
    May 3, 2013

    @Aline
    If you don’t have any package manager such as apt-get, ipkg, zypper, yum… then I suppose you may have to cross-compile the libraries you need.

    Using multiarch on your PC, and copying the required ARM binaries to the target board might also work, but it’s likely you’ll have version conflicts with the libs in your board.

  9. Aline
    May 7, 2013

    Hello,

    when i execute apt-get build-dep -a armel chromium-browser

    i get an error didnt find chromium-browser package

    Reading state information… Done
    E: Unable to find a source package for chromium-brwoser

  10. cnxsoft
    May 7, 2013

    @Aline
    Something weird in this log. Did you type “chromium-brwoser” or “chromium-browser” ? I can see both in the log…

    Do you really need to build chromium? You could just install it with something like: apt-get install chromium-browser:armel

  11. Aline
    May 7, 2013

    @cnxsoft

    My Problem is i need to compile and install the chromium-browser for arm architecture .
    when i run apt-get install chromium-browser:armel i dont have any output to make in the target arm
    if you have idea about haw can i run apt-get install chromium-browser:arme and befor haw i can make the chromium-browser in my target arm

  12. cnxsoft
    May 8, 2013

    @Aline
    This will install the necessary files, but you’re right, it won’t show which files are necessary. Tools like ldd will help find out which libraries are used by chromium.

    You’d better just follow the cross-compilation instructions @ http://code.google.com/p/chromium/wiki/LinuxChromiumArm

  13. Byung Jang
    August 13, 2013

    There is a typo in “deb-src http://archive.ubuntu.com/ubuntu price main universe”. “price” should be “precise”, I think.

  14. cnxsoft
    August 13, 2013

    @Byung Jang
    Thanks for letting me know. I’ve updated the post.

  15. aravind
    October 3, 2013

    Hi , when i’m try install armel packages using apt-get install libjpeg-dev:armel libpng12-dev:armel
    its throwing following error, Can any one suggest me how to resolve those errors

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Note, selecting ‘libjpeg-turbo8-dev:armel’ instead of ‘libjpeg-dev:armel’
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libjpeg-turbo8-dev:armel : Depends: libjpeg-turbo8:armel (= 1.1.90+svn733-0ubuntu4) but it is not going to be installed
    Depends: libc-dev:armel
    libpng12-dev:armel : Depends: libpng12-0:armel (= 1.2.46-3ubuntu4) but it is not going to be installed
    Depends: zlib1g-dev:armel but it is not going to be installed
    openssh-client : Depends: libedit2 (>= 2.11-20080614-1) but it is not going to be installed
    Recommends: xauth but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Leave a Reply

 

 

 

Back to top
mobile desktop