Ubuntu 12.04 on ODroid-X Development Board

Orange Pi Development Boards

Yesterday, Hardkernel released the first version of Ubuntu for ODroid-X development board based on Linux 3.6-rc1 and Linaro Ubuntu Desktop 12.07.

This is still early work, but here’s the current status:

  • Linux Kernel 3.6-rc1 with gcc 4.7.1 Linaro toolchain
  • SMP driven Quad-Core processing
  • PMIC device driver
  • USB 2.0 High-speed Host driver for Exynos-4412 HSIC interface
  • Ethernet + USB Hub device driver
  • LCD display driver
  • HDMI display driver (Very early version and it may have HDMI 1.4a compatibility issues with some monitors)

To do:

  • Audio codec driver
  • eMMC device driver
  • Clock control driver
  • 3D HW-GPU X11 driver (This may need couple of months)
  • Power-off support
  • WiFi module is not working with Ubuntu GUI. Hardkernel Wi-Fi module is not working due to missing driver

There are 2 images: one for LCD display kits, one for HDMI output that can be downloaded via:

Once the download complete, uncompress the image and copy on a 8GB SD card or greater as follows:


where X is the letter of your SD card device on your system. If you’re using a 8GB SD card, there might be some slight differences in size, and you could see the following message:


If you still try to boot Ubuntu with this SD card, the boot will miserably fail to mount the rootfs:


Run the following command to fix and resize the rootfs partition:


Now you’re ready to insert the SD card in the board. Make sure the Jumper to boot from SD card is inserted and start the board. After slightly over 1 minute the Ubuntu desktop should appear.

Linaro Ubuntu on ODroid-X

Boot time would be greatly reduced with initramfs support and a  Class 4 or 10 SD card. I’m using a cheap SD card and the system response is not that great at the moment, although it’s still usable. Hardkernel Wi-Fi module is using Ralink RT5370 chipset, and the driver was not included in this image. I’ve built the driver successfully, but memory allocation error at load time prevent it from working correctly. Without network, I’ve decided not to review Ubuntu just yet.

If you want to customize the kernel, Hardkernel made it available on github. If you don’t have it already installed the Linaro cross-toolchain in Ubuntu:


For other distributions, you can download the latest gcc-linaro binary image, and uncompress it to your system

Now you can retrieve the code and build it:


To copy arch/arm/boot/zImage to your SD-Card, use the following command in your host PC:


and copy the modules to the rootfs.

Support CNX Software - Donate via PayPal or become a Patron on Patreon

19
Leave a Reply

avatar
19 Comment threads
0 Thread replies
0 Followers
 
Most reacted comment
Hottest comment thread
11 Comment authors
Nathaniel JobsRaspberry-Pi is leuk, maar Odroid-X is nog leuker - Win2Lin - van Windows > LinuxHanni HannselChris VarnsverryJesse Recent comment authors
  Subscribe  
newest oldest most voted
Notify of
e8hffff
Guest
e8hffff

Let me get this correct. There is an ARM Linux hardware 3D/OpenGL able driver for Mali400, but projects like Lima are dedicated for open source driver?

menno
Guest
menno

Great board and topic!

Can you test something for me?
Is it possible to test the encoding processor power of this cpu within ubuntu linux on the odroid-x board?

You can install ffmpeg with the command: apt-get install ffmpeg (and this version include all options) and execute:

wget http://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_480p_surround-fix.avi

ffmpeg -i big_buck_bunny_480p_surround-fix.avi -acodec libvorbis -ab 128k -vcodec libx264 -vb 2000k -threads 0 webmout.webm

How many fps does this board encode realtime?

h0ly lag
Guest
h0ly lag

I am looking into getting one of these, or something similar. I know they are intended to be used as mobile development boards but I want one to tinker with as a small computer. Mainly it would be used for streaming HD video from a NAS, but I would also use it to play around as a small linux computer. I was looking at the Pandaboard and the ODROID-X. Pandaboard seems to have a much larger community following and support. Do you see this coming from the hardkernal dev’s and/or community? I am just worried that the things that do not work will not get finished or may take a very long time to be released.

helpinghand
Guest
helpinghand

The rt5370 driver provided by ralink would build, but threw up errors when I tried to load it. To get the wifi working I rebuilt the kernel with the rt2x00 module and rt5370 support.

Paladine
Guest
Paladine

Any updates on audio support?

Is there any possibility of getting 3D console support? Don’t necessarily want to run full-blown X, but I’d like to write some OpenGL apps that can be started from the cmdline.

david
Guest
david

How much wattage consumption does this use in one hr?

Jesse
Guest
Jesse

Would it be easy to run xibo client on this dev board?

Chris Varnsverry
Guest
Chris Varnsverry

Hi cnxsoft,

Can I ask how you worked out exactly where to seek to to dump the zImage?

Thanks,
Chris

Chris Varnsverry
Guest
Chris Varnsverry

Aah, I feel an idiot. Thanks!

cnxsoft :
@Chris Varnsverry
I can’t remember exactly. Maybe I read it somewhere, or I just saw the following lines in the kernel output:
Hit any key to stop autoboot: 0
reading kernel..device 0 Start 1057, Count 16384
MMC read: dev # 0, block # 1057, count 16384 … 16384 blocks read: OK
completed
Boot with zImage

Hanni Hannsel
Guest
Hanni Hannsel

Hello,
is already a new Ubuntu image available?

Has anybody used the WLan Dongle with success?

Thanks for your answer
Hanni

trackback

[…] Ik heb Ubuntu 12.04 op de Odroid-X geïnstalleerd. Dit is de Linaro versie. Kijk maar eens op deze site […]

Nathaniel Jobs
Guest

how to do apply ODROID-A?