Home > Allwinner A-Series, Android, Hardware, Linux > Cubieboard Unboxing and Quick Start Guide

Cubieboard Unboxing and Quick Start Guide

Orange Pi Development Boards

I’ve received another cool board this week with the Cubieboard development board. As a quick reminder, the Cubieboard is the only proper low cost AllWinner A10 development board available, and comes with 512MB/1GB RAM, 4GB NAND Flash, 10/100 MBit Ethernet, HDMI output, 2x USB Host port, 1x USB OTG port, a microSD socket, a SATA interface, an IR sensor and 2 headers to access extra pins such as GPIOs, I2C, SPI,VGA pins, CVBS pins etc…

CubieTech had a successful Indiegogo campaign where the 1GB board was available for $59 including worldwide shipping (and as low as $19 for early birds), and you can now buy it from resellers. [Update: It’s now available with several cables, USB to TTL debug board, and an enclosure for $80 on dx.com]

Cubieboard Unboxing

The board comes with a SATA cable and a USB cable for power. There’s no power supply so you’ll need you own, either using the USB cable provided, or a standard USB power supply connected to the USB OTG port.

Cubieboard + USB Power Cable + SATA Cables

Most of the components are at the top of the board.

Cubieboard (Top) – Click to Enlarge

But the 2 expansion headers are soldered on the back, as well as the line-in connector, the Ethernet PHY and the 4G NAND flash.

Cubieboard (Bottom) – Click to Enlarge

The board is slightly bigger than the Raspberry Pi, but provides much more features, and the 4 mounting holes may also be convenient if you intend to use a casing. The features of the Cubieboard are very similar to the Mele A1000, and it just lacks the casing, remote control and the Wi-Fi module. Composite, VGA & SPDIF outputs are also missing, but those can also be added via the expansion header.

If you prefer unboxing videos, watch haritot video (8 minutes). His kit also includes a transparent casing.

Getting Started with the Cubieboard

First Boot

First, connect USB keyboard & mouse, an Ethernet cable, an HDMI cable and finally the power supply to boot the board.  I used the USB power supply that came with my Raspberry Pi. My board NAND flash came pre-loaded with CyanogenMod with Android 4.0.4 and Kernel 3.0.42+, so after a few seconds it booted in Android. You then just need to go to Settings->Ethernet to enable Ethernet and get an IP address assuming your LAN has a DHCP server. At this point, you are good to go and do whatever you want with the board in Android.

Installing Linux

However, I assume most people actually plan to run Linux on this board. Maxnet’s BerryBoot makes this very easy, and there are 2 methods.

  • Within Android – If you have Android running in your Cubieboard, install the APK from http://get.berryboot.com/, and follow the instructions in BerryBoot Android to install Linux in a microSD card.
  • From a Windows or Linux PC – See instructions below.

I mainly followed the instructions provided on Cubieboard.org to install Linaro Ubuntu ALIP 12.08 on a microSD card.

  1. Insert a microSD card to your computer (preferrably 4GB or higher).
  2. Download “Berryboot-cubieboard-beta1.zip” from http://www.berryterminal.com/doku.php/berryboot_a10 and extract it.
  3. “Burn” the image in the microSD card
    • In Windows
      1. Download “win32diskimager-binary.zip” from https://launchpad.net/win32-image-writer/+download
      2. Run Win32DiskImager.exe
      3. Select “Berryboot-cubieboard-beta1.ddimg” file
      4. Verify that correct disk drive is selected. This is very important. On my system, Win32DiskImager.exe selects my external USB hard drive by default…
      5. Write the file to the microSD card
    • In Linux
      1. Open a terminal window, and type:

        where /dev/sdX corresponds to your SD card.
      2. You’re done.
  4. Insert the microSD card into the Cubieboard, and power on the board.
  5. Follow the instructions provided in BerryBoot user interface.
  6. Select the media device where to install the Linux distribution. In my case, I had 2 choices: mmcblk0 or networked storage (iSCSI SAN). I’m not sure what the second choice does (NAS Boot, See Max’s comment), and selected the microSD card. (mmcblk0)
  7. BerryBoot User Interface Showing List of OSes.

    At this stage, it may tell you a new version is available, and ask you to download it. I did just that, but nothing changed after reboot, and asked me again to download the latest version. So you can safely say “No”.

  8. Select a Linux distribution from the list.
      1. Linaro Ubuntu ALIP 2012.08 (268 MB)
      2. Debian Wheezy Raspbian 2012.09 (430 MB)
      3. OpenELEC r11791 (71 MB)
      4. Puppy Linux Alpha (123 MB)
      5. RaspRazor (624 MB) – Distribution with Qt/Razor 0.4.9 desktop
      6. Sugar OS (473 MB) – Education OS as used in OLPC Laptop
      7. LTSP Thinclient Berry Terminal (22 MB) – Thin client OS to connect to LTSP/Edubuntu server
      8. BerryWebServer (5MB) – Distribution with Lightppd, php 5.3 & SQLite
      9. Memtester (<1MB) – Program to test the memory
    • After selection (I chose Linao ALIP), BerryBoot will download the image, and install it in your chosen storage device.
    • Once the installation is complete, exit the BerryBoot installer to reboot the board, and start your newly installed Linux operating system.

    More Information and Technical Support

    If you want to use/test the latest kernel and bootloader, you can get the Cubieboard hardware pack from the “nightly” builds at http://dl.linux-sunxi.org/amery/sunxi-3.0/latest/. You need to use sunxi-media-create.sh, and the instructions are the same as for a1x-media-create.sh. If you want to keep your existing rootfs, and just update the U-Boot, the kernel, kernel modules and binary libraries, simply run something like:

    Alternatively, you may also want to build your own kernel (and u-boot) for the Cubieboard, which you can do by following the first steps instructions on sunxi-linux.org.

    You can get hardware and software support on Cubieboard Google Group or on #cubieboard IRC channel. However, if you are “playing” around with the kernel or u-boot source code or find bugs, you may prefer to contact sunxi-linux mailing-list which is more geared towards development (most patches go through this list before behind merged).

    1. Magio
      December 9th, 2012 at 11:50 | #1

      Too slow too late too bad … Million user super supported Pi for far less or for me hard kernel odroid U samsung quad core A9 for a few bucks more blows this single Core A8 back to where it came from .. Freescale imx6 quad core what have you to offer as well 😉

    2. December 9th, 2012 at 13:05 | #2

      It all depends what you want to do. Depending on your requirements, the Raspberry Pi is not always the cheapest option. The ODROID-U is very powerful and low cost ($99 inc. shipping), but lacks I/O headers. The Cubieboard is in between in terms of performance and price, it has a small, but active, community behind it, and 2 expansion headers which allow to do everything the Pi does and more.

      The cheapest devboard for Freescale i.MX6 is the Sabrelite i.MX6 (Elements14) at $179. HI-802 dongle ($89) could also be an option, and although it’s not a devboard, the debug pins are easy accessible.

    3. Max
      December 9th, 2012 at 23:16 | #3

      >or networked storage (iSCSI SAN). I’m not sure what the second choice does

      The second option is experimental support for storing the files on a NAS device such as those made by Synology and QNAP.

      Need to create an iSCSI LUN (“virtual disk”) first on your NAS device, and then connect to it.
      It will be presented in Linux as a normal /dev/sda disk.


    4. mac me
      December 11th, 2012 at 03:12 | #4


      As someone that uses a mele A1000 24/7 running as a debian headless media server i have experienced just how weak the linux support (and SOC support) for A10 is and just how small the “community” is .. the pi may be slower but has immense support, right from the SOC maker and addons (the really neat Olimex pi board and uext addons) and you know its going to be around for a considerable time

      I would say in moving my setup from a hacked iconnect to the mele the biggest difference has been the impact of armhf .. much more so than the extra memory or moving one step up the ARM heirarchy.

      I do drool over the odroid U2 at what you get for the price (and its spiffy case/hsf design)

    5. December 11th, 2012 at 08:35 | #5

      @mac me
      armhf should only speeds up your system if your application uses floating-point operations, but for a server I doubt it provides much performance improvements, unless it does some multimedia files transcoding. However, it’s still possible other improvements have been made in the armhf rootfs (but not related to armhf).

    6. mac me
      December 11th, 2012 at 22:17 | #6


      MEDIA server .. the squeezebox media scan (big library) is around 3x faster, now the jgeg resizing element of it i know (from when i tried disabling it on the plug on its own makes a huge diff) quite a few of the plugins use some form of transcoding as well .. so all in all well worth the move to armhf 🙂

      I will have to give my mele to my nephew i think, just cant resist the U2 for the price 🙂

    7. e8hffff
      December 12th, 2012 at 19:00 | #7

      Tried on Mele 2000 and it seems to work. Yet to test the full install. What’s disappointing is still the lack of using nand memory on-board the motherboard. The serious short coming of all A10 development so far for Linux.

    8. December 12th, 2012 at 19:03 | #8

      I think NAND Flash support works, as Pendpod tablets can run Linux from flash, but there may not be an easy to use method yet.

    9. oliverzhang
      January 1st, 2013 at 11:18 | #9

      why I can’t reboot from miniSD’s Ubuntu Linux OS after shutdown Ubuntu(12.08) that download from Ardroid Berryboot.

    10. Philip
      January 2nd, 2013 at 01:59 | #10

      i’d like to see a revision B to the cubieboard with the allwinner A20 processor. It’s a dual core processor with the same pinouts so I assume you could just put on the same board with little or no changes. Let’s see what people come up with in the next couple of months.

      Of course even better would be to have the cortex a7 Allwinner A31 quad core processor, but that would be a new board.

    11. hyojae Kim
      January 2nd, 2013 at 22:16 | #11

      Hello, I read your guide very interestingly.

      May I use your guide on linux-sunxi.org? It’s linked to here and I want to translate into korean users.
      (I will copy and paste into new page of wiki after translating)
      Thank you.

      Happy new year!

    12. January 3rd, 2013 at 08:00 | #12

      @hyojae Kim
      If you want to translate it into Korean please go ahead. A link back to the source is always appreciated.

    13. Pablo Aliaga
      January 4th, 2013 at 16:05 | #13


      First thanks for your usefull guide. I’m a newbie
      I just recived a cubieboard with android, and I want to install the raspbian.
      But I would like to make a backup of the NAND memory or this memory it’s not affected ?

    14. Pablo Aliaga
      January 4th, 2013 at 16:23 | #14

      @Pablo Aliaga
      By the way, I would like to make a couple of things with the cubieboard, as computer vision (opencv) and connection with arduinos (http://arduino.cc/) or IOIO (http://ytai-mer.blogspot.com.es/2011/04/meet-ioio-io-for-android.html).

      I would like to make a blog with every step, and I ask also permision to translate to spanish your page, and give reference to this page.
      (althoug I want to make the blog in both languages )

    15. January 4th, 2013 at 17:39 | #15

      @Pablo Aliaga
      With Berryboot A10, Linux is installed in the microSD card, so it won’t affect the Android firmware loaded in your NAND flash. The Android image should also be available for download somewhere on cubieboard.org or sunxi-linux.org.

      Yes, anybody who wants to translate this page go ahead. Please just link back to this page if you do so.

    16. Pablo Aliaga
      January 5th, 2013 at 23:09 | #16

      Hi, again.

      I started to make a blog to put all I’m learning about cubieboard on it, I put a couple of links to your page.

      This is the url http://cubieboard.blogspot.com.es/
      If you have any comment, don’t hesitate to let me know.


    17. January 6th, 2013 at 10:29 | #17

      @Pablo Aliaga
      I can’t read Spanish, but there seems to be a lot of interesting info.
      You may want to add a link to your blog to http://linux-sunxi.org/Cubieboard/es. I’m sure this would help others.

    18. Troels Tornmark
      January 26th, 2013 at 04:54 | #18

      Newbie to restrictions analysis of Linux distros, but anyone tried a Chromium OS build on the Cubieboard yet? If so, what method worked?

      • January 26th, 2013 at 08:54 | #19

        I haven’t tried. Since it boots and runs on the Raspberry Pi (http://blog.hexxeh.net/), it should be possible to run on the Cubieboard. However, Chromium OS needs proper GPU accel to be usable, which is currently not the case on the Raspberry Pi, and probably not yet the case for AllWinner A10 devices either.

    19. cocopuff
      January 26th, 2013 at 14:37 | #20

      I have this same problem. Can someone direct me to a solution?
      I don’t have win 32 bit to image a disk to the sd. I used the android berryboot to install the images. The images run fine, I was able to access both ubunto and debian. However, as soon as I shut down, I can’t boot up from the SD card. I have to boot into android using the mini usb power from my computer. I can’t use the provided usb to 5v adapter. Thanks.

    20. cocopuff
      January 26th, 2013 at 14:42 | #21

      @Troels Tornmark
      I have run chromium under ubuntu after initial image flash. After I shutdown. I can’t boot up to any os except for android through mini usb with the sd card ejected. If I keep the card it, android doesn’t even load.

    21. January 26th, 2013 at 15:02 | #22

      Do you have access to the serial console (via a TTL to USB debug board)?

    22. 90dfr3y
      February 22nd, 2013 at 17:33 | #23

      Hi, I tried your steps, but when I select Linaro Ubuntu, it only download up to 13%. I kept on trying, but still the download would not complete.
      Do you know what could be the problem? Are there other ways to install Ubuntu on Cubieboard?
      I appreaciate any of your help/recommendations.

    23. Ruediger Leibrandt
      April 19th, 2013 at 19:55 | #24

      Congrats, @cnxsoft !
      I like the Cubie board very much for it’s SATA connector, and indeed, and in regards to @magio , the cubieboard is for advanced hardware hackers that feel to limited on the Pi and can’t make much from the ODROID or don’t need the latters power.
      However I agree with @Philip – the A20 would be a major improvement, permitting a smooth use of a full blown desktop like KDE – at least by pure calculation and comparision to my 1GHz AMD netbook I think it should be usable.

      For those dedicated to design cases – why not make a case for the Cubieboard that can hold a 2,5″ SATA drive alongside the cubie?

      And… I’d like a manual for Dummies like me on how to get a real Debian armhf ( and not Raspian ) to run from the cubieboard’s NAND.

    24. wao
      May 15th, 2013 at 07:35 | #25

      I have installed this image: cb-sdcard-1.1-linaro-quantal-alip-20130227-290.img on a micro SD Card…
      It boots with no issues… When I attempt to set up the Wireless Adapter, it asks for a password.
      I’ve been looking for days.. where do I find the elusive Administrator’s password????

    25. May 15th, 2013 at 09:19 | #26

      Linaro rootfs normally boot with user linaro (password: linaro).

    26. Sky
      July 6th, 2013 at 01:54 | #27

      And than you want to use SATA drive…

    27. didier
      July 16th, 2013 at 22:45 | #28

      le password est cubie

    28. Alvin
      July 23rd, 2013 at 09:30 | #29

      I had written berryboot-cubieboard-beta6.zip and inserted the microSD card into my Cubieboard A20, and power on the board. However it just unable to boot up.

      My A20 boot up to Android only when I had removed the microSD.

      Please advice why my A20 unable to boot up from my microSD.

    29. Frank
      August 30th, 2013 at 22:32 | #30

      Hi I have the same problem.
      Do you have a solution in the meanwhile?

    1. December 22nd, 2012 at 02:11 | #1
    2. February 21st, 2013 at 11:45 | #2
    3. March 6th, 2013 at 17:25 | #3
    4. March 7th, 2013 at 14:58 | #4
    5. March 24th, 2013 at 11:15 | #5
    6. May 9th, 2013 at 04:45 | #6
    7. June 19th, 2013 at 17:40 | #7
    8. July 8th, 2013 at 10:50 | #8
    9. July 12th, 2013 at 10:55 | #9
    10. July 26th, 2013 at 09:46 | #10
    11. August 22nd, 2013 at 11:10 | #11
    12. May 11th, 2014 at 19:10 | #12
    13. May 20th, 2014 at 23:44 | #13
    14. July 16th, 2014 at 23:00 | #14
    15. August 6th, 2014 at 07:12 | #15
    16. January 11th, 2015 at 06:42 | #16
    17. January 20th, 2015 at 08:53 | #17
    18. February 7th, 2015 at 01:00 | #18
    19. March 16th, 2015 at 00:58 | #19