Wandboard Quad Unboxing, Getting Started with Android and Linux (via The Yocto Project)

After my review of the Wandboard Dual in February, I’ve now received Wanboard Quad development board  powered by Freescale i.MX6 Quad Cortex A9 processor, with 2 GB RAM, HDMI output, Gigabit Ethernet, and SATA. The board is available from several distributors including Mouser ($139), DigiKey ($144.38) and FutureElectronics ($125). I’ll start by showing some unboxing pictures of the board, as well as pictures of Wandboard Dual and Quad side-by-side. Then I’ll explain how to install Android and Linux on the board, build the images from source, run some benchmarks, and test different features.

Wandboard Quad Unboxing

Ive received the board via UPS in a large box that contained the package below. This is exactly the same as Wandboard Dual, except for the sticker.

There’s just the board inside the package, and it would just look like Wandboard Dual with all connectors on the top, and the EDM module at the back, were it not for the massive heatsink to keep i.MX 6Quad cool. One other key difference is that the SATA connector is populated, and you can connect an hard drive. Since there’s no paper documentation, you may want to download and read Wandboard Quad user’s manual and schematics PDF for details.

Wandboard Quad (Click to Enlarge)
Wandboard Quad (Click to Enlarge)

I’ve taken a few picture with Wandboard Quad and Wandboard Dual side and side, and as expect both baseboards are virtually the same.

Wandboard Dual vs Wandboard Quad (Click to Enlarge)
Wandboard Quad (Left) vs Wandboard Dual (Right)  (Click to Enlarge)

The older board (Revision A0) has been replaced with Revision B1 that fixes SPDIF wiring, updates MIPI voltage updated, slightly change USB circuitry, and adds an additional resistor pad option for playing with different I2C channels for audio/HDMI. Another difference is that the fuse is now easily replaceable without soldering involved. I assume all new Wandboard Solo/Dual/Quad now ship with Rev B1. Note that if you’ve got an older revision, there’s an hardware fix for SPDIF.

EDM Boards - Wandboard Dual vs Wandboard Quad (Click to Enlarge)
EDM Boards – Wandboard Dual vs Wandboard Quad (Click to Enlarge)

I’ve removed the heatsink, and taken the EDM module out of the baseboard, and there’s very little difference between the dual and quad modules.

EDM Module - Wandboard Dual (Left) vs Wandboard Quad (Right)
EDM Module – Wandboard Dual (Left) vs Wandboard Quad (Right)

On the back of the module, the key differences are the memory chips: Hynix H5TQ4G63MFR (4Gbit) on the quad version, and Hynix H5TQ2G63BFR (2Gbit) on the dual version. On another note, I can often see people ask if they can buy the EDM module separately, and the answer is yes. The distributors I’ve mentioned at the top of the post sell the modules in pack of 10.

I also tried the casing and Wi-Fi antenna I got with my Wandboard Dual board, and assembly is not a problem despite the extra heatsink. The antenna cable will touch the heatsink, but I’ve been told it’s not an issue, as it’s isolated.

Installing Android 4.2.2 on Wandboard Quad

Let’s prepare a micro SD card with the latest Android 4.2.2 image. For optimal performance, make sure you use a Class 10 SD card (I’m using ADATA 16GB Class 10 micro SD for testing).

The installation is just the same as with Wandboard Dual, just a different image. Download and extract the file:

wget http://www.wandboard.org/images/downloads/android-4.2.2-wand-quad-20130621.zip
unzip android-4.2.2-wand-quad-20130621.zip

There are 4 files in the archive: The image itself, a short changelog, win32diskimager, and “Source_and_Build_Simple_Howtos.txt”, an how-to explaining how to build Android from source, install Google Play, and flash the image to an SD card.

Insert a micro SD card in your Linux PC (8GB or greater), umount the partition, and flash the image:

The second line is optional, but I had to do this, or Ubuntu would just remount the partitions, and the final dd would fail. I just run “sudo dd if=/dev/zero…” for a few seconds and press control+C.

If you need Google Play, there are a few more steps. Remove and re-insert the micro SD card, download and extract gapps-jb-20130301-signed.zip, and copy Google Play to the micro SD:

If you’re using Windows, you can use Win32DiskImager to flash the image, and adb.exe to transfer Google Play framework to the board, but since you’re using a Linux based system, I really recommend you install Linux, either in dual boot configuration with Windows, or as a virtual machine (e.g. Virtual Box).

Create an Android 4.2.2 Image from source for Wandboard Quad

I haven’t tried this myself, but those are the steps mentioned in the How-to:

Now copy google gapps-jb-20130301-signed.zip to ~/wandboard/Build, and start the build:

Lunch will take a while :), and once this is done you are ready to create an SD card with the right partitions:

and copy the binaries:

You’ve now built and installed Android 4.2.2 image for Wandboard Quad from source all by yourself.

Android 4.2.2 in Wandboard Quad and Antutu & Quadrant Benchmarks

Let’s insert the micro SD in the EDM module slot (under the heatsink), connect an HDMI, Ethernet and serial NULL modem cable, some input device (Mele F10 receiver in the picture below), and the power supply. The most natural way may be to put the heatsink on the table, and have easy access to the connectors as shown below.

Wandboard Quad Will Overheat in This Position
Wandboard Quad Will Overheat in This Position

But don’t do that, it will prevent proper heat dissipation, and your board will overheat and hang. Instead make sure the heatsink points to the ceiling as shown below. In this configuration, I’ve measured 52 degrees Celcius at idle time, and 56 degrees Celcius during benchmarks by pointing an IR Thermometer to the heatsink.


If you don’t have a DB9 serial port on your PC, you’ll need an RS232 to USB converter to access the serial console. via programs such as Putty or Minicom.  This is what the boot log looks like for Wandboard Quad.

As with Wandboard Dual, Android is really smooth as long as you use a fast SD card, the system appears to be stable, but there’s still more work to make it a fully functional image, as I encountered a few issues:

  • No HDMI audio on my system
  • Bluetooth can be enabled, but it failed to find my smartphone, and the system is not currently compatible with Sixaxis (to connect PS3 controllers)
  • Video hardware decoding does not work (at least for H.264 and MPEG2).

However, Antutu and Quadrant benchmarks show some impressive progress compared to other i.MX6 Quad / Android 4.0 solutions I tested a few months ago.


In this benchmark, Wandboard Quad is equivalent to Google Nexus 7 based on Tegra 3, and interestingly 3D performance is impressive, whereas it was dismal in Hi802/GK802 mini PC when I tested it, so there seems to have been some dramatic software improvements both with Android (4.0 vs 4.2), and Vivante drivers. The table below shows the performance difference between Wandboard Dual/Android 4.1.2, Hi802/Android 4.0.4 and Wandboard Quad/Android 4.2.2.

Antutu 3.x Tests Wandboard Dual
Android 4.1.2
Android 4.0.4
Wandboard Quad
Android 4.2.2
Total 6190 8516 12615
RAM 1032 1619 1477
CPU Integer 1299 2490 2514
CPU float-point 1120 1838 2200
2D Graphics [720×1232] 477 [1280×672] 733 [720×1232] 929
3D Graphics [720×1232] 1771 [1280×672] 1272 [720×1232] 4901
Database IO 280 245 315
SD card write 97 115 87
SD card read 114 204 192
CPU frequency (x2) (x4) 996 MHz (x4)
Date 2013-06-10 2013-01-18 2013-07-24

Quadrant benchmark shows Wandboard Quad (3402) to be a bit slower than Transformer Prime mainly due to the processor benchmark. Wandboard Dual got 2305 points.


Following the good GPU results, I tried a 3D game that may be challenging to render smoothly: Real Racing 3. The game  is actually very smooth, and at first it looks much better than the RK3188 platforms I’ve tried, but closer inspection shows the game has decided to use a lower quality level… Nevertheless, 3D performance appears to be now much better than when i.MX6 Quad was first release with Android 4.0.4.

Building Linux with the Yocto Project on Wandboard Quad

There are now more and more Linux distributions for Wandboard (Quad): Ubuntu 11.10, Ubuntu 12.04, images built with the Yocto Project or buildroot, Timesys Linux (Wandboard Quad support is work in progress), and recently an XBMC Linux image has popped up. Wandboard boards are also part of mainline U-boot, and will be supported, at least partially, in Linux 3.12.

Since I have already shown how to install Ubuntu 11.10, and build the kernel from the SDK for Wandboard Dual, and using Ubuntu 11.10 or 12.04 on Wandboard Quad is basically the same with a different image, I’ll try something different today with the Yocto Project which allows you to build images fully customized for your project. I’ll mainly follow the instructions on elinux.org.

First let’s get the repo tool:

Add it to the path, and retrieve the source code from Freescale Yocto BSP on github.

Note that we use the development branch (master), because Wandboard Quad was not available for Yocto 1.4 (dylan) release.

Now set the machine to Wandboard Quad, setup the environment, and start the build for a minimal image:

Since all of the sources are downloaded from the Internet and built from scratch (including things like the toolchain), it may take a while depending on your Internet connection, and the performance of your build machine. The full process took three hours on my machine (AMD FX8350 with 16GB RAM). Subsequent builds are much faster.

Once the build is complete you can find the image in ./tmp/deploy/images/core-image-minimal-wandboard-quad.sdcard (28 MB). Just flash it to a micro SD card (32 MB or greater) to try it out:

Replace /dev/sdX by your actual micro SD card device name, e.g. /dev/sdc. I have a USB hard drive attached to my build machine, so I always run lsblk, before running dd in order to double check the device, and avoid losing my precious data, and hating myself for the rest of my life… Once this is done, you probably want to resize the rootfs partition to make full use of your SD card storage capacity with tools such as gparted.

Finally insert the micro SD card into your Wandboard Quad, boot it up, and access the terminal via an HDMI monitor, or a serial console:


Here’s the boot log for the minimal image built with Yocto:

If you want an image with a desktop environment, you can run bitbake core-image-sato instead (See SATO UI screenshot). In theory, It’s also possible to build a custom image with XFCE by adding sources/meta-openembedded/meta-xfce to the list of layers, as well as packagegroup-xfce-base, packagegroup-xfce-extended and packagegroup-xfce-multimedia to the list of package groups, either via the command line, or hob, Yocto’s graphical user interface, but for some reasons the build failed when I tried to build an XFCE image via hob for the Wandboard Dual a few weeks ago. I believe the pre-built Yocto image for Wandboard Quad does indeed include XFCE (TBC).

Share this:
FacebookTwitterHacker NewsSlashdotRedditLinkedInPinterestFlipboardMeWeLineEmailShare

Support CNX Software! Donate via cryptocurrencies, become a Patron on Patreon, or purchase goods on Amazon or Aliexpress

ROCK Pi 4C Plus

53 Replies to “Wandboard Quad Unboxing, Getting Started with Android and Linux (via The Yocto Project)”

  1. That’s some heatsink. The imx6 is a bit of a fail when it comes to heat. I’m yet to see a device that runs at the quote max speed of 1.2Ghz presumably due to heat.

  2. Hi,

    The heatsink is made this size to have an easy to assemble solution and avoid the creation of additional holes in the PCB. It therefore uses the identical holes as the EDM module.

  3. wandboard :
    The heatsink is made this size to have an easy to assemble solution and avoid the creation of additional holes in the PCB. It therefore uses the identical holes as the EDM module.

    Are there any imx6 quadcore soc for mobile phones?
    Because soc from Wandboard is sooo big

  4. Could somebody please benchmark the SATA connection with some serious SSD, all I have seen is people have tested those with some bargain-bin three+ generations old SSDs, that are not even close to the performance on the current generation stuff.

    Yes, the i.MX6 SATA is only 3.0Gbps, but even so, do not use some lousy/ancient JMicron/SandForce crud that nobody should buy/use these days.

    Have not found a single ARM SATA benchmark that uses any of the fast SSDs around these days, hard to get an mental image of the raw data bandwidth speeds that can be achieved with the ARM platform (and is the internal data busses the bottleneck). 🙁

    ps. hopefully Samsung has fixed their incompatibilities between Exynos 5 series and Samsung 840 SSDs on Exynos 5420, that was a silly thing to not verify before putting it on sale. 🙂

  5. Thanks for all the info about wandboard quad version. I just got the board and about to play with it myself and this article save me a lot of time.

  6. @anon
    Agreed, but it’d also be good to know this runs in a ‘nettop’ configuration with Linux on a SATA HDD? & how does it compare with low end Atom mini PCs, which are available in a similar price bracket, for various applications? Is there any prospect of getting a more recent mainstream distro going on it?

  7. hi,

    interesting board, but i would like to get more info about it.
    – is this real SATA (not usb2sata) and as others already asked: what about a sata benchmark?
    – it is also important to know anything about power consumtion. how much watts does the board consume in idle mode and how much under full load?
    – can we run linaro as well on this board (i think we can, but may there be any problems with drivers?)
    – what about using the gpu for transcoding (actually i am not aware of any arm soc that supports hardware accelerated transcoding under linux using ffmpeg – this would be great for a small htpc)

    this said, i would really like to see a comparision table of all devices you test that contains infos about: power consumtion, cpu speed (benchmark), gpu speed (benchmark), disk speed (benchmark if sata connector is available), linux (linaro) support, linux drivers (what works and what does not work), connectors (vga,hdmi,sata,ethernet,wlan,…) – this would give an interesting overview, if you would update this table whenever you get a new device.

  8. @mehre
    1. Yes, it’s real SATA. You can also check the schematics so it’s easy to verify.
    I don’t have spare SATA drives, let alone on the latest SSD…

    2. I haven’t made the cable for measurement with a multimeter, so even though it’s not ideal (e.g. power supply dissipation) I’ve done a quick test using a “kill-a-watt” equivalent instead:
    * Android Idle: 3.2 to 3.8 Watts
    * Antutu CPU: 6.6 Watts
    * Antutu RAM: 5 Watts
    * Antutu 2D (Bouncing Androids): 5.2 Watts
    * Antutu 3D – 7 to 8 Watts

    3. Linaro rootfs should be easy, but you’ll lose GPU and VPU support without some extra work.
    4. Trancoding: In theory it should be possible. In April, I started writing a post about gstreamer on i.MX6, but did not complete it, because some parts could not work. You may want to check at this post to see what’s possible with gstreamer at http://boundarydevices.com/gstreamer-camera-streaming-on-i-mx6/

    A comparison table is always nice, but this can be very challenging to maintain and update in details. Just a post like the one above took me over 10 hours to complete.

  9. @cnxsoft
    thanks for the info!

    yeah, i understand it’s hard to maintain such a comparision table. actually you could avoid the update challange if you just a column with date of your test and just fill in what you know for each new device. this table would be incomplete and outdatet, but i think it would be useful anyway. if specs of a device fits and a user is interested in the device he could search for this missing info and in best case he reports back to you 😉 – if not it saves time anyway for instance if i need a device with 1GB ethernet i could rule out many devices…

    just think about it

  10. @onebir
    Unfortunately you cannot boot directly off the iMX6 SATA, but if you write the uboot on other devices (NAND/MMC/SD), then the rest can be on the SATA device, at least that is with the Boundary Device i.MX6 boards, and why would the Wandboard makers change that?

    Of course you need to check it from them to be sure, personally I do not have any i.MX6 boards/devices.

    About distros, of course you can install pretty much any of the distros on i.MX6 devices, all you want to do is find an armhf version (that pretty much all are currently), and i.MX6 platform is a lot more open for Linux community, so you can find all kind of help all over for them, much better than for those Asian ARM manufacturers.

    Only major thing that is not so great thing going for the i.MX6 is of course the awful Vivante GPU that has no FLOSS drivers/support, just nasty binary hacks. 🙁

  11. @anon
    Some i.MX6 boards (e.g. Sabrelite) have a small 1 or 2MB SPI NOR Flash, and I guess you could boot from that to SATA. In some ways, it’s a little like the BIOS for x86.

  12. You do mention that sound over HDM doesn’t work but were you able to get multi channel sound via SPDIF in android and/or linux?

  13. @cnxsoft
    Yes, you can indeed store the u-boot into that SPI NOR Flash (it uses SPI signaling, thus is the same thing as slow SD mode that uses 1-bit lanes to each way, not 4 parallel bits of normal SD usage, let alone 8-bit MMC), so it shows as an SD card to Linux kernel, so same difference from software’s point of view.

    At least on those Boundary Device boards the u-boot location is determined with dip switches, have not looked up how it is done in Wandboard, but I would think the exact same way (there are actual physical signals for selecting that in the processor itself).

  14. @Michal S
    Oh wow, had not googled for anything Vivante-related for a while (maybe in 2012?), so did not even know about that one, very cool…

    Still at pre-alpha it seems (and no GC2000 support for the i.MX6 Quad), so actually very close to what the limadriver was planning to do.

    It is still pretty sad that the lima stuff is still not getting too much attention from others developers beyond Luc himself… Too bad I have no time for it either, maybe after I finish my clustering stuff, then I can start to really getting into driver coding again. 🙂

    Of well, all those different framebuffer-based drivers sure would need to pull into a singular effort to get them pushed into the mainline kernel, that would certainly help things along a lot, no need for 3D acceleration at start, that could always come later on.

  15. @S
    I haven’t check that, as I don’t have hardware. I’ve tried to buy a home theater system from Chinese websites once, but strangely I could not find any. Maybe it’s too large to ship, but somehow I expected to find a system with small speakers.

  16. > In this configuration, I’ve measured 52 degrees Celcius at idle time,
    > and 56 degrees Celcius during benchmarks by pointing an IR Thermometer to the heatsink.

    That is a blank aluminium heatsink.
    Due to reflection properties you don’t get proper readings with IR thermos!
    Only works with BLACK heatsinks.
    As a quick and dirty solution you might try to use some black isolation tape
    and stick it flat onto large surfaces – but can be tricky with such a fin heatsink…
    (note that the IR thermo takes AVERAGE of a rather large field of view so you better
    put it very very close)

    Another factor is WHERE at that large heatsink you pointed.
    You should do it in the center.

    Yeah tricky and complex 😉

  17. @NoNoCat
    Thanks. I had read about that, and tried some black tape. But the temperature readings were about the same. Obviously with this type of heatsink it’s difficult to properly transfer the heat to the black tape since it’s not in full contact.

    I actually moved the thermometer over the heatsink, and could just see 1 or 2 degrees differences between different places. And 55 degrees looked like OK, based on “hand” measurements 🙂

    The thing I don’t know is if bright surfaces over or under report the temperature readings.

  18. Well that is weird that this does not change – maybe the heatsink is coated somehow and not actually a blank one? Is it conductive when you measure resistance with a multimeter (without pushing too hard!)?
    I get lower readings with the IR thermo I have here on blank type of heatsinks and it rises drastically when I use tape on a small flat(!) area. Not on top of the fins of course.

    Maybe you can try to check the internal temp sensor of the chip to see if it is reasonable. It is a file somewhere in /sys/devices/virtual/thermal … or so that you can cat.
    The die temp should be higher than heatsink temp of course.

  19. @cnxsoft

    after all i think i will buy this board even i wanted to wait for the CompuLab Utilite because of it’s better connectivity and it’s nicer design, but checking prices of other CompuLab devices i think the price will be much higher as i guess the base version for 99$ will be only single core with 512MB or 1GB RAM.

    after some research i think the i.mx6 boards will be the first arm-boards that can be used for vpu transcoding on linux and i hope it really works – fingers crossed

    i still have some questions:

    you said “Linaro rootfs should be easy, but you’ll lose GPU and VPU support without some extra work”
    shouldn’t it work if i use the kernel+kernel modules provided by freescale together with linaro rootfs to get VPU support? or do i need anything else compiled for linaro in order to get VPU support?

    actually they provide an Ubuntu 12.04 LTS preview image, with 3D multimedia enabled, so i assume VPU transcoding should work with this image (would be nice, maybe you can test this?)

    there seems to be only a sata data connector on board, so an externel power supply for the sata device is required?

  20. @mehere
    I don’t really know how to get GPU and VPU support.

    If it’s just 3D multimedia in Ubuntu 12.04, then it does not look like VPU is enabled, so no transcoding yet.

    I think there’s a discussion on the mailing list about powering up the hard drive.

  21. anon :
    Still at pre-alpha it seems (and no GC2000 support for the i.MX6 Quad), so actually very close to what the limadriver was planning to do.
    It is still pretty sad that the lima stuff is still not getting too much attention from others developers beyond Luc himself… Too bad I have no time for it either, maybe after I finish my clustering stuff, then I can start to really getting into driver coding again.

    IMO adding GC2000 could be quick. It differs from 800 and 880 by few registers and extra pixel. GC880 even worked with GC800 driver because there is backward compatibility in hardware! I don’t have GC2000 and laanwj is working on other stuff. Finish your clustering stuff and join 🙂

  22. @cnxsoft

    well, i just read this:

    The following images are marked as preview and use Freescale latest LTIB-4.0.0 drivers. 3D, multimedia have been enabled. Performance on WBSOLO is quite nice compared with the older image.

    Ubuntu 12.04 LTS images.

    and according to this
    vpu and gpu support should work with ltib drivers…
    i just don’t know if they user the X-Windows drivers for the ubuntu preview image or the version without x-windows support

    maybe you can test the preview image and write an article about it or even better record a nice video and show us how powerfull (or not) ubuntu is running on this nice board – i did not found any videos so you can be the first… 😉 and testing if gstreamer transcoding works, would be a nice bonus for your readers 😉

    at least it looks very promising!

  23. @NoNoCat
    The other day, I did put the black tape on top of the fins (there’s no large enough flat zone), and waited a few minutes for heat to transfer… It’s probably not a good idea…

    The heastsink is definitely conductive (Multimeter shows 0 Ohm)

    I measure temperature again today with the IR thermometer without tape (38 degree Celsius), and also checked the value in /sys/devices/virtual/thermal/thermal_zone0/temp which strangely is also 38. I wonder if that number is in Celsius or we need to convert it.

    There are actually 4 more temperature “points” in the directory:
    cat /sys/devices/virtual/thermal/thermal_zone0/*temp

    temp (38), as well as trip_point_0_temp, trip_point_1_temp, and trip_point_2_temp, but those last 3 never change。

  24. What is the Ambient temp in your area?
    The deviation should get larger with higher heatsink temp – lower temps are usually fine as the ambient is reflected in the aluminium!
    Maybe your IR Thermo is calibrated for aluminium reflectivity (better models allow for adjusting that) – but that would make most other materials readings wrong 😉
    May I know which type it is?

    Yep that temp reading is in Celsius.
    trip_point_* are the thresholds when thermal throttling takes place and it clocks down to reduce heat and protect itself. All modern CPUs do that (which btw. may affect benchmarks especially on mobile devices without good heatsinks).

  25. Ah forget it I just saw that you put a link to the thermometer model you used.
    Emissivity: 0.95 (pre-set)

    Aluminium is in the 0.07 – 0.7 range depending on surface treatment.
    Very strange that you get good readings with that thing.

  26. @NoNoCat
    Just as reference, when I point the device to my head it read 35 degrees, boiling water: 97 degrees, freezer: -14 degrees. So it may not be extremely accurate, but I guess it give a good range.

    We’ve got “cool” weather today, about 26 degrees C in the room.

  27. @anon
    It’s not exactly want you want, but ODROID-XU board has been benchmarked with OCZ’s Vertex3 128GB SSD via a USB3 to SATA adapter. Command lines and results:

    Test Root File System : Linaro Ubuntu with Linux Kernel 3.4.5
    Read Test Command : dd if=./test of=/dev/null bs=1M count=1000 iflag=nocache oflag=nocache
    Write Test Command : dd if=/dev/zero of=./test bs=1M count=1000 iflag=nocache oflag=nocache conv=fdatasync

    Test result
    Write Speed : 190 MB/S
    Read Speed : 151 MB/S

    Source: http://com.odroid.com/sigong/blog/blog_list.php?bid=153

  28. Hi!
    I added sources/meta-openembedded/meta-xfce to sources/base/conf/bblayers.conf.

    Where do i need to add the package groups: packagegroup-xfce-base, packagegroup-xfce-extended and packagegroup-xfce-multimedia ? so that bitbake core-image-minimal includes it?


  29. Hi, cnxsoft,

    Thanks for this post.
    I’m about to buy a WBQUAD for fun, very excited.

    One more question I’m wondering.
    The retailer tells me there is no power supply adapter shipped together with the wbquad box, so I must buy a power supply by myself.
    But I do not know what kind to buy? I know it should be 10W 5V, but how many pins should be? 2-pin? or 3-pin adapter?

    Could you give me some guidance on this to help me out ?
    Thank you, thank you so much in advance.


  30. @cnxsoft

    Thank you for your reply.
    Actually, I’ve checked that website out a few days ago.
    I’m puzzled about the “power supply with a positive center pin”.
    Does that mean only 3-pin power supply should be used instead of 2-pin?
    Also, it seems the barrel connector’s diameter shold meet that requirement too, doesn’t it ?

    From what you said, it seems both 2-pin and 3-pin are OK, could you share me with a website for your power supply please?

    Thank you.

  31. cnxsoft :
    They told about the jack you connect into the board. The outside should be ground, and inside +5V. I guess most power supply are like that, but you can check with a multimeter to make sure. The important part is the diameter of the jack, although you should also be able to use an adapter.
    I did not buy my power supply online. It’s shown in the list @ http://www.cnx-software.com/2013/02/14/electronics-shop-in-thailand-what-will-33-buy/

    I’m in China Mainland, as you know, the power supply used in China is not the same with the ones in Europe or America, So, I think I should take care of this issue, or, the board may be smoked …

  32. @cnxsoft

    Ok, I see.
    I misunderstood just now.

    You mean you do the power supply by yourself with the cost $33.
    That sounds great.

    Maybe I also could do it, right?

  33. @shawnbai
    No. That’s not what I meant. In that page you can scroll down and see the $10 power supply I used (Viper something).

    You could probably buy the board first, then go to the shop with the board to find and try the power supply before purchase. Just make sure the ground is outside first.

  34. @cnxsoft

    Yes, I have noticed that.
    Since only the jack and 5V2W must be ensured, I have found the website to buy the power supply adapter.
    On that website, 2.5 x 5.5 pin connector specification of the power supply adapter is beging sold, outer(V-), Inner(+5V), so I guss, this one is what I need.

    Thank you again, cnxsoft.

Leave a Reply

Your email address will not be published. Required fields are marked *

Khadas VIM4 SBC
Khadas VIM4 SBC