Raspberry Pi 4 is Now OpenGL ES 3.1 Conformant, Work on Vulkan Drivers Started

Raspberry Pi 4 Model B 4 was launched last June with a new Broadcom BCM2711 SoC featuring an upgraded Videocore VI GPU supporting OpenGL ES 3.0 graphics API.

Some drivers only implement a subset of OpenGL 3.0/3.1 3D graphics standard defined by the Khronos Group, and the good news is that Raspberry Pi 4 Model B is now OpenGL ES 3.1 conformant, as it passed all tests in Khronos conformance test suite.

That means that any Linux programmed using OpenGL ES 3.1 API should work out of the box, although in some cases there may be issues/bugs that were not detected by the test suite.

The Vulkan API is an evolution of OpenGL ES API that is meant to be more power-efficient as it better makes utilize of multi-core processors. The Raspberry Pi Foundation has also started working on Vulkan support for Raspberry Pi 4, and while the driver is still very much work in progress the basic triangle demo (i.e. the “Hello World!” of graphics programming) is now working.

Click to Enlarge

The Raspberry Pi Foundation has outsourced graphics development work to an open-source consulting company based in Spain called Igalia and notes full support will take much longer, as the company has only worked on the Vulkan driver for a few weeks so far. Eben Upton mentions it will take a while before people can try out Vulkan on the Pi:

Once we have something suitable for tire-kicking we’ll do another post with instructions. Probably six months or so.

At that time, they may be a release of the code running on the Arm core as well, but it will take much longer to get Vulkan conformance.

Support CNX Software - Donate via PayPal or become a Patron on Patreon
Subscribe
Notify of
guest
1 Comment
oldest
newest most voted
m][sko
6 months ago

Let’s pray for working(with gpu acceleration) ubuntu 20.04 on raspberry pi 4

Advertisements