How-to Install Ubuntu on Allwinner A80 Powered pcDuino8 and A80 OptimusBoard

Last month, pcDuino released Android 4.4 and Ubuntu images for pcDuino8 board powered by Allwinner A80 octa core processor, and since it’s the same board layout as A80 OptimusBoard, I decided to try it out, but it failed as the update script would try to flash it to a partition that’s too small for the root file systems. But last week, Ian Morrison and Minidodes gave it another try, and successfully booted Ubuntu, or more exactly Lubuntu, on A80 OptimusBoard.

Lubuntu Screenshot in A80 OptimusBoard
Lubuntu Screenshot in A80 OptimusBoard

Both their screenshot reports sun9i platform in /proc/cpuinfo, so that’s definitely Allwinner A80, but only one core is shown. I’m not sure if it’s because the other are idled and don’t show, or for some reasons, the kernel only supports one core at this stage.

Anyway, here’s how they did to install Lubuntu:

  • Flash the kernel (pcduino8_kernel_livesuit_20141008.img) with PhoenixCard or Livesuit first. See instructions to use Livesuit with A80 OptimusBoard.
  • Extract the rootfs (pcduino8_ubuntu_20141008.rar) to an SD card or USB flash drive. There should be two files: pcduino8_ubuntu_20141008.img and update.sh.
  • Boot the board, but don’t insert the SD card or USB flash drive yet.
  • update.sh script will attempt to copy the rootfs to /dev/nandd, but there’s not even space, so it will fail. So instead login as root (no password) and kill update.sh: ps ax | grep update, kill “pid”.
  • Now connect the mass storage device to pcDuino3 / A80 Optimusboard, and mount it to /mnt
  • Flash the Ubuntu image to /dev/mmcblk0p1:
  • Now reboot the board and interrupt the boot sequence to enter U-boot, and use ‘env’ to change the bootargs with mmc_root to /dev/mmcblk0p1 and init to /sbin/init.
  • Save the environment with env save, and boot the board to start Ubuntu.

I have not tried (yet), since I’m busy with other hardware, so let me know if the instructions above need improvement. [Update: the procedure may depend on the Android firmware / flash partition, as described in the comments section]

On a side note, Merrii released some new SDKs for A10, A20, A31, and A80.

Support CNX Software - Donate via PayPal or become a Patron on Patreon

16
Leave a Reply

avatar
16 Comment threads
0 Thread replies
0 Followers
 
Most reacted comment
Hottest comment thread
8 Comment authors
erikMK80 Linux Edition is an octa-core Ubuntu mini PC - LiliputingvpeterMRB3D Graphics Acceleration in Linux on Allwinner A80 based Cubieboard4 Recent comment authors
  Subscribe  
newest oldest most voted
Notify of
Toto
Guest
Toto

For the CPU, there is the same behavior on the cubieboard2 with archlinuxARM, only one cpu is displayed on proc/cpuinfo, but htop (or new version of top) for example, displays 2 CPUs. I suppose this is due to linux-sunxi kernel patchs ?

JIV
Guest
JIV

whats the kernel version?

Simos
Guest

1. Change ‘of= /dev/mmcblk0p1’ to ‘of=/dev/mmcblk0p1’ (there is a space).
2. Change ‘I decoded to try it out’ to ‘I decided to try it out’.

The device /dev/mmcblk0p1 does not exist.
When creating it with
mknod /dev/mmcblk0 b 254 0
mknod /dev/mmcblk0p1 b 254 1
it still does not work as if no appropriate kernel driver is loaded for them.

In U-Boot, the old value of the variable was:
mmc_root=/dev/mmcblk0p2

To save the environment variables, “env save”.

I performed the dd instruction on the ‘/dev/nandd’ device (8GB eMMC) instead and it worked. Now I am in Ubuntu on the A80 Optimusboard, as shown in the screenshot.

Simos
Guest

/var/log/kern.log mentions all cores. Apparently they just do not show up in /proc/cpuinfo.

Nov 18 20:11:56 ubuntu kernel: [11878.787202] CPU2: Booted secondary processor
Nov 18 20:11:57 ubuntu kernel: [11879.289774] CPU3: Booted secondary processor
Nov 18 20:11:57 ubuntu kernel: [11879.812919] CPU4: Booted secondary processor
Nov 18 20:12:01 ubuntu kernel: [11883.273026] CPU3: shutdown
Nov 18 20:12:01 ubuntu kernel: [11883.775673] CPU2: shutdown
Nov 18 20:12:02 ubuntu kernel: [11884.277526] CPU4: shutdown
Nov 18 20:12:03 ubuntu kernel: [11885.275437] CPU1: shutdown

glxinfo output: http://paste.ubuntu.com/9080957/
There is “software rendering”, which does not take advantage of the GPU capabilities.
If you feel the environment is somewhat fast, it’s due to the CPUs.

Xorg.log.0: http://paste.ubuntu.com/9081038/

Peter Bauer
Guest

It might be that CPU cores just go offline when they are not needed and go online if you run some processes which really need more performance. So they will not show up in /proc/cpuinfo.

Peter Bauer
Guest

What about the following in Ubuntu ?
sudo apt-get install cpuburn
sudo -i #get root
burnCortexA9 & burnCortexA9 & burnCortexA9 & burnCortexA9 & burnCortexA9 & burnCortexA9 & burnCortexA9 & burnCortexA
This should give some workload for all 8 CPU cores.

trackback

[…] if you’re not a fan of running Android on a TV, you should be able to run Ubuntu or other GNU/Linux operating systems instead… although you’ll probably need to put in […]

trackback

[…] or Tronsmart Draco AW80. Some early Ubuntu images and instructions had already been released for A80 Optimusboard and Draco AW80, but none of these featured GPU drivers for 3D acceleration, which to be honest, has […]

MRB
Guest
MRB

When I turned other cpus(1-7), they shutdown immediately even I assigned task by ‘taskset’ command. How can I turn them all?

vpeter
Guest
vpeter

I don’t get any output over HDMI to TV (hd ready). Is this normal or doing something wrong? Console works and also vnc works.

trackback

[…] with a choice of Ubuntu in addition to Android. If you don’t feel like trying to figure out how to install Ubuntu yourself, that might be worth the premium […]

erik
Guest
erik

@Simos

dd on ‘/dev/nandd’ on optiumsboard complains about not enough disk space. Optimusboard does NOT have NAND, it has 8GB of mmc instead, pcduino8 HAS 8GB of NAND. This is why you cannot dd on /dev/nandd with this board.

erik
Guest
erik

The instructions of this guide are incorrect. After flashing the kernel with phoenixsuit and the file pcduino8_kernel_livesuit_20141008.img and booting, the system loops indefinitely. Inserting a SD card in the slot does not stop the system from looping.