<!DOCTYPE html>
<html lang="en-US" class="no-js no-svg">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">

<meta name="referrer" content="always"/>
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel='preconnect' href='//cmp.uniconsent.com' />
<link rel='preconnect' href='//static.addtoany.com' />

<!-- PubGalaxy IAB TCF 2.0 script Top -->
<script src="https://cmp.uniconsent.com/v2/stub.min.js"></script>
<script async src='https://cmp.uniconsent.com/v2/de538b0a3a/cmp.js'></script>
<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
window.googletag.cmd.push(function () {
    window.googletag.pubads().enableAsyncRendering();
    window.googletag.pubads().disableInitialLoad();
});
(adsbygoogle = window.adsbygoogle || []).pauseAdRequests = 1;
</script>
<script>
__tcfapi("addEventListener", 2, function(tcData, success) {
    if (success && tcData.unicLoad  === true) {
        if(!window._initAds) {
            window._initAds = true;
            var script = document.createElement('script');
            script.async = true;
            script.src = 'https://dsh7ky7308k4b.cloudfront.net/publishers/cnx-softwarecom_new.min.js';
            document.head.appendChild(script);

/* Disable... using amz.to links instead 
            var script = document.createElement('script');
            script.async = true;
            script.src = '//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=593731f3-2419-45b0-9d08-5e745f36e047';
            document.head.appendChild(script); */
	    
	    /* Disable Adsense for now to fix CLS issue    
	    var script = document.createElement('script');
            script.async = true;
	    script.setAttribute('data-ad-client','ca-pub-3693704647095934');
            script.src = '//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js';
            document.head.appendChild(script); */

	    var script = document.createElement('script');
            script.async = true;
            script.src = '//pubgalaxy-com.videoplayerhub.com/gallery.js';
            document.head.appendChild(script);

/* Disable use fave.co links instead 
            var script = document.createElement('script');
            script.async = true;
            script.src = 'https://s.skimresources.com/js/38249X983277.skimlinks.js';
            document.head.appendChild(script); */
        }
    }
});
</script>
<!-- PubGalaxy IAB TCF 2.0 script top end -->
 
<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<script>function loadAsync(e,t){var a,n=!1;a=document.createElement("script"),a.type="text/javascript",a.src=e,a.onreadystatechange=function(){n||this.readyState&&"complete"!=this.readyState||(n=!0,"function"==typeof t&&t())},a.onload=a.onreadystatechange,document.getElementsByTagName("head")[0].appendChild(a)}</script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v17.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Ubuntu 22.04 LTS to leverage zswap to run on Raspberry Pi 4 with 2GB RAM - CNX Software</title>
	<meta name="description" content="Canonical used to recommend Raspberry Pi 4 with at least 4GB RAM to run Ubuntu Desktop, but Ubuntu 22.04 LTS should run more smoothly on the Raspberry Pi" />
	<link rel="canonical" href="https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Ubuntu 22.04 LTS to leverage zswap to run on Raspberry Pi 4 with 2GB RAM - CNX Software" />
	<meta property="og:description" content="Canonical used to recommend Raspberry Pi 4 with at least 4GB RAM to run Ubuntu Desktop, but Ubuntu 22.04 LTS should run more smoothly on the Raspberry Pi" />
	<meta property="og:url" content="https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/" />
	<meta property="og:site_name" content="CNX Software - Embedded Systems News" />
	<meta property="article:publisher" content="https://www.facebook.com/cnxsoft/" />
	<meta property="article:published_time" content="2022-01-13T10:20:58+00:00" />
	<meta property="article:modified_time" content="2022-01-13T12:55:07+00:00" />
	<meta property="og:image" content="https://www.cnx-software.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg" />
	<meta property="og:image:width" content="720" />
	<meta property="og:image:height" content="480" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@cnxsoft" />
	<meta name="twitter:site" content="@cnxsoft" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jean-Luc Aufranc (CNXSoft)" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="3 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO plugin. -->


<link rel="alternate" type="application/rss+xml" title="CNX Software - Embedded Systems News &raquo; Feed" href="https://www.cnx-software.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CNX Software - Embedded Systems News &raquo; Comments Feed" href="https://www.cnx-software.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CNX Software - Embedded Systems News &raquo; Ubuntu 22.04 LTS to leverage zswap to run on Raspberry Pi 4 with 2GB RAM Comments Feed" href="https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/feed/" />
<style type="text/css" media="all">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</style>
<link rel='stylesheet' id='crayon-theme-classic-css'  href='https://www.cnx-software.com/wp-content/plugins/urvanov-syntax-highlighter/themes/classic/classic.css' media='all' />
<link rel='stylesheet' id='crayon-font-monaco-css'  href='https://www.cnx-software.com/wp-content/plugins/urvanov-syntax-highlighter/fonts/monaco.css' media='all' />
<link rel='stylesheet' id='cookie-law-info-css'  href='https://www.cnx-software.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css' media='all' />
<link rel='stylesheet' id='cookie-law-info-gdpr-css'  href='https://www.cnx-software.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css' media='all' />
<link rel='stylesheet' id='wsl-widget-css'  href='https://www.cnx-software.com/wp-content/plugins/wordpress-social-login/assets/css/style.css' media='all' />
<link rel='stylesheet' id='achored-header-css'  href='https://www.cnx-software.com/wp-content/plugins/wp-anchor-header/css/achored-header.css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://www.cnx-software.com/wp-content/plugins/wpdiscuz/themes/default/style.css' media='all' />
<style id='wpdiscuz-frontend-css-inline-css'>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</style>
<link rel='stylesheet' id='wpdiscuz-combo-css-css'  href='https://www.cnx-software.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-combo.min.css' media='all' />
<link rel='stylesheet' id='ivory-search-styles-css'  href='https://www.cnx-software.com/wp-content/plugins/add-search-to-menu/public/css/ivory-search.min.css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.cnx-software.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css' media='all' />
<link rel='stylesheet' id='lazyload-video-css-css'  href='https://www.cnx-software.com/wp-content/plugins/lazy-load-for-videos/public/css/lazyload-shared.css' media='all' />
<style id='lazyload-video-css-inline-css'>
.entry-content a.lazy-load-youtube, a.lazy-load-youtube, .lazy-load-vimeo{ background-size: cover; }.lazy-load-div { background: url(https://eji4evk5kxx.exactdn.com/wp-content/plugins/lazy-load-for-videos//public/play-y-red.png?lossy=1&ssl=1) center center no-repeat; }
</style>
<link rel='stylesheet' id='parent-style-css'  href='https://www.cnx-software.com/wp-content/themes/twentyseventeen/style.css' media='all' />
<link rel='stylesheet' id='twentyseventeen-style-css'  href='https://www.cnx-software.com/wp-content/themes/twentyseventeen-child/style.css' media='all' />
<link rel='stylesheet' id='twentyseventeen-block-style-css'  href='https://www.cnx-software.com/wp-content/themes/twentyseventeen/assets/css/blocks.css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyseventeen-ie8-css'  href='https://www.cnx-software.com/wp-content/themes/twentyseventeen/assets/css/ie8.css' media='all' />
<![endif]-->
<link rel='stylesheet' id='recent-posts-widget-with-thumbnails-public-style-css'  href='https://www.cnx-software.com/wp-content/plugins/recent-posts-widget-with-thumbnails/public.css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.cnx-software.com/wp-content/plugins/tablepress/css/default.min.css' media='all' />
<link rel='stylesheet' id='tablepress-responsive-tables-css'  href='https://www.cnx-software.com/wp-content/plugins/tablepress-responsive-tables/css/tablepress-responsive.min.css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://www.cnx-software.com/wp-content/plugins/add-to-any/addtoany.min.css' media='all' />
<script>if (!navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|x11.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i)){
    loadAsync('https://static.addtoany.com/menu/page.js', null);
}</script>
<script src='https://www.cnx-software.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script src='https://www.cnx-software.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<!--[if lt IE 9]>
<script src='https://www.cnx-software.com/wp-content/themes/twentyseventeen/assets/js/html5.js' id='html5-js'></script>
<![endif]-->
<script id='wpo_min-header-0-js-extra'>
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[],"non_necessary_cookies":[],"ccpaEnabled":"","ccpaRegionBased":"","ccpaBarEnabled":"","strictlyEnabled":["necessary","obligatoire"],"ccpaType":"gdpr","js_blocking":"","custom_integration":"","triggerDomRefresh":"","secure_cookies":""};
var cli_cookiebar_settings = {"animate_speed_hide":"500","animate_speed_show":"500","background":"#fff","border":"#444","border_on":"","button_1_button_colour":"#000","button_1_button_hover":"#000000","button_1_link_colour":"#fff","button_1_as_button":"1","button_1_new_win":"","button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":"","button_2_hidebar":"1","button_3_button_colour":"#000","button_3_button_hover":"#000000","button_3_link_colour":"#fff","button_3_as_button":"1","button_3_new_win":"1","button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#fff","button_4_as_button":"1","button_7_button_colour":"#61a229","button_7_button_hover":"#4e8221","button_7_link_colour":"#fff","button_7_as_button":"1","button_7_new_win":"","font_family":"inherit","header_fix":"","notify_animate_hide":"1","notify_animate_show":"","notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":"","scroll_close_reload":"","accept_close_reload":"","reject_close_reload":"","showagain_tab":"","showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#000","show_once_yn":"1","show_once":"10000","logging_on":"","as_popup":"","popup_overlay":"1","bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"};
var log_object = {"ajax_url":"https:\/\/www.cnx-software.com\/wp-admin\/admin-ajax.php"};
</script>
<script defer src='https://www.cnx-software.com/wp-content/cache/wpo-minify/1642305197/assets/wpo-minify-header-ccdc1496.min.js' id='wpo_min-header-0-js'></script>
<script id='wpp-json' type="application/json">
{"sampling_active":1,"sampling_rate":20,"ajax_url":"https:\/\/www.cnx-software.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/www.cnx-software.com\/wp-json\/wordpress-popular-posts","ID":95092,"token":"75137017a4","lang":0,"debug":0}
</script>
<script src='https://www.cnx-software.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js' id='wpp-js-js'></script>

<!-- Google Analytics snippet added by Site Kit -->
<script src='https://www.googletagmanager.com/gtag/js?id=UA-2022395-2' id='google_gtagjs-js' async></script>
<script id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.cnx-software.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-2022395-2", {"anonymize_ip":true});
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<link rel="https://api.w.org/" href="https://www.cnx-software.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.cnx-software.com/wp-json/wp/v2/posts/95092" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.cnx-software.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.cnx-software.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.3" />
<link rel='shortlink' href='https://www.cnx-software.com/?p=95092' />
<link rel="alternate" type="application/json+oembed" href="https://www.cnx-software.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cnx-software.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.17 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.gxmas { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gxmas img { height:auto; }
	.gxmas-col { position:relative; float:left; }
	.gxmas-col:first-child { margin-left: 0; }
	.gxmas-col:last-child { margin-right: 0; }
	.gsensor-1 { margin:1px 1px 1px 1px; }
	.gborted-2 {  margin: 0 auto; }
	.gcacheb-3 { margin:1px 1px 1px 1px; }
	.gborted-5 { margin:10px 0px 0px 0px; }
	.gborted-11 {  margin: 0 auto; }
	.gborted-16 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.gxmas-col, .gxmas-dyn, .gxmas-single { width:100%; margin-left:0; margin-right:0; }
	}
.ajdg_bnnrwidgets, .ajdg_grpwidgets { overflow:hidden; padding:0; }
.5ff14a3410ea9, .5ff14a34136f9 { overflow:hidden; padding:0; }
</style>
<!-- /AdRotate CSS -->

<meta name="generator" content="Site Kit by Google 1.48.1" />        <style>
            span[class*="simple-icon-"] {
            	width: 1.5rem;
            	height: 1.5rem;
            	display: inline-block;

            }
            span[class*="simple-icon-"] svg {
            	display: inline-block;
            	vertical-align: middle;
                height: inherit;
                width: inherit;
            }
        </style>
                <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>
            <style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>			<script type="text/javascript">
				var cli_flush_cache = true;
			</script>
<noscript><style>.lazyload[data-src]{display:none !important;}</style></noscript><style>.lazyload{background-image:none !important;}.lazyload:before{background-image:none !important;}</style><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="amphtml" href="https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/?amp=1"><!--Customizer CSS--> 
<style type="text/css">
.admin-bar :target:before
{
   height: 117px;
   margin-top: -117px;
}
.single-post:not(.has-sidebar) #primary,
.page.page-one-column:not(.twentyseventeen-front-page) #primary,
.archive.page-one-column:not(.has-sidebar) .page-header,
.archive.page-one-column:not(.has-sidebar) #primary {
    max-width: none;
}
.navigation-top {
    z-index: 1001 !important;
}
@supports (-webkit-touch-callout: none) {
	@media screen and (min-width: 48em) {
		.background-fixed .panel-image {
			background-size: cover;
			height: auto;
			background-attachment: scroll;
		}
	}
}
body, body.colors-dark, body.colors-custom { background-color: #f9f9f8; }.widget ul li a {
    box-shadow: inset 0 -1px 0 rgba(15, 15, 15, 1);
}
.navigation-top, .main-navigation ul, .colors-dark .navigation-top, .colors-dark .main-navigation ul, .colors-custom .navigation-top, .colors-custom .main-navigation ul {
background-size: cover;
background-position: center center;
background-repeat: no-repeat;
}
#content { background-color: #f9f9f8; }.archive .page-header .page-title, .home .page-header .page-title, .blog .page-header .page-title { color: #41758b; }.entry-meta, .entry-footer .cat-links, .entry-footer .tags-links { font-weight: 700; }.post .entry-header .entry-title, .archive .entry-header .entry-title a, .blog .entry-header .entry-title a { color: #41758b; }.entry-content a { color: #41758b; }.entry-content a:hover { color: #41758b; }.entry-footer .cat-links { display:none; }.site-info:last-child a:last-child {
    display: none;
}
.site-info:last-child span {
    display: none;
}
.site-info p {
    margin: 0;
}
</style> 
<!--/Customizer CSS-->
<style type="text/css">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</style><link rel="icon" href="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/cropped-CNX-Software-Square-Logo-Light-Grey-1.png?lossy=1&#038;resize=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/cropped-CNX-Software-Square-Logo-Light-Grey-1.png?lossy=1&#038;resize=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/cropped-CNX-Software-Square-Logo-Light-Grey-1.png?lossy=1&#038;resize=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/cropped-CNX-Software-Square-Logo-Light-Grey-1.png?lossy=1&#038;resize=270%2C270&#038;ssl=1" />
		<style id="wp-custom-css">
			/* Desktop Sticky banner style */
.fixeddbar { position: fixed; bottom: 0px; left: 0; width: 100%; min-height: 90px; max-height: 100px; padding: 5px 5px; box-shadow: 0 -6px 18px 0 rgba(9,32,76,.1); -webkit-transition: all .1s ease-in; transition: all .1s ease-in; display: flex; align-items: center; justify-content: center; background-color: rgba(255, 255, 255, 0.6); z-index: 20; }
.fixeddbar-close { width: 30px; height: 30px; display: flex; align-items: center; justify-content: center; border-radius: 12px 0 0; position: absolute; right: 0; top: -30px; background-color: #fefefe; box-shadow: 0 -6px 18px 0 rgba(9,32,76,.08); }
.fixeddbar .fixeddbar-close svg { width: 22px; height: 22px; fill: #000; }
.fixeddbar .fixeddbar-content { overflow: hidden; display: block; position: relative; height: 100px; width: 100%; margin-right: 10px; margin-left: 10px; }

/* Mobile Sticky banner style */
.fixedmbar { position: fixed; bottom: 0px; left: 0; width: 100%; min-height: 65px; max-height: 75px; padding: 5px 5px; box-shadow: 0 -6px 18px 0 rgba(9,32,76,.1); -webkit-transition: all .1s ease-in; transition: all .1s ease-in; display: flex; align-items: center; justify-content: center; background-color: rgba(255, 255, 255, 0.6); z-index: 20; }
.fixedmbar-close { width: 30px; height: 30px; display: flex; align-items: center; justify-content: center; border-radius: 12px 0 0; position: absolute; right: 0; top: -30px; background-color: #fefefe; box-shadow: 0 -6px 18px 0 rgba(9,32,76,.08); }
.fixedmbar .fixeddbar-close svg { width: 22px; height: 22px; fill: #000; }
.fixedmbar .fixeddbar-content { overflow: hidden; display: block; position: relative; height: 60px; width: 100%; margin-right: 5px; margin-left: 5px; }
		</style>
		<!-- PubGalaxy IAB TCF 2.0 script bottom -->
<script>
(function waitGEO() {
    var readyGEO;
    if (window['UnicI'] && window['UnicI'].geo && window['UnicI'].geo !== '-' ) {
        readyGEO = true;
        console.log(window['UnicI'].geo);
        if (window['UnicI'].geo === 'EU') {
            if(document.getElementById("unic-gdpr")) {
              document.getElementById("unic-gdpr").style.display = 'block';
            }
        }
        if (window['UnicI'].geo === 'CA') {
            if(document.getElementById("unic-ccpa")) {
              document.getElementById("unic-ccpa").style.display = 'block';
            }
        }
    }
    if (!readyGEO) {
        setTimeout(waitGEO, 200);
    }
})();
</script>
<!-- PubGalaxy IAB TCF 2.0 script bottom End -->
 
<!-- Preload wpdiscuz font for Lighthouse performance improvements -->
<link id='wpdiscuz-preload-0' rel='preload' href='https://www.cnx-software.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/webfonts/fa-brands-400.woff2' as='font' type='font/woff2' crossorigin />
<link id='wpdiscuz-preload-1' rel='preload' href='https://www.cnx-software.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/webfonts/fa-solid-900.woff2' as='font' type='font/woff2' crossorigin />
<link id='wpdiscuz-preload-2' rel='preload' href='https://www.cnx-software.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/webfonts/fa-regular-400.woff2' as='font' type='font/woff2' crossorigin />
 
</head>

<body class="post-template-default single single-post postid-95092 single-format-standard wp-custom-logo wp-embed-responsive twentyseventeen group-blog has-sidebar colors-light">
<script data-cfasync="false">var ewww_webp_supported=false;</script>
<div id="page" class="site">
        <a class="skip-link screen-reader-text" href="#content">Skip to content</a>

        <header id="masthead" class="site-header">

                <div class="custom-header">

		<div class="custom-header-media">
					</div>

	<div class="site-branding">
        <div class="wrap">

                <div class="cnx-logo one-third-m">
                        <a href="https://www.cnx-software.com/" class="custom-logo-link" rel="home"><img width="250" height="250" src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/cropped-CNX-Software-Square-Logo-Light-Grey.png?lossy=1&amp;ssl=1" class="custom-logo" alt="CNX Software &#8211; Embedded Systems News" srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/cropped-CNX-Software-Square-Logo-Light-Grey.png?lossy=1&amp;ssl=1 250w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/cropped-CNX-Software-Square-Logo-Light-Grey-144x144.png?lossy=1&amp;ssl=1 144w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/cropped-CNX-Software-Square-Logo-Light-Grey-100x100.png?lossy=1&amp;ssl=1 100w" sizes="100vw" /></a>                </div>

                <div class="site-branding-text two-third-m">
                                                        <p class="site-title"><a href="https://www.cnx-software.com/" rel="home">CNX Software &#8211; Embedded Systems News</a></p>
                        
                                                        <p class="site-description">Reviews, tutorials and the latest news about embedded systems, IoT, open-source hardware, SBC&#039;s, microcontrollers, processors, and more</p>
                                        </div><!-- .site-branding-text -->
                <!-- JLA - PubGalaxy Top Banner -->
                <div class="header-ad"><div class="gxmas gxmas-1"><div class="gxmas-single axmas-96"><a href="https://store.rakwireless.com/pages/wisblock?utm_source=CNX&utm_medium=Display&utm_campaign=CNXWisBlock" rel="nofollow  noopener" target="_blank"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 728 90'%3E%3C/svg%3E" alt="Wisblock modular IoT system" width="728" height="90" style="display: block; margin: auto;" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/WisBlock.png?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="728" data-eio-rheight="90"><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/04/WisBlock.png?lossy=1&ssl=1" alt="Wisblock modular IoT system" width="728" height="90" style="display: block; margin: auto;" data-eio="l"></noscript></a></div></div></div>                
        </div><!-- .wrap -->
</div><!-- .site-branding -->

</div><!-- .custom-header -->

                                        <div class="navigation-top">
                                <div class="wrap">
                                        <nav id="site-navigation" class="main-navigation" role="navigation" aria-label="Top Menu">
	<button class="menu-toggle" aria-controls="top-menu" aria-expanded="false">
		<svg class="icon icon-bars" aria-hidden="true" role="img"> <use href="#icon-bars" xlink:href="#icon-bars"></use> </svg><svg class="icon icon-close" aria-hidden="true" role="img"> <use href="#icon-close" xlink:href="#icon-close"></use> </svg>Menu	</button>

	<div class="menu-cnx-software-streamlined-container"><ul id="top-menu" class="menu"><li id="menu-item-90064" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-90064"><a href="#">About<svg class="icon icon-angle-down" aria-hidden="true" role="img"> <use href="#icon-angle-down" xlink:href="#icon-angle-down"></use> </svg></a>
<ul class="sub-menu">
	<li id="menu-item-90066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90066"><a href="https://www.cnx-software.com/about/">About</a></li>
	<li id="menu-item-90895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90895"><a href="https://www.cnx-software.com/contact-us/?noamp=mobile">Contact Us</a></li>
	<li id="menu-item-90067" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90067"><a href="https://www.cnx-software.com/about/advertisement-consulting-services/">Advertisement &#038; Consulting Services</a></li>
	<li id="menu-item-90070" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90070"><a href="https://www.cnx-software.com/work-for-us/">Work for Us</a></li>
	<li id="menu-item-90069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90069"><a href="https://www.cnx-software.com/about/support-cnx-software/">Support CNX Software</a></li>
	<li id="menu-item-90068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-90068"><a rel="nofollow noopener" href="https://www.cnx-software.com/about/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
<li id="menu-item-90071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-90071"><a href="https://www.cnx-software.com">All News</a></li>
<li id="menu-item-90918" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90918"><a href="https://www.cnx-software.com/news/raspberry-pi">Raspberry Pi</a></li>
<li id="menu-item-90919" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90919"><a href="https://www.cnx-software.com/news/arduino">Arduino</a></li>
<li id="menu-item-90072" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90072"><a href="https://www.cnx-software.com/news/review">Reviews</a></li>
<li id="menu-item-90073" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90073"><a href="https://www.cnx-software.com/news/tutorial">Tutorials</a></li>
<li id="menu-item-90074" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90074"><a rel="nofollow noopener" href="https://shop.cnx-software.com">Shop</a></li>
</ul></div>
	</nav><!-- #site-navigation -->
                                </div><!-- .wrap -->
                        </div><!-- .navigation-top -->
                
        </header><!-- #masthead -->

        
        <div class="site-content-contain">
                <div id="content" class="site-content">


<div class="wrap">
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

			
<article id="post-95092" class="post-95092 post type-post status-publish format-standard has-post-thumbnail hentry category-broadcom-bcmxxxx category-linux category-ubuntu-os tag-linux tag-optimization tag-raspberry-pi tag-sbc tag-ubuntu tag-zram">
		<header class="entry-header">

	<div class="entry-meta"><span class="posted-on"><span class="screen-reader-text">Posted on</span> <a href="https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/" rel="bookmark"><time class="entry-date published" datetime="2022-01-13T17:20:58+07:00">January 13, 2022</time><time class="updated" datetime="2022-01-13T19:55:07+07:00">January 13, 2022</time></a></span><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://www.cnx-software.com/author/cnxsoft/">Jean-Luc Aufranc (CNXSoft)</a></span></span> - <a href="https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comments" rel="nofollow">10 Comments<span class="screen-reader-text"> on Ubuntu 22.04 LTS to leverage zswap to run on Raspberry Pi 4 with 2GB RAM</span></a></div>
	<div class="post-title"><h1 class="entry-title">Ubuntu 22.04 LTS to leverage zswap to run on Raspberry Pi 4 with 2GB RAM</h1></div>	</header><!-- .entry-header -->

	
			

	<div class="entry-content">
		<p>Canonical used to recommend Raspberry Pi 4 with at least 4GB RAM to run Ubuntu Desktop, but Ubuntu 22.04 LTS should run more smoothly on the Raspberry Pi 4 2GB as the company has enabled zswap by default to allow the Linux operating system to run better on systems with less memory.</p>
<p>Canonical explains that zswap is essentially a compression tool.</p>
<blockquote><p>When a process is about to be moved to the swap file, zswap compresses it and checks whether the new, smaller size still needs to be moved or if it can stay in your RAM. It is much quicker to decompress a &lsquo;zswapped&rsquo; page than it is to access the swap file so this is a great way of getting more bang for your buck from systems with smaller amounts of RAM.</p></blockquote>
<p><a href="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&ssl=1"><img class="aligncenter size-full wp-image-95117 lazyload" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 720 480'%3E%3C/svg%3E" alt="Raspberry Pi 4 2GB Ubuntu 22.04" width="720" height="480"   data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&resize=525%2C350&ssl=1" data-srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;ssl=1 720w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04-300x200.jpg?lossy=1&amp;ssl=1 300w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;w=105&amp;ssl=1 105w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;w=210&amp;ssl=1 210w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;w=420&amp;ssl=1 420w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;w=525&amp;ssl=1 525w" data-sizes="auto" data-eio-rwidth="525" data-eio-rheight="350"><noscript><img class="aligncenter size-full wp-image-95117" src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&resize=525%2C350&ssl=1" alt="Raspberry Pi 4 2GB Ubuntu 22.04" width="720" height="480" srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;ssl=1 720w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04-300x200.jpg?lossy=1&amp;ssl=1 300w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;w=105&amp;ssl=1 105w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;w=210&amp;ssl=1 210w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;w=420&amp;ssl=1 420w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/Raspberry-Pi-4-2GB-Ubuntu-22.04.jpg?lossy=1&amp;w=525&amp;ssl=1 525w" sizes="(max-width: 525px) 100vw, 525px" data-eio="l"></noscript></a></p>
<p>The good news is that you don&rsquo;t even need to wait for Ubuntu 22.04 LTS to come out, since it can be enabled manually in Raspberry Pi 4 as follows:<br>
</p><!-- Urvanov Syntax Highlighter v2.8.27 -->

		<div id="urvanov-syntax-highlighter-61e398b3cad68373498629" class="urvanov-syntax-highlighter-syntax crayon-theme-classic urvanov-syntax-highlighter-font-monaco urvanov-syntax-highlighter-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button urvanov-syntax-highlighter-nums-button" title="Toggle Line Numbers"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-plain-button" title="Toggle Plain Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-wrap-button" title="Toggle Line Wrap"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-expand-button" title="Expand Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-copy-button" title="Copy"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-popup-button" title="Open Code In New Window"><div class="urvanov-syntax-highlighter-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="urvanov-syntax-highlighter-plain-wrap"><textarea wrap="soft" class="urvanov-syntax-highlighter-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
$ sudo sed -i -e 's/$/ zswap.enabled=1/' /boot/firmware/cmdline.txt</textarea></div>
			<div class="urvanov-syntax-highlighter-main" style="">
				<table class="crayon-table">
					<tr class="urvanov-syntax-highlighter-row">
				<td class="crayon-nums " data-settings="show">
					<div class="urvanov-syntax-highlighter-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="urvanov-syntax-highlighter-61e398b3cad68373498629-1">1</div></div>
				</td>
						<td class="urvanov-syntax-highlighter-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="urvanov-syntax-highlighter-61e398b3cad68373498629-1"><span class="crayon-sy">$</span><span class="crayon-h"> </span><span class="crayon-e">sudo </span><span class="crayon-v">sed</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-v">i</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">e</span><span class="crayon-h"> </span><span class="crayon-s">'s/$/ zswap.enabled=1/'</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">boot</span><span class="crayon-o">/</span><span class="crayon-v">firmware</span><span class="crayon-o">/</span><span class="crayon-v">cmdline</span><span class="crayon-sy">.</span><span class="crayon-v">txt</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p><br>
Or simply edit /boot/firmware/cmdline.txt file, and add the following string to the existing command:<br>
</p><!-- Urvanov Syntax Highlighter v2.8.27 -->

		<div id="urvanov-syntax-highlighter-61e398b3cad79440672742" class="urvanov-syntax-highlighter-syntax crayon-theme-classic urvanov-syntax-highlighter-font-monaco urvanov-syntax-highlighter-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button urvanov-syntax-highlighter-nums-button" title="Toggle Line Numbers"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-plain-button" title="Toggle Plain Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-wrap-button" title="Toggle Line Wrap"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-expand-button" title="Expand Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-copy-button" title="Copy"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-popup-button" title="Open Code In New Window"><div class="urvanov-syntax-highlighter-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="urvanov-syntax-highlighter-plain-wrap"><textarea wrap="soft" class="urvanov-syntax-highlighter-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
zswap.enabled=1</textarea></div>
			<div class="urvanov-syntax-highlighter-main" style="">
				<table class="crayon-table">
					<tr class="urvanov-syntax-highlighter-row">
				<td class="crayon-nums " data-settings="show">
					<div class="urvanov-syntax-highlighter-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="urvanov-syntax-highlighter-61e398b3cad79440672742-1">1</div></div>
				</td>
						<td class="urvanov-syntax-highlighter-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="urvanov-syntax-highlighter-61e398b3cad79440672742-1"><span class="crayon-v">zswap</span><span class="crayon-sy">.</span><span class="crayon-v">enabled</span><span class="crayon-o">=</span><span class="crayon-cn">1</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p><br>
After a reboot, that should even help the performance of Raspberry Pi 4 boards with 4GB and 8GB RAM, but with the 2GB model, some extra steps are needed to enable z3fold allocator &amp; lz4 compression. The commands to run are explained in detail in <a href="https://ubuntu.com/blog/how-low-can-you-go-running-ubuntu-desktop-on-a-2gb-raspberry-pi-4">Ubuntu blog</a>, and in the end, you&rsquo;ll have loaded a few more modules and your cmdline.txt should have three extra parameters:<br>
</p><!-- Urvanov Syntax Highlighter v2.8.27 -->

		<div id="urvanov-syntax-highlighter-61e398b3cad7b024334164" class="urvanov-syntax-highlighter-syntax crayon-theme-classic urvanov-syntax-highlighter-font-monaco urvanov-syntax-highlighter-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button urvanov-syntax-highlighter-nums-button" title="Toggle Line Numbers"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-plain-button" title="Toggle Plain Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-wrap-button" title="Toggle Line Wrap"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-expand-button" title="Expand Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-copy-button" title="Copy"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-popup-button" title="Open Code In New Window"><div class="urvanov-syntax-highlighter-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="urvanov-syntax-highlighter-plain-wrap"><textarea wrap="soft" class="urvanov-syntax-highlighter-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
zswap.enabled=1 zswap.compressor=lz4 zswap.zpool=z3fold</textarea></div>
			<div class="urvanov-syntax-highlighter-main" style="">
				<table class="crayon-table">
					<tr class="urvanov-syntax-highlighter-row">
				<td class="crayon-nums " data-settings="show">
					<div class="urvanov-syntax-highlighter-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="urvanov-syntax-highlighter-61e398b3cad7b024334164-1">1</div></div>
				</td>
						<td class="urvanov-syntax-highlighter-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="urvanov-syntax-highlighter-61e398b3cad7b024334164-1"><span class="crayon-v">zswap</span><span class="crayon-sy">.</span><span class="crayon-v">enabled</span><span class="crayon-o">=</span><span class="crayon-cn">1</span><span class="crayon-h"> </span><span class="crayon-v">zswap</span><span class="crayon-sy">.</span><span class="crayon-v">compressor</span><span class="crayon-o">=</span><span class="crayon-e">lz4 </span><span class="crayon-v">zswap</span><span class="crayon-sy">.</span><span class="crayon-v">zpool</span><span class="crayon-o">=</span><span class="crayon-v">z3fold</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p><br>
There will be nothing to do in Ubuntu 22.04 LTS as those will be enabled by default.</p>
<p>We previously wrote about <a href="https://www.cnx-software.com/2018/05/14/running-out-of-ram-in-ubuntu-enable-zram/">enabling ZRAM in Ubuntu</a> to improve the performance and reliability of systems low on RAM. So what&rsquo;s the difference between zram and zswap exactly? I understand zram is like a compressed swap that resides in RAM, while zswap uses both storage and RAM, and only stores the compressed data into the swap file on the storage device, if there&rsquo;s not enough RAM to hold the data.</p>
<p>That question was also <a href="https://stackoverflow.com/questions/18437205/difference-between-zram-and-zswap#18598732">asked on Stackoverflow</a> so we have a more detailed answer (edited for brevity):</p>
<blockquote><p><strong>zram</strong><br>
Status: Available since Linux 3.14 (March 2014)<br>
Implementation: compressed block device, memory is dynamically allocated as data is stored<br>
Usage: Configure zram block device as a swap device to eliminate need for physical swap defice or swap file</p>
<p>Benefits:</p>
<ul>
<li>Eliminates need for physical swap device.</li>
<li>A zram block device can be used for other applications other than swap, anything you might use a block device for conceivably.</li>
</ul>
<p>Drawbacks:</p>
<ul>
<li>Once a page is stored in zram it will remain there until paged in or invalidated. &hellip; zram can not do evict pages out to physical disk.</li>
</ul>
<p><strong>zswap</strong><br>
Status: Available since Linux 3.11 (September 2013)<br>
Implementation: compressed in-kernel cache for swap pages. In-kernel cache is compressed, the compression algorithm is pluggable using the CryptoAPI and the storage for pages is dynamically allocated. Older pages can be evicted to disk making this a sort of write-behind cache.<br>
Usage: Cache swap pages destined for regular swap devices (or swap files).</p>
<p>Benefits:</p>
<ul>
<li>Integration with swap code (using Frontswap API) allows zswap to choose to store only pages that compress well and handle memory allocation failures, in those cases pages are sent to the backing swap device.</li>
<li>Oldest pages in the cache are pushed out to backing swap device to make room for newer pages.</li>
</ul>
<p>Drawbacks:</p>
<ul>
<li>Needs a physical swap device (or swapfile).</li>
</ul>
</blockquote>
<p>Thanks to Geokon for the tip.</p>
<div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-tab"><div class="saboxplugin-gravatar"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 100 100'%3E%3C/svg%3E" width="100"  height="100" alt="jean-luc aufranc cnxsoft" itemprop="image" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/02/jean-luc-aufranc-cnxsoft.jpg?lossy=1&resize=100%2C100&ssl=1" class="lazyload" data-eio-rwidth="100" data-eio-rheight="100"><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/02/jean-luc-aufranc-cnxsoft.jpg?lossy=1&resize=100%2C100&ssl=1" width="100"  height="100" alt="jean-luc aufranc cnxsoft" itemprop="image" data-eio="l"></noscript></div><div class="saboxplugin-authorname"><a href="https://www.cnx-software.com/author/cnxsoft/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Jean-Luc Aufranc (CNXSoft)</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>Jean-Luc started CNX Software in 2010 as a part-time endeavor, before quitting his job as a software engineering manager, and starting to write daily news, and reviews full time later in 2011.</p>
</div></div><div class="clearfix"></div><div class="saboxplugin-socials "><a target="_blank" href="https://www.twitter.com/cnxsoft" aria-label="Twitter" rel="nofollow noopener" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-twitter" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></span></a><a target="_blank" href="https://www.linkedin.com/in/cnxsoft/" aria-label="Linkedin" rel="nofollow noopener" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-linkedin" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M100.3 480H7.4V180.9h92.9V480zM53.8 140.1C24.1 140.1 0 115.5 0 85.8 0 56.1 24.1 32 53.8 32c29.7 0 53.8 24.1 53.8 53.8 0 29.7-24.1 54.3-53.8 54.3zM448 480h-92.7V334.4c0-34.7-.7-79.2-48.3-79.2-48.3 0-55.7 37.7-55.7 76.7V480h-92.8V180.9h89.1v40.8h1.3c12.4-23.5 42.7-48.3 87.9-48.3 94 0 111.3 61.9 111.3 142.3V480z"></path></svg></span></a></div></div></div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="addtoany_header">Share this:</div><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/" data-a2a-title="Ubuntu 22.04 LTS to leverage zswap to run on Raspberry Pi 4 with 2GB RAM"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_hacker_news" href="https://www.addtoany.com/add_to/hacker_news?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="Hacker News" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_slashdot" href="https://www.addtoany.com/add_to/slashdot?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="Slashdot" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="LinkedIn" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_mewe" href="https://www.addtoany.com/add_to/mewe?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="MeWe" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_line" href="https://www.addtoany.com/add_to/line?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="Line" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F&amp;linkname=Ubuntu%2022.04%20LTS%20to%20leverage%20zswap%20to%20run%20on%20Raspberry%20Pi%204%20with%202GB%20RAM" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>	</div><!-- .entry-content -->

			<!-- JLA - Donations -->
		<p>Support CNX Software! Donate via <b><u><a href="https://paypal.me/jlahk/24usd" target="_blank" rel="nofollow noopener">PayPal</a></u></b> or <b><u><a href="https://www.cnx-software.com/donate-cryptocurrencies/" rel="nofollow noopener">cryptocurrencies</a></u></b>, <b><u><a href="https://www.patreon.com/cnxsoft" target="_blank" rel="nofollow noopener">become a Patron</a></u></b> on Patreon, or <b><u><a href="https://shop.cnx-software.com/" target="_blank" rel="nofollow noopener">buy review samples</a></u></b></p>

		<div class="axmas-single axmas-103"><!-- /8095840/.2_A.37829.46_cnx-software.com_tier1 -->
<div id='div-gpt-ad-1597905513858-0'>
</div></div><footer class="entry-footer"><span class="cat-tags-links"><span class="tags-links"><svg class="icon icon-hashtag" aria-hidden="true" role="img"> <use href="#icon-hashtag" xlink:href="#icon-hashtag"></use> </svg><span class="screen-reader-text">Tags</span><a href="https://www.cnx-software.com/news/linux/" rel="tag">Linux</a>, <a href="https://www.cnx-software.com/news/optimization/" rel="tag">optimization</a>, <a href="https://www.cnx-software.com/news/raspberry-pi/" rel="tag">raspberry pi</a>, <a href="https://www.cnx-software.com/news/sbc/" rel="tag">Single Board Computer</a>, <a href="https://www.cnx-software.com/news/ubuntu/" rel="tag">ubuntu</a>, <a href="https://www.cnx-software.com/news/zram/" rel="tag">zram</a></span></span></footer> <!-- .entry-footer --><footer id="entry-subFooter" class="one"><div class="one-half"><div class="gxmas gxmas-4"><div class="gxmas-single axmas-17"><div class="adsense">
<!-- TAGNAME: Desktop Main Body Before Comments 300x250 -->
<!-- /8095840/.2_A.35196.4_cnx-software.com_tier1 -->
<div id='div-gpt-ad-cnx-softwarecom35196' style='height:250px; width:300px;display: block; margin: auto;'>
</div>
</div></div></div></div><div class="one-half"><div class='yarpp yarpp-related yarpp-related-website yarpp-template-list'>
<!-- YARPP List -->
<p>Related posts:</p><ol>
<li><a href="https://www.cnx-software.com/2021/10/16/raspberry-pi-4-rockchip-rk3399-sbcs-get-arm-systemready-ir-certification/" rel="bookmark" title="Raspberry Pi 4, Rockchip RK3399 SBC&#8217;s get Arm SystemReady IR certification">Raspberry Pi 4, Rockchip RK3399 SBC&#8217;s get Arm SystemReady IR certification </a></li>
<li><a href="https://www.cnx-software.com/2015/02/02/raspberry-pi-2-odroid-c1-development-boards-comparison/" rel="bookmark" title="Raspberry Pi 2 / ODROID C1+ Development Boards Comparison">Raspberry Pi 2 / ODROID C1+ Development Boards Comparison </a></li>
<li><a href="https://www.cnx-software.com/2016/01/03/raspberry-pi-zero-c-h-i-p-and-orange-pi-one-features-and-price-comparisons/" rel="bookmark" title="Raspberry Pi Zero, C.H.I.P, and Orange Pi One Boards&#8217; Features and Price Comparisons">Raspberry Pi Zero, C.H.I.P, and Orange Pi One Boards&#8217; Features and Price Comparisons </a></li>
<li><a href="https://www.cnx-software.com/2016/03/01/raspberry-pi-3-odroid-c2-and-pine-a64-development-boards-comparison/" rel="bookmark" title="Raspberry Pi 3, ODROID-C2 and Pine A64+ Development Boards Comparison">Raspberry Pi 3, ODROID-C2 and Pine A64+ Development Boards Comparison </a></li>
<li><a href="https://www.cnx-software.com/2016/04/02/low-cost-development-boards-linux-benchmarks-raspberry-pi-vs-banana-pi-vs-orange-pi-vs-odroid/" rel="bookmark" title="Low Cost Development Boards Linux Benchmarks &#8211; Raspberry Pi vs Banana Pi vs Orange Pi vs ODROID">Low Cost Development Boards Linux Benchmarks &#8211; Raspberry Pi vs Banana Pi vs Orange Pi vs ODROID </a></li>
</ol>
</div>
</div></footer>
</article><!-- #post-## -->
    <div class="wpdiscuz_top_clearing"></div>
    <div id='comments' class='comments-area'><div id='respond' style='width: 0;height: 0;clear: both;margin: 0;padding: 0;'></div>    <div id="wpdcom" class="wpdiscuz_unauth wpd-default wpd-layout-1 wpd-comments-open">
                    <div class="wc_social_plugin_wrapper">
                
<!--
	wsl_render_auth_widget
	WordPress Social Login 3.0.3.
	http://wordpress.org/plugins/wordpress-social-login/
-->

<style type="text/css">
.wp-social-login-connect-with{}.wp-social-login-provider-list{}.wp-social-login-provider-list a{}.wp-social-login-provider-list img{}.wsl_connect_with_provider{}</style>

<div class="wp-social-login-widget">

	<div class="wp-social-login-connect-with">Connect with:</div>

	<div class="wp-social-login-provider-list">

		<a rel="nofollow" href="https://www.cnx-software.com/smart-login/?action=wordpress_social_authenticate&#038;mode=login&#038;provider=Facebook&#038;redirect_to=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F" title="Connect with Facebook" class="wp-social-login-provider wp-social-login-provider-facebook" data-provider="Facebook" role="button">
			<img alt="Facebook" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 32 32'%3E%3C/svg%3E" aria-hidden="true" data-src="https://eji4evk5kxx.exactdn.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom//facebook.png?lossy=1&ssl=1" class="lazyload" width="32" height="32" data-eio-rwidth="32" data-eio-rheight="32" /><noscript><img alt="Facebook" src="https://eji4evk5kxx.exactdn.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom//facebook.png?lossy=1&ssl=1" aria-hidden="true" data-eio="l" /></noscript>
		</a>

		<a rel="nofollow" href="https://www.cnx-software.com/smart-login/?action=wordpress_social_authenticate&#038;mode=login&#038;provider=Google&#038;redirect_to=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F" title="Connect with Google" class="wp-social-login-provider wp-social-login-provider-google" data-provider="Google" role="button">
			<img alt="Google" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 32 32'%3E%3C/svg%3E" aria-hidden="true" data-src="https://eji4evk5kxx.exactdn.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom//google.png?lossy=1&ssl=1" class="lazyload" width="32" height="32" data-eio-rwidth="32" data-eio-rheight="32" /><noscript><img alt="Google" src="https://eji4evk5kxx.exactdn.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom//google.png?lossy=1&ssl=1" aria-hidden="true" data-eio="l" /></noscript>
		</a>

		<a rel="nofollow" href="https://www.cnx-software.com/smart-login/?action=wordpress_social_authenticate&#038;mode=login&#038;provider=Twitter&#038;redirect_to=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F" title="Connect with Twitter" class="wp-social-login-provider wp-social-login-provider-twitter" data-provider="Twitter" role="button">
			<img alt="Twitter" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 32 32'%3E%3C/svg%3E" aria-hidden="true" data-src="https://eji4evk5kxx.exactdn.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom//twitter.png?lossy=1&ssl=1" class="lazyload" width="32" height="32" data-eio-rwidth="32" data-eio-rheight="32" /><noscript><img alt="Twitter" src="https://eji4evk5kxx.exactdn.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom//twitter.png?lossy=1&ssl=1" aria-hidden="true" data-eio="l" /></noscript>
		</a>

	</div>

	<div class="wp-social-login-widget-clearing"></div>

</div>

<!-- wsl_render_auth_widget -->

            </div>
            <div class="wpd-form-wrap">
                <div class="wpd-form-head">
                                            <div class="wpd-sbs-toggle">
                            <i class="far fa-envelope"></i> <span class="wpd-sbs-title">Subscribe</span> <i class="fas fa-caret-down"></i>
                        </div>
                                            <div class="wpd-auth">
                                                <div class="wpd-login">
                            <a rel="nofollow" href="https://www.cnx-software.com/smart-login/?redirect_to=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F"><i class='fas fa-sign-in-alt'></i> Login</a>                        </div>
                    </div>
                </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://www.cnx-software.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Notify of </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">new follow-up comments</option>
                                                                                                                                <option value="all_comment" >new replies to my comments</option>
                                                                                </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                    <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" class="wpd-prim-button" type="submit" value="›" name="wpdiscuz_subscription_button" />
                                </div> 
                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="a54fd6af1c" /><input type="hidden" name="_wp_http_referer" value="/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/" />                            </form>
                                                </div>
                            <div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id='wpd-main-form-wrapper-0_0'>
                                        <form class="wpd_comm_form wpd_main_comm_form" method="post" enctype="multipart/form-data">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap ">
                                                                                                        <div class="wpd-avatar">
                                        <img alt='guest' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 56 56'%3E%3C/svg%3E'  class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' data-src="https://secure.gravatar.com/avatar/?s=56&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='guest' src='https://secure.gravatar.com/avatar/?s=56&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x' class='avatar avatar-56 photo avatar-default' height='56' width='56' data-eio="l" /></noscript>                                    </div>
                                                <div id="wpd-editor-wraper-0_0" style="display: none;">
                <div id="wpd-editor-char-counter-0_0" class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-0_0">Label</label>
                <textarea id="wc-textarea-0_0" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-0_0"></div>
                        <div id="wpd-editor-toolbar-0_0">
                            <button title="Bold" class="ql-bold"  ></button>
                                <button title="Italic" class="ql-italic"  ></button>
                                <button title="Underline" class="ql-underline"  ></button>
                                <button title="Strike" class="ql-strike"  ></button>
                                <button title="Ordered List" class="ql-list" value='ordered' ></button>
                                <button title="Unordered List" class="ql-list" value='bullet' ></button>
                                <button title="Blockquote" class="ql-blockquote"  ></button>
                                <button title="Code Block" class="ql-code-block"  ></button>
                                <button title="Link" class="ql-link"  ></button>
                                <button title="Source Code" class="ql-sourcecode"  data-wpde_button_name='sourcecode'>{}</button>
                                <button title="Spoiler" class="ql-spoiler"  data-wpde_button_name='spoiler'>[+]</button>
                            <div class="wpd-editor-buttons-right">
                <span class='wmu-upload-wrap' wpd-tooltip='' wpd-tooltip-position='left'><label class='wmu-add'><i class='far fa-image'></i><input style='display:none;' class='wmu-add-files' type='file' name='wmu_files[]'  accept='image/*'/></label></span>            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot" >
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"><div class='wmu-action-wrap'><div class='wmu-tabs wmu-images-tab wmu-hide'></div></div></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                    <input id="wc_name-0_0" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title="">
                <label for="wc_name-0_0" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                    <input id="wc_email-0_0" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" />
                <label for="wc_email-0_0" class="wpdlb">Email*</label>
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input id="wc_website-0_0" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" />
                    <label for="wc_website-0_0" class="wpdlb">Website</label>
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wpdiscuz-item wpd-field-group wpd-field-checkbox wpd-field-agreement wpd-field-single custom_field_5b078c9ac5656-wrapper wpd-required-group wpd-has-desc">
            <div class="wpd-field-group-title">
                <div class="wpd-item">
                    <input id="custom_field_5b078c9ac5656-1_0_0" type="checkbox" name="custom_field_5b078c9ac5656" value="1" class="custom_field_5b078c9ac5656 wpd-field wpd-agreement-checkbox  wpd_agreement_hide "  required>
                    <label class="wpd-field-label wpd-cursor-pointer" for="custom_field_5b078c9ac5656-1_0_0">I agree to the <a href=https://www.cnx-software.com/privacy-policy>Privacy Policy</a></label>
                </div>
            </div>
                            <div class="wpd-field-desc">
                    <i class="far fa-question-circle"></i><span>The comment form collects your name, email and content to allow us keep track of the comments placed on the website.  Please read and accept our website Terms and Privacy Policy to post a comment.</span>
                </div>
                    </div>
                <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" />
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-0_0" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" />
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
                </form>
                        </div>
                <div id="wpdiscuz_hidden_secondary_form" style="display: none;">
                    <div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id='wpd-secondary-form-wrapper-wpdiscuzuniqueid' style='display: none;'>
                            <div class="wpd-secondary-forms-social-content"></div><div class="clearfix"></div>
                                        <form class="wpd_comm_form wpd-secondary-form-wrapper" method="post" enctype="multipart/form-data">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap ">
                                                                                                        <div class="wpd-avatar">
                                        <img alt='guest' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 56 56'%3E%3C/svg%3E'  class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' data-src="https://secure.gravatar.com/avatar/?s=56&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='guest' src='https://secure.gravatar.com/avatar/?s=56&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x' class='avatar avatar-56 photo avatar-default' height='56' width='56' data-eio="l" /></noscript>                                    </div>
                                                <div id="wpd-editor-wraper-wpdiscuzuniqueid" style="display: none;">
                <div id="wpd-editor-char-counter-wpdiscuzuniqueid" class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-wpdiscuzuniqueid">Label</label>
                <textarea id="wc-textarea-wpdiscuzuniqueid" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-wpdiscuzuniqueid"></div>
                        <div id="wpd-editor-toolbar-wpdiscuzuniqueid">
                            <button title="Bold" class="ql-bold"  ></button>
                                <button title="Italic" class="ql-italic"  ></button>
                                <button title="Underline" class="ql-underline"  ></button>
                                <button title="Strike" class="ql-strike"  ></button>
                                <button title="Ordered List" class="ql-list" value='ordered' ></button>
                                <button title="Unordered List" class="ql-list" value='bullet' ></button>
                                <button title="Blockquote" class="ql-blockquote"  ></button>
                                <button title="Code Block" class="ql-code-block"  ></button>
                                <button title="Link" class="ql-link"  ></button>
                                <button title="Source Code" class="ql-sourcecode"  data-wpde_button_name='sourcecode'>{}</button>
                                <button title="Spoiler" class="ql-spoiler"  data-wpde_button_name='spoiler'>[+]</button>
                            <div class="wpd-editor-buttons-right">
                <span class='wmu-upload-wrap' wpd-tooltip='' wpd-tooltip-position='left'><label class='wmu-add'><i class='far fa-image'></i><input style='display:none;' class='wmu-add-files' type='file' name='wmu_files[]'  accept='image/*'/></label></span>            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot" >
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"><div class='wmu-action-wrap'><div class='wmu-tabs wmu-images-tab wmu-hide'></div></div></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                    <input id="wc_name-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title="">
                <label for="wc_name-wpdiscuzuniqueid" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                    <input id="wc_email-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" />
                <label for="wc_email-wpdiscuzuniqueid" class="wpdlb">Email*</label>
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input id="wc_website-wpdiscuzuniqueid" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" />
                    <label for="wc_website-wpdiscuzuniqueid" class="wpdlb">Website</label>
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wpdiscuz-item wpd-field-group wpd-field-checkbox wpd-field-agreement wpd-field-single custom_field_5b078c9ac5656-wrapper wpd-required-group wpd-has-desc">
            <div class="wpd-field-group-title">
                <div class="wpd-item">
                    <input id="custom_field_5b078c9ac5656-1_wpdiscuzuniqueid" type="checkbox" name="custom_field_5b078c9ac5656" value="1" class="custom_field_5b078c9ac5656 wpd-field wpd-agreement-checkbox  wpd_agreement_hide "  required>
                    <label class="wpd-field-label wpd-cursor-pointer" for="custom_field_5b078c9ac5656-1_wpdiscuzuniqueid">I agree to the <a href=https://www.cnx-software.com/privacy-policy>Privacy Policy</a></label>
                </div>
            </div>
                            <div class="wpd-field-desc">
                    <i class="far fa-question-circle"></i><span>The comment form collects your name, email and content to allow us keep track of the comments placed on the website.  Please read and accept our website Terms and Privacy Policy to post a comment.</span>
                </div>
                    </div>
                <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" />
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-wpdiscuzuniqueid" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" />
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
                </form>
                        </div>
                </div>
                    </div>
                        <div id="wpd-threads" class="wpd-thread-wrapper">
                <div class="wpd-thread-head">
                    <div class="wpd-thread-info " data-comments-count="10">
                        <span class='wpdtc' title='10'>10</span> Comments                    </div>
                                        <div class="wpd-space"></div>
                    <div class="wpd-thread-filter">
                                                    <div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div>
                                                        <div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div>
                                                        <div class="wpd-filter wpdf-sorting">
                                                                        <span class="wpdiscuz-sort-button wpdiscuz-date-sort-asc wpdiscuz-sort-button-active" data-sorting="oldest">oldest</span>
                                                                        <i class="fas fa-sort-down"></i>
                                <div class="wpdiscuz-sort-buttons">
                                                                            <span class="wpdiscuz-sort-button wpdiscuz-date-sort-desc" data-sorting="newest">newest</span>
                                                                        </div>
                            </div>
                                                </div>
                </div>
                <div class="wpd-comment-info-bar">
                    <div class="wpd-current-view"><i class="fas fa-quote-left"></i> </div>
                    <div class="wpd-filter-view-all"></div>
                </div>
                                <div class="wpd-thread-list">
                    <div id='wpd-comm-589731_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <img alt='Igor' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo lazyload' height='64' width='64' data-src="https://secure.gravatar.com/avatar/f5cd7b79d22c4a5ebecf15e41f615073?s=64&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/f5cd7b79d22c4a5ebecf15e41f615073?s=128&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='Igor' src='https://secure.gravatar.com/avatar/f5cd7b79d22c4a5ebecf15e41f615073?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f5cd7b79d22c4a5ebecf15e41f615073?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-eio="l" /></noscript>
</div>
    
    
</div>
    <div id="comment-589731" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='http://Armbian' rel='noreferrer ugc nofollow' target='_blank'>Igor</a>
</div>
    <div class="wpd-comment-date" title="January 13, 2022 17:34">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=Ubuntu is integrating what Armbian is ... &url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589731' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589731'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>Ubuntu is integrating what Armbian is providing since 2014 🙂 and selling as super speed advantage.</p>

</div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies" wpd-tooltip-position='left'>
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589731_0'></div><div id='wpd-comm-589734_589731' class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <img alt='tkaiser' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo lazyload' height='64' width='64' data-src="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='tkaiser' src='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-eio="l" /></noscript>
</div>
    
    
</div>
    <div id="comment-589734" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    tkaiser
</div>
    <div class="wpd-comment-date" title="January 13, 2022 18:22">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=What did &#8216;Armbian&#8217; provide... &url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589734' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589734'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    &nbsp;
    <a href="#comment-589731">
        Igor
    </a>
</div>
    <div class="wpd-comment-text">
    <p>What did &#8216;Armbian&#8217; provide since 2014?</p>
<p>Armbian used an 128MB &#8217;emergency swap file&#8217; with vm.swappiness=0 setting until few years ago. After <a rel="nofollow"href="https://forum.armbian.com/topic/5565-zram-vs-swap/" target="_blank" rel="noopener nofollow ugc">months or even a year of testing</a> <strong>zram</strong> became default in 2018 and the swap file was gone. And only recently (Dec 2020) the <strong>zram</strong> config script had been adjusted to not conflict with <strong>zswap</strong> which always was up to the kernel and user in question to be used or not.</p>

</div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies" wpd-tooltip-position='left'>
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589734_589731'></div><div id='wpd-comm-589745_589734' class='wpd-comment wpd-reply wpd_comment_level-3'><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <img alt='Igor' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo lazyload' height='64' width='64' data-src="https://secure.gravatar.com/avatar/f5cd7b79d22c4a5ebecf15e41f615073?s=64&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/f5cd7b79d22c4a5ebecf15e41f615073?s=128&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='Igor' src='https://secure.gravatar.com/avatar/f5cd7b79d22c4a5ebecf15e41f615073?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f5cd7b79d22c4a5ebecf15e41f615073?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-eio="l" /></noscript>
</div>
    
    
</div>
    <div id="comment-589745" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='http://Armbian' rel='noreferrer ugc nofollow' target='_blank'>Igor</a>
</div>
    <div class="wpd-comment-date" title="January 13, 2022 22:22">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=I checked upon first mentioning. &#822... &url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589745' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589745'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    &nbsp;
    <a href="#comment-589734">
        tkaiser
    </a>
</div>
    <div class="wpd-comment-text">
    <p>I checked upon first mentioning. &#8220;Proper&#8221; implementation in 2017/18, more proper in 2020 but still not perfect for everyone &#8230; since someone recently reported &#8220;he has to have full control over his memory, so he is disabling zram 1st&#8221;</p>

</div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies" wpd-tooltip-position='left'>
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589745_589734'></div><div id='wpd-comm-589747_589745' class='wpd-comment wpd-reply wpd_comment_level-4'><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <img alt='tkaiser' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo lazyload' height='64' width='64' data-src="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='tkaiser' src='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-eio="l" /></noscript>
</div>
    
    
</div>
    <div id="comment-589747" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    tkaiser
</div>
    <div class="wpd-comment-date" title="January 13, 2022 23:10">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=&gt; someone recently reported “he has... &url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589747' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589747'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    &nbsp;
    <a href="#comment-589745">
        Igor
    </a>
</div>
    <div class="wpd-comment-text">
    <p>&gt; someone recently reported “he has to have full control over his memory, so he is disabling zram 1st”</p>
<p>There are also people who still run a monthly defrag on their SSDs.</p>
<p>Anyway it seems you still confuse zram with zswap&#8230;</p>

</div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589747_589745'></div></div></div></div></div><div id='wpd-comm-589736_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <img alt='tkaiser' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo lazyload' height='64' width='64' data-src="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='tkaiser' src='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-eio="l" /></noscript>
</div>
    
    
</div>
    <div id="comment-589736" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    tkaiser
</div>
    <div class="wpd-comment-date" title="January 13, 2022 18:24">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=&gt; Or simply edit /boot/firmware/cmd... &url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589736' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589736'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>&gt; Or simply edit /boot/firmware/cmdline.txt file, and add the line</p>
<p>That&#8217;s not a good idea to add lines to cmdline.txt since ThreadX (that&#8217;s the OS parsing the secondary OS&#8217;s kernel params) can&#8217;t cope with multiple lines. &#8216;zswap.enabled=1&#8217; needs to be appended separated by spaces to the one existing line.</p>

</div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies" wpd-tooltip-position='left'>
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589736_0'></div><div id='wpd-comm-589739_589736' class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <a href='https://www.cnx-software.com/author/cnxsoft/' target='_blank' rel='noreferrer ugc'><img alt='Jean-Luc Aufranc (CNXSoft)' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo sab-custom-avatar lazyload' height='64' width='64' data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/02/jean-luc-aufranc-cnxsoft.jpg?lossy=1&ssl=1" data-srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/02/jean-luc-aufranc-cnxsoft.jpg?lossy=1&ssl=1 2x" data-eio-rwidth="250" data-eio-rheight="187" /><noscript><img alt='Jean-Luc Aufranc (CNXSoft)' src='https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/02/jean-luc-aufranc-cnxsoft.jpg?lossy=1&ssl=1' srcset='https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/02/jean-luc-aufranc-cnxsoft.jpg?lossy=1&ssl=1 2x' class='avatar avatar-64 photo sab-custom-avatar' height='64' width='64' data-eio="l" /></noscript></a>
</div>
    <div class="wpd-comment-label" wpd-tooltip="Author" wpd-tooltip-position="right">
    <span>Author</span>
</div>
    
</div>
    <div id="comment-589739" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    <a href='https://www.cnx-software.com/author/cnxsoft/' rel='noreferrer ugc' target='_blank'>Jean-Luc Aufranc (CNXSoft)</a><span class='wpd-user-nicename' data-wpd-clipboard='@cnxsoft'>(@cnxsoft)</span>
</div>
    <div class="wpd-comment-date" title="January 13, 2022 19:53">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=I see. I mixed up with config.txt.
&url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589739' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589739'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    &nbsp;
    <a href="#comment-589736">
        tkaiser
    </a>
</div>
    <div class="wpd-comment-text">
    <p>I see. I mixed up with config.txt.</p>

</div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies" wpd-tooltip-position='left'>
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589739_589736'></div><div id='wpd-comm-589741_589739' class='wpd-comment wpd-reply wpd_comment_level-3'><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <img alt='tkaiser' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo lazyload' height='64' width='64' data-src="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='tkaiser' src='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-eio="l" /></noscript>
</div>
    
    
</div>
    <div id="comment-589741" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    tkaiser
</div>
    <div class="wpd-comment-date" title="January 13, 2022 20:05">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=BTW: I would believe the initramfs stu... &url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589741' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589741'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    &nbsp;
    <a href="#comment-589739">
        Jean-Luc Aufranc (CNXSoft)
    </a>
</div>
    <div class="wpd-comment-text">
    <p>BTW: I would believe the initramfs stuff is still important (at least on x86 it&#8217;s needed to get things working as desired). Maybe you can test since the Internet is full of wrong tutorials that get copy&amp;pasted over and over again&#8230;</p>

</div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589741_589739'></div></div></div></div><div id='wpd-comm-589737_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <img alt='tkaiser' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo lazyload' height='64' width='64' data-src="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='tkaiser' src='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-eio="l" /></noscript>
</div>
    
    
</div>
    <div id="comment-589737" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    tkaiser
</div>
    <div class="wpd-comment-date" title="January 13, 2022 18:29">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=&gt; I understand zram is like a compr... &url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589737' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589737'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>&gt; I understand zram is like a compressed swap that resides in RAM</p>
<p>It can also use a &#8216;backing device&#8217; since some kernel version and could always be combined with regular swap files/partitions which has its own drawbacks (see comments in the linked &#8216;<a rel="nofollow"href="https://www.cnx-software.com/2018/05/14/running-out-of-ram-in-ubuntu-enable-zram/">enabling ZRAM in Ubuntu</a>&#8216; thread).</p>
<p>In general zram is great if swap on storage should be avoided which applies especially to SBC running off flash memory with horribly low random I/O performance and low endurance (AKA &#8216;average SD card&#8217;).</p>

</div><div class='wpd-comment-last-edited'><i class='far fa-edit'></i></div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589737_0'></div></div><div id='wpd-comm-589742_0' class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <img alt='dgp' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo lazyload' height='64' width='64' data-src="https://secure.gravatar.com/avatar/e55839b7b7dac2a872d25fd188cee894?s=64&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/e55839b7b7dac2a872d25fd188cee894?s=128&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='dgp' src='https://secure.gravatar.com/avatar/e55839b7b7dac2a872d25fd188cee894?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e55839b7b7dac2a872d25fd188cee894?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-eio="l" /></noscript>
</div>
    
    
</div>
    <div id="comment-589742" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    dgp
</div>
    <div class="wpd-comment-date" title="January 13, 2022 20:23">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=Bit depressing that ubuntu can&#8217;t... &url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589742' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589742'></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>Bit depressing that ubuntu can&#8217;t run in 2GB of RAM without this. I&#8217;m not one of those save every K on machines with 32 or 64GB of RAM people but how much is ubuntu really doing to not be able to fit into 2GB of RAM + a bit of swap. Is it all of the overlayed squashfs crap?</p>
<p>That said apt-get on a bare minimum Debian install causes OOMs on a 128MB machine. Pretty sure that used to work fine a few years ago.</p>

</div><div class='wpd-comment-last-edited'><i class='far fa-edit'></i></div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    <div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies" wpd-tooltip-position='left'>
    <i class='fas fa-chevron-up'></i>
</div>
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589742_0'></div><div id='wpd-comm-589743_589742' class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left ">
    <div class="wpd-avatar ">
    <img alt='tkaiser' src='data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 64 64'%3E%3C/svg%3E'  class='avatar avatar-64 photo lazyload' height='64' width='64' data-src="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&d=mm&r=g" data-srcset="https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x" data-eio-rwidth="" data-eio-rheight="" /><noscript><img alt='tkaiser' src='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/25c0b984d190269875919c1969cb28b1?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-eio="l" /></noscript>
</div>
    
    
</div>
    <div id="comment-589743" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author ">
    tkaiser
</div>
    <div class="wpd-comment-date" title="January 13, 2022 20:45">
    <i class='far fa-clock' aria-hidden='true'></i>
    2 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class='fas fa-share-alt' aria-hidden='true'></i>
    <div class="wpd-tooltip-content">
        <a class='wc_tw' rel='noreferrer' target='_blank' href='https://twitter.com/intent/tweet?text=&gt; Bit depressing that ubuntu can’t ... &url=https%3A%2F%2Fwww.cnx-software.com%2F2022%2F01%2F13%2Fubuntu-22-04-zswap-raspberry-pi-4-2gb-ram%2F%23comment-589743' title='Share On Twitter'><i class='fab fa-twitter wpf-cta' aria-hidden='true'></i></a><a class='wc_vk' rel='noreferrer' target='_blank' href='https://vk.com/share.php?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On VKontakte'><i class='fab fa-vk wpf-cta' aria-hidden='true'></i></a><a class='wc_ok' rel='noreferrer' target='_blank' href='https://connect.ok.ru/offer?url=https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/' title='Share On Odnoklassniki'><i class='fab fa-odnoklassniki wpf-cta' aria-hidden='true'></i></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip='' wpd-tooltip-position='left'><i class='fas fa-link' aria-hidden='true' data-wpd-clipboard='https://www.cnx-software.com/2022/01/13/ubuntu-22-04-zswap-raspberry-pi-4-2gb-ram/#comment-589743'></i></span>
</div>
</div>
    <div class="wpd-reply-to">
    <i class='far fa-comments'></i>
    &nbsp;
    <a href="#comment-589742">
        dgp
    </a>
</div>
    <div class="wpd-comment-text">
    <p>&gt; Bit depressing that ubuntu can’t run in 2GB of RAM without this</p>
<p>Huh? That works perfectly fine. But here it&#8217;s not about Ubuntu in general but about something else: <a rel="nofollow"href="https://ubuntu.com/tutorials/how-to-install-ubuntu-desktop-on-raspberry-pi-4" rel="nofollow ugc">https://ubuntu.com/tutorials/how-to-install-ubuntu-desktop-on-raspberry-pi-4</a></p>
<p>They advertise this as a fully functional desktop (IDE, tons of browser tabs open) and oviously configure swap on the rootfs which simply sucks once it happens on slow SD cards. Enabling zswap is a cheap &#8216;fix&#8217;.</p>

</div>
    <div class="wpd-comment-footer">
    
    <div class="wpd-reply-button">
    <svg xmlns='https://www.w3.org/2000/svg' viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill='none'/></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id='wpdiscuz_form_anchor-589743_589742'></div></div></div><!-- // From wpDiscuz's Caches // -->                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
            </div>
                </div>
        </div>
    <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar-unauth"></div>
    <div id="wpdiscuz-comment-message" class="wpdiscuz-comment-message-unauth"></div>
    <div class="gxmas gxmas-2"><div class="gxmas-single axmas-9"><div style="margin: 0 auto;text-align:center">Advertisement</div>
<!-- TAGNAME:  Desktop Main Body Bottom 728x90 React -->
<!-- /8095840/.2_A.35142.3_cnx-software.com_tier1 -->
<div id='div-gpt-ad-cnx-softwarecom35142' style='height:90px; width:728px;display: block; margin: auto;'></div></div></div>
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.cnx-software.com/2022/01/13/pcie-6-0-delivers-up-to-256-gb-s-for-big-data-applications/" rel="prev"><span class="screen-reader-text">Previous Post</span><span aria-hidden="true" class="nav-subtitle">Previous</span> <span class="nav-title"><span class="nav-title-icon-wrapper"><svg class="icon icon-arrow-left" aria-hidden="true" role="img"> <use href="#icon-arrow-left" xlink:href="#icon-arrow-left"></use> </svg></span>PCIe 6.0 delivers up to 256 GB/s for Big Data applications</span></a></div><div class="nav-next"><a href="https://www.cnx-software.com/2022/01/13/liva-q3-plus-pocket-sized-amd-ryzen-embedded-mini-pc/" rel="next"><span class="screen-reader-text">Next Post</span><span aria-hidden="true" class="nav-subtitle">Next</span> <span class="nav-title">LIVA Q3 Plus pocket-sized AMD Ryzen Embedded mini PC sells for $242 and up<span class="nav-title-icon-wrapper"><svg class="icon icon-arrow-right" aria-hidden="true" role="img"> <use href="#icon-arrow-right" xlink:href="#icon-arrow-right"></use> </svg></span></span></a></div></div>
	</nav>
		</main><!-- #main -->
	</div><!-- #primary -->
	
<aside id="secondary" class="widget-area" role="complementary" aria-label="Blog Sidebar">
	<section id="search-3" class="widget widget_search"><form  class="is-search-form is-form-style is-form-style-3 is-form-id-87358 " action="https://www.cnx-software.com/" method="get" role="search" ><label for="is-search-input-87358"><span class="is-screen-reader-text">Search for:</span><input  type="search" id="is-search-input-87358" name="s" value="" class="is-search-input" placeholder="Search here..." autocomplete=off /></label><button type="submit" class="is-search-submit"><span class="is-screen-reader-text">Search Button</span><span class="is-search-icon"><svg focusable="false" aria-label="Search" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" width="24px"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path></svg></span></button><input type="hidden" name="post_type" value="post" /></form></section><section id="text-22" class="widget widget_text">			<div class="textwidget"><div style="margin: 0 auto;text-align:center"><a class="sidebar-social" href="https://web.facebook.com/cnxsoft" target="_blank" rel="noopener nofollow"><span class="simple-icon-facebook" style="fill:#1877F2; height:32px; width:32px;"><svg role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>Facebook</title><path d="M24 12.073c0-6.627-5.373-12-12-12s-12 5.373-12 12c0 5.99 4.388 10.954 10.125 11.854v-8.385H7.078v-3.47h3.047V9.43c0-3.007 1.792-4.669 4.533-4.669 1.312 0 2.686.235 2.686.235v2.953H15.83c-1.491 0-1.956.925-1.956 1.874v2.25h3.328l-.532 3.47h-2.796v8.385C19.612 23.027 24 18.062 24 12.073z" /></svg></span></a>  <a class="sidebar-social" href="https://twitter.com/cnxsoft" target="_blank" rel="noopener nofollow"><span class="simple-icon-twitter" style="fill:#1DA1F2; height:32px; width:32px;"><svg role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>Twitter</title><path d="M23.953 4.57a10 10 0 01-2.825.775 4.958 4.958 0 002.163-2.723c-.951.555-2.005.959-3.127 1.184a4.92 4.92 0 00-8.384 4.482C7.69 8.095 4.067 6.13 1.64 3.162a4.822 4.822 0 00-.666 2.475c0 1.71.87 3.213 2.188 4.096a4.904 4.904 0 01-2.228-.616v.06a4.923 4.923 0 003.946 4.827 4.996 4.996 0 01-2.212.085 4.936 4.936 0 004.604 3.417 9.867 9.867 0 01-6.102 2.105c-.39 0-.779-.023-1.17-.067a13.995 13.995 0 007.557 2.209c9.053 0 13.998-7.496 13.998-13.985 0-.21 0-.42-.015-.63A9.935 9.935 0 0024 4.59z" /></svg></span></a>   <a class="sidebar-social" href="https://www.linkedin.com/company/cnx-software" target="_blank" rel="noopener nofollow"><span class="simple-icon-linkedin" style="fill:#0A66C2; height:32px; width:32px;"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>LinkedIn</title><path d="M20.447 20.452h-3.554v-5.569c0-1.328-.027-3.037-1.852-3.037-1.853 0-2.136 1.445-2.136 2.939v5.667H9.351V9h3.414v1.561h.046c.477-.9 1.637-1.85 3.37-1.85 3.601 0 4.267 2.37 4.267 5.455v6.286zM5.337 7.433c-1.144 0-2.063-.926-2.063-2.065 0-1.138.92-2.063 2.063-2.063 1.14 0 2.064.925 2.064 2.063 0 1.139-.925 2.065-2.064 2.065zm1.782 13.019H3.555V9h3.564v11.452zM22.225 0H1.771C.792 0 0 .774 0 1.729v20.542C0 23.227.792 24 1.771 24h20.451C23.2 24 24 23.227 24 22.271V1.729C24 .774 23.2 0 22.222 0h.003z" /></svg></span></a>  <a class="sidebar-social noskim" href="https://mewe.com/group/5be39b2273cd9f0ce95b40f0" target="_blank" rel="noopener nofollow"><span class="simple-icon-mewe" style="fill:#17377F; height:32px; width:32px;"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>MeWe</title><path d="M3.029 7.712a.768.768 0 100 1.536.768.768 0 000-1.536zm7.883 0a.768.768 0 100 1.536.768.768 0 000-1.536zm4.414 0a.768.768 0 100 1.536.768.768 0 000-1.536zm4.418 0a.768.768 0 100 1.537.768.768 0 000-1.537zm-4.447 2.307c-.27 0-.453.175-.54.428l-1.378 4.175-1.403-4.193a.546.546 0 00-.532-.392c-.296 0-.55.227-.55.523 0 .07.018.148.044.21l1.805 5.056c.105.279.296.444.558.444h.105c.261 0 .461-.165.557-.444l1.36-3.985 1.36 3.985c.096.279.288.444.55.444h.105c.261 0 .462-.174.558-.444l1.804-5.057a.617.617 0 00.052-.218.525.525 0 00-.531-.514c-.262 0-.445.166-.523.383l-1.404 4.202-1.377-4.175c-.079-.253-.27-.428-.541-.428zM.54 10.045a.538.538 0 00-.54.541v5.117c0 .297.227.523.523.523a.52.52 0 00.532-.523V12.05l1.482 2.224c.113.174.253.279.444.279.201 0 .34-.105.454-.28l1.49-2.24v3.661a.54.54 0 00.533.532.53.53 0 00.54-.532v-5.108a.538.538 0 00-.54-.54h-.114a.54.54 0 00-.488.278L3 13.227 1.15 10.333a.565.565 0 00-.497-.288zm8.368 1.439c-1.316 0-2.25 1.081-2.25 2.397v.018c0 1.42 1.03 2.389 2.363 2.389.715 0 1.239-.236 1.657-.61a.46.46 0 00.14-.323.415.415 0 00-.419-.427.391.391 0 00-.27.096 1.655 1.655 0 01-1.09.4c-.68 0-1.212-.418-1.325-1.168h2.885c.27 0 .497-.209.497-.505 0-1.064-.723-2.267-2.188-2.267zm12.904 0c-1.317 0-2.25 1.081-2.25 2.397v.018c0 1.42 1.029 2.389 2.363 2.389.715 0 1.238-.236 1.657-.61a.46.46 0 00.139-.323.415.415 0 00-.418-.427.392.392 0 00-.271.096 1.652 1.652 0 01-1.09.4c-.68 0-1.211-.418-1.325-1.168h2.886c.27 0 .497-.209.497-.505 0-1.064-.724-2.267-2.188-2.267zm-12.913.863c.698 0 1.099.532 1.169 1.212H7.705c.096-.715.549-1.212 1.194-1.212zm12.904 0c.697 0 1.098.532 1.168 1.212h-2.363c.096-.715.55-1.212 1.195-1.212z" /></svg></span></a>  <a class="sidebar-social" href="https://www.youtube.com/cnxlinux" target="_blank" rel="noopener nofollow"><span class="simple-icon-youtube" style="fill:#FF0000; height:32px; width:32px;"><svg role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>YouTube</title><path d="M23.498 6.186a3.016 3.016 0 0 0-2.122-2.136C19.505 3.545 12 3.545 12 3.545s-7.505 0-9.377.505A3.017 3.017 0 0 0 .502 6.186C0 8.07 0 12 0 12s0 3.93.502 5.814a3.016 3.016 0 0 0 2.122 2.136c1.871.505 9.376.505 9.376.505s7.505 0 9.377-.505a3.015 3.015 0 0 0 2.122-2.136C24 15.93 24 12 24 12s0-3.93-.502-5.814zM9.545 15.568V8.432L15.818 12l-6.273 3.568z" /></svg></span></a>  <a class="sidebar-social" href="https://www.cnx-software.com/feed" target="_blank" rel="noopener nofollow"><span class="simple-icon-rss" style="fill:#FFA500; height:32px; width:32px;"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>RSS</title><path d="M19.199 24C19.199 13.467 10.533 4.8 0 4.8V0c13.165 0 24 10.835 24 24h-4.801zM3.291 17.415c1.814 0 3.293 1.479 3.293 3.295 0 1.813-1.485 3.29-3.301 3.29C1.47 24 0 22.526 0 20.71s1.475-3.294 3.291-3.295zM15.909 24h-4.665c0-6.169-5.075-11.245-11.244-11.245V8.09c8.727 0 15.909 7.184 15.909 15.91z" /></svg></span></a></div>
</div>
		</section><section id="text-10" class="widget widget_text">			<div class="textwidget"><div class="gxmas gxmas-5"><div class="gxmas-single axmas-59"><div>
<a href="https://url2.cnx-software.com/CpvDD" rel="nofollow noopener" target="_blank"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 300 250'%3E%3C/svg%3E" alt="COM-HPC server type" width="300" height="250" style="display: block; margin: auto;" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/COM-HPC-Server-Type.jpg?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="300" data-eio-rheight="250"><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/COM-HPC-Server-Type.jpg?lossy=1&ssl=1" alt="COM-HPC server type" width="300" height="250" style="display: block; margin: auto;" data-eio="l"></noscript></a></div></div></div></div>
		</section>
<section id="wpp-2" class="widget popular-posts">
<h2 class="widget-title">Trending Posts &#8211; Last 7 Days</h2>


<ul class="wpp-list">
<li> <a href="https://www.cnx-software.com/2022/01/09/rock5-model-b-rk3588-single-board-computer/" class="wpp-post-title" target="_self">ROCK5 Model B RK3588 single board computer is up for pre-order for $79 and up</a> <span class="wpp-meta post-stats"><span class="wpp-views">14.4k views</span> | <span class="wpp-comments">54 comments</span></span></li>
<li> <a href="https://www.cnx-software.com/2022/01/06/the-death-of-transformers-ac-direct-dc-enabler-is-a-solid-state-solution-for-ac-dc-power-supplies/" class="wpp-post-title" target="_self">The death of transformers? AC Direct DC Enabler is a solid-state solution for AC-DC power supplies</a> <span class="wpp-meta post-stats"><span class="wpp-views">5.5k views</span> | <span class="wpp-comments">1 comment</span></span></li>
<li> <a href="https://www.cnx-software.com/2022/01/15/usb-add-on-boards-leverage-raspberry-pi-zero-test-pads-usb-gadget-mode/" class="wpp-post-title" target="_self">USB add-on boards leverage Raspberry Pi Zero test pads, USB Gadget mode</a> <span class="wpp-meta post-stats"><span class="wpp-views">4.8k views</span> | <span class="wpp-comments">2 comments</span></span></li>
<li> <a href="https://www.cnx-software.com/2022/01/13/raspberry-pi-cm4-nano-industrial-mini-pc-supports-wide-temperature-range-12-18v-dc-input/" class="wpp-post-title" target="_self">Raspberry Pi CM4 Nano industrial mini PC supports wide temperature range, 12-18V DC input</a> <span class="wpp-meta post-stats"><span class="wpp-views">3.3k views</span> | <span class="wpp-comments">4 comments</span></span></li>
<li> <a href="https://www.cnx-software.com/2022/01/11/microchip-sam-l22-board-makes-casio-f-91w-watch-more-customizable/" class="wpp-post-title" target="_self">Microchip SAM L22 board makes Casio F-91W watch more customizable (Crowdfunding)</a> <span class="wpp-meta post-stats"><span class="wpp-views">3.3k views</span> | <span class="wpp-comments">4 comments</span></span></li>

</ul>

</section>
<section id="text-14" class="widget widget_text">			<div class="textwidget"><div style="margin: 0 auto;text-align:center"><a href="https://www.cnx-software.com/comments/feed/" rel=nofollow>Subscribe to Comments RSS Feed</a></div>
<p></p></div>
		</section><section id="text-20" class="widget widget_text"><h2 class="widget-title">SPONSORS</h2>			<div class="textwidget"><div class="gxmas gxmas-16">
<div class="gxmas-single axmas-15"><a href="https://www.gateworks.com/?utm_source=cnxsoftware&#038;utm_medium=ad&#038;utm_campaign=cnx-ad-2021-industrial-rugged-iot" rel="nofollow noopener" title="Gateworks rugged SBC" target="_blank"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 300 250'%3E%3C/svg%3E" alt="Gateworks rugged industrial IoT SBC" width="300" height="250" style="display: block; margin: auto;" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/06/gateworks-rugged-industrial-iot.webp?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="300" data-eio-rheight="250"><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/06/gateworks-rugged-industrial-iot.webp?lossy=1&ssl=1" alt="Gateworks rugged industrial IoT SBC" width="300" height="250" style="display: block; margin: auto;" data-eio="l"></noscript></a></div>
</div>
<p> <!-- Gateworks --></p>
<div class="gxmas gxmas-17">
<div class="gxmas-single axmas-16"><a href="https://ugoos.com/" rel="nofollow noopener" target="_blank" title="UGOOS products 2022"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 300 250'%3E%3C/svg%3E" alt="UGOOS products 2022" width=300 height=250 style="display: block; margin: auto;" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/ugoos-ut8-tv-box-2022.webp?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="300" data-eio-rheight="250"><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2022/01/ugoos-ut8-tv-box-2022.webp?lossy=1&ssl=1" alt="UGOOS products 2022" width=300 height=250 style="display: block; margin: auto;" data-eio="l"></noscript></a></div>
</div>
<p> <!-- Ugoos --></p>
<div class="gxmas gxmas-18">
<div class="gxmas-single axmas-24"><a href="https://www.geniatech.com/product/arm-embedded/?utm_source=cnx&#038;utm_medium=ad" rel="nofollow noopener" target="_blank" title="RK3399Pro SBC"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 300 250'%3E%3C/svg%3E" alt="RK3399Pro SBC" width=300 height=250 style="display: block; margin: auto;" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/06/rockchip-sbc-10s.webp?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="300" data-eio-rheight="250"><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/06/rockchip-sbc-10s.webp?lossy=1&ssl=1" alt="RK3399Pro SBC" width=300 height=250 style="display: block; margin: auto;" data-eio="l"></noscript></a></div>
</div>
<p> <!-- Geniatech --></p>
<div class="gxmas gxmas-19">
<div class="gxmas-single axmas-28"><a href="http://www.rikomagic.com/en/product/showpro_id_115_pid_20.html" rel="nofollow noopener" target="_blank"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 300 250'%3E%3C/svg%3E" alt="DS03 digital signage" width="300" height="250" style="display: block; margin: auto;" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/03/digital-signage-ds3.jpg?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="300" data-eio-rheight="250"><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/03/digital-signage-ds3.jpg?lossy=1&ssl=1" alt="DS03 digital signage" width="300" height="250" style="display: block; margin: auto;" data-eio="l"></noscript></a></div>
</div>
<p> <!-- Rikomagic --></p>
<div class="gxmas gxmas-20">
<div class="gxmas-single axmas-94"><a href="https://www.stationpc.com/product/stationm2" rel="nofollow noopener" target="_blank" title="Firefly Station M2"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 300 250'%3E%3C/svg%3E" alt="Station M2 Geek Computer"  width="300" height="250" style="display: block; margin: auto;" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/06/station-m2-geek-computer.jpg?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="300" data-eio-rheight="250"><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/06/station-m2-geek-computer.jpg?lossy=1&ssl=1" alt="Station M2 Geek Computer"  width="300" height="250" style="display: block; margin: auto;" data-eio="l"></noscript></a></div>
</div>
<p> <!-- T-Chip --><br />
<!-- Either there are no banners, they are disabled or none qualified for this location! --> <!-- Congatec --></p>
<div style="margin: 0 auto; text-align: center;">Advertisement</div>
<div class="gxmas gxmas-25">
<div class="gxmas-single axmas-10"><!-- TAGNAME: Outstream_video Desktop --><br />
<!-- /8095840/.2_A.37641.46_cnx-software.com_tier1 --></p>
<div id='div-gpt-ad-cnx-softwarecom37641' style="display: block; margin: auto;"></div>
</div>
</div>
<p> <!-- PubGalaxy --></p>
</div>
		</section><section id="recent-comments-3" class="widget widget_recent_comments"><h2 class="widget-title">Recent Comments</h2><nav role="navigation" aria-label="Recent Comments"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">sander</span> on <a href="https://www.cnx-software.com/2022/01/13/pcie-6-0-delivers-up-to-256-gb-s-for-big-data-applications/#comment-589772">PCIe 6.0 delivers up to 256 GB/s for Big Data applications</a></li><li class="recentcomments"><span class="comment-author-link">Dev</span> on <a href="https://www.cnx-software.com/2022/01/14/khadas-tea-magsafe-hi-fi-headphone-amplifier-lossless-audio-smartphone/#comment-589771">Khadas Tea &#8211; A MagSafe Hi-Fi headphone amplifier to play lossless audio on smartphones (Crowdfunding)</a></li><li class="recentcomments"><span class="comment-author-link">rbm78bln</span> on <a href="https://www.cnx-software.com/2022/01/15/usb-add-on-boards-leverage-raspberry-pi-zero-test-pads-usb-gadget-mode/#comment-589770">USB add-on boards leverage Raspberry Pi Zero test pads, USB Gadget mode</a></li><li class="recentcomments"><span class="comment-author-link">P.P.A.</span> on <a href="https://www.cnx-software.com/2022/01/15/usb-add-on-boards-leverage-raspberry-pi-zero-test-pads-usb-gadget-mode/#comment-589769">USB add-on boards leverage Raspberry Pi Zero test pads, USB Gadget mode</a></li><li class="recentcomments"><span class="comment-author-link">JDm</span> on <a href="https://www.cnx-software.com/2021/07/12/nodemcu-esp32-c3-wifi-ble-iot-boards/#comment-589767">NodeMCU ESP32-C3 WiFi &#038; BLE IoT boards show up for about $4</a></li></ul></nav></section><section id="text-13" class="widget widget_text">			<div class="textwidget"><div class="gxmas gxmas-6"><div class="gxmas-single axmas-26"><div style="margin: 0 auto;text-align:center">Advertisement</div>
<!-- TAGNAME: 300x600 BTF Right Sidebar Homepage -->
<!-- /8095840/.2_A.35141.7_cnx-software.com_tier1 -->
<div id='div-gpt-ad-cnx-softwarecom35141' style='height:600px; width:300px;display: block; margin: auto;'></div></div></div></div>
		</section><section id="recent-posts-widget-with-thumbnails-2" class="widget recent-posts-widget-with-thumbnails">
<div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
<h2 class="widget-title">Latest Reviews</h2>
	<nav role="navigation" aria-label="Latest Reviews">
	<ul>
		<li><a href="https://www.cnx-software.com/2022/01/09/reolink-go-plus-4g-review-solar-powered-4g-lte-security-camera-with-person-vehicle-detection/"><img width="58" height="58" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 58 58'%3E%3C/svg%3E" class="attachment-58x58 size-58x58 wp-post-image lazyload" alt="Reolink Go Plus 4G Review"   data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review.jpg?lossy=1&resize=58%2C58&ssl=1" data-srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review.jpg?lossy=1&amp;resize=58%2C58&amp;ssl=1 58w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review-100x100.jpg?lossy=1&amp;ssl=1 100w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review-120x120.jpg?lossy=1&amp;ssl=1 120w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review.jpg?lossy=1&amp;zoom=3&amp;resize=58%2C58&amp;ssl=1 174w" data-sizes="auto" data-eio-rwidth="58" data-eio-rheight="58" /><noscript><img width="58" height="58" src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review.jpg?lossy=1&amp;resize=58%2C58&amp;ssl=1" class="attachment-58x58 size-58x58 wp-post-image" alt="Reolink Go Plus 4G Review" srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review.jpg?lossy=1&amp;resize=58%2C58&amp;ssl=1 58w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review-100x100.jpg?lossy=1&amp;ssl=1 100w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review-120x120.jpg?lossy=1&amp;ssl=1 120w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Reolink-Go-Plus-Review.jpg?lossy=1&amp;zoom=3&amp;resize=58%2C58&amp;ssl=1 174w" sizes="100vw" data-eio="l" /></noscript><span class="rpwwt-post-title">Reolink Go Plus 4G review &#8211; Part 2: A Solar-powered 4G LTE security camera with person &#038; vehicle detection</span></a><div class="rpwwt-post-excerpt">Last month, I received Reolink Go Plus 4G smart security camera with 4G LTE connectivity, vehicle/human <span class="rpwwt-post-excerpt-more"> […]</span></div></li>
		<li><a href="https://www.cnx-software.com/2021/12/26/beelink-gti11-review-part-2-ubuntu-20-04-on-an-intel-core-i5-1135g7-mini-pc/"><img width="58" height="58" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 58 58'%3E%3C/svg%3E" class="attachment-58x58 size-58x58 wp-post-image lazyload" alt=""   data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review.jpg?lossy=1&resize=58%2C58&ssl=1" data-srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review.jpg?lossy=1&amp;resize=58%2C58&amp;ssl=1 58w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review-100x100.jpg?lossy=1&amp;ssl=1 100w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review-120x120.jpg?lossy=1&amp;ssl=1 120w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review.jpg?lossy=1&amp;zoom=3&amp;resize=58%2C58&amp;ssl=1 174w" data-sizes="auto" data-eio-rwidth="58" data-eio-rheight="58" /><noscript><img width="58" height="58" src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review.jpg?lossy=1&amp;resize=58%2C58&amp;ssl=1" class="attachment-58x58 size-58x58 wp-post-image" alt="" srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review.jpg?lossy=1&amp;resize=58%2C58&amp;ssl=1 58w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review-100x100.jpg?lossy=1&amp;ssl=1 100w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review-120x120.jpg?lossy=1&amp;ssl=1 120w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/Beelink-GTi11-Ubuntu-review.jpg?lossy=1&amp;zoom=3&amp;resize=58%2C58&amp;ssl=1 174w" sizes="100vw" data-eio="l" /></noscript><span class="rpwwt-post-title">Beelink GTi11 review &#8211; Part 2: Ubuntu 20.04 on an Intel Core i5-1135G7 mini PC</span></a><div class="rpwwt-post-excerpt">Previously I reviewed Beelink’s new GTi11 Intel Tiger Lake mini PC running Windows 11, so in this part, I <span class="rpwwt-post-excerpt-more"> […]</span></div></li>
		<li><a href="https://www.cnx-software.com/2021/12/24/manufacturing-xassette-asterisk-open-source-hardware-board/"><img width="58" height="58" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 58 58'%3E%3C/svg%3E" class="attachment-58x58 size-58x58 wp-post-image lazyload" alt=""   data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board.jpg?lossy=1&resize=58%2C58&ssl=1" data-srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board.jpg?lossy=1&amp;resize=58%2C58&amp;ssl=1 58w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board-100x100.jpg?lossy=1&amp;ssl=1 100w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board-120x120.jpg?lossy=1&amp;ssl=1 120w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board.jpg?lossy=1&amp;zoom=3&amp;resize=58%2C58&amp;ssl=1 174w" data-sizes="auto" data-eio-rwidth="58" data-eio-rheight="58" /><noscript><img width="58" height="58" src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board.jpg?lossy=1&amp;resize=58%2C58&amp;ssl=1" class="attachment-58x58 size-58x58 wp-post-image" alt="" srcset="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board.jpg?lossy=1&amp;resize=58%2C58&amp;ssl=1 58w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board-100x100.jpg?lossy=1&amp;ssl=1 100w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board-120x120.jpg?lossy=1&amp;ssl=1 120w, https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/manufacturing-open-source-hardware-board.jpg?lossy=1&amp;zoom=3&amp;resize=58%2C58&amp;ssl=1 174w" sizes="100vw" data-eio="l" /></noscript><span class="rpwwt-post-title">Manufacturing samples of Xassette-Asterisk open-source hardware board</span></a><div class="rpwwt-post-excerpt">We covered Xassette-Asterisk open source-hardware Allwinner D1s RISC-V Linux SBC last October. But it will <span class="rpwwt-post-excerpt-more"> […]</span></div></li>
	</ul>
	</nav>
</div><!-- .rpwwt-widget -->
</section><section id="text-19" class="widget widget_text">			<div class="textwidget"><div style="margin: 0 auto; text-align: center;"><a title="Follow CNX Software on Google News" href="https://news.google.com/publications/CAAiEOXZ6HhDZkCSmH1JfR9AcXMqFAgKIhDl2eh4Q2ZAkph9SX0fQHFz?hl=en-US&amp;gl=US&amp;ceid=US%3Aen" target="_blank" rel="nofollow noopener"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 300 82'%3E%3C/svg%3E" alt="Follow CNX Software on Google News" width="300" height="82" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/07/Google-News-CNX-Software-Grey.jpg?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="300" data-eio-rheight="82" /><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/07/Google-News-CNX-Software-Grey.jpg?lossy=1&ssl=1" alt="Follow CNX Software on Google News" width="300" height="82" data-eio="l" /></noscript></a></div>
</div>
		</section><section id="text-24" class="widget widget_text">			<div class="textwidget"><div style="margin: 0 auto; text-align: center;"><a title="Subscribe to CNX Software by email" href="https://follow.it/cnx-software-embedded-systems-news?action=followPub" target="_blank" rel="nofollow noopener"><img style="display: block; margin: auto;" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 320 58'%3E%3C/svg%3E" alt="Email subscription" width="320" height="58" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/08/cnx-software-email-subscription.png?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="320" data-eio-rheight="58" /><noscript><img style="display: block; margin: auto;" src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/08/cnx-software-email-subscription.png?lossy=1&ssl=1" alt="Email subscription" width="320" height="58" data-eio="l" /></noscript></a></div>
<p><a id='unic-gdpr' onclick='__tcfapi("openunic");return false;' style='display:none;cursor:pointer;'>Change Ad Consent</a><br />
<a id='unic-ccpa' onclick="window.__uspapi('openunic')" style='display:none;cursor:pointer;'>Do not sell my data</a></p>
</div>
		</section></aside><!-- #secondary -->
</div><!-- .wrap -->


                </div><!-- #content -->

                <footer id="colophon" class="site-footer" role="contentinfo">
                        <div class="wrap">
                                

	<aside class="widget-area" role="complementary" aria-label="Footer">
					<div class="widget-column footer-widget-1">
				<section id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">Copyright 2021 - CNX Software Limited</div></section>			</div>
				</aside><!-- .widget-area -->

<div class="site-info">
	<a class="privacy-policy-link" href="https://www.cnx-software.com/about/privacy-policy/">Privacy Policy</a><span role="separator" aria-hidden="true"></span></div><!-- .site-info -->
                        </div><!-- .wrap -->
                </footer><!-- #colophon -->
        </div><!-- .site-content-contain -->
</div><!-- #page -->
<!--googleoff: all--><div id="cookie-law-info-bar" data-nosnippet="true"><span>This website uses cookies to improve your experience. We'll assume you're ok with this, but if you don't like these, you can remove them <a role='button' tabindex='0' data-cli_action="accept" id="cookie_action_close_header"  class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block; ">Accept</a></span></div><div id="cookie-law-info-again" style="display:none;" data-nosnippet="true"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" data-nosnippet="true" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
	<div class="cli-modal-content cli-bar-popup">
	  	<button type="button" class="cli-modal-close" id="cliModalClose">
			<svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
			<span class="wt-cli-sr-only">Close</span>
	  	</button>
	  	<div class="cli-modal-body">
			<div class="cli-container-fluid cli-tab-container">
	<div class="cli-row">
		<div class="cli-col-12 cli-align-items-stretch cli-px-0">
			<div class="cli-privacy-overview">
				<h4>Privacy Overview</h4>				<div class="cli-privacy-content">
					<div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may affect your browsing experience.</div>
				</div>
				<a class="cli-privacy-readmore"  aria-label="Show more" tabindex="0" role="button" data-readmore-text="Show more" data-readless-text="Show less"></a>			</div>
		</div>
		<div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
												<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab">
								Necessary							</a>
							<div class="wt-cli-necessary-checkbox">
                        <input type="checkbox" class="cli-user-preference-checkbox"  id="wt-cli-checkbox-necessary" data-id="checkbox-necessary" checked="checked"  />
                        <label class="form-check-label" for="wt-cli-checkbox-necessary">Necessary</label>
                    </div>
                    <span class="cli-necessary-caption">Always Enabled</span> 						</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="necessary">
								<div class="wt-cli-cookie-description">
									Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="non-necessary" data-toggle="cli-toggle-tab">
								Non-necessary							</a>
							<div class="cli-switch">
                        <input type="checkbox" id="wt-cli-checkbox-non-necessary" class="cli-user-preference-checkbox"  data-id="checkbox-non-necessary"  checked='checked' />
                        <label for="wt-cli-checkbox-non-necessary" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Non-necessary</span></label>
                    </div>						</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="non-necessary">
								<div class="wt-cli-cookie-description">
									Any cookies that may not be particularly necessary for the website to function and is used specifically to collect user personal data via analytics, ads, other embedded contents are termed as non-necessary cookies. It is mandatory to procure user consent prior to running these cookies on your website.								</div>
							</div>
						</div>
					</div>
										</div>
	</div>
</div>
	  	</div>
	  	<div class="cli-modal-footer">
			<div class="wt-cli-element cli-container-fluid cli-tab-container">
				<div class="cli-row">
					<div class="cli-col-12 cli-align-items-stretch cli-px-0">
						<div class="cli-tab-footer wt-cli-privacy-overview-actions">
						
															<a id="wt-cli-privacy-save-btn" role="button" tabindex="0" data-cli-action="accept" class="wt-cli-privacy-btn cli_setting_save_button wt-cli-privacy-accept-btn cli-btn">SAVE & ACCEPT</a>
													</div>
						
					</div>
				</div>
			</div>
		</div>
	</div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<!--googleon: all--><a href='javascript:void(0);' id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div><div id='wpd-editor-source-code-wrapper-bg'></div><div id='wpd-editor-source-code-wrapper'><textarea id='wpd-editor-source-code'></textarea><button id='wpd-insert-source-code'>Insert</button><input type='hidden' id='wpd-editor-uid' /></div><script type="text/javascript">!function(t,e){"use strict";function n(){if(!a){a=!0;for(var t=0;t<d.length;t++)d[t].fn.call(window,d[t].ctx);d=[]}}function o(){"complete"===document.readyState&&n()}t=t||"docReady",e=e||window;var d=[],a=!1,c=!1;e[t]=function(t,e){return a?void setTimeout(function(){t(e)},1):(d.push({fn:t,ctx:e}),void("complete"===document.readyState||!document.attachEvent&&"interactive"===document.readyState?setTimeout(n,1):c||(document.addEventListener?(document.addEventListener("DOMContentLoaded",n,!1),window.addEventListener("load",n,!1)):(document.attachEvent("onreadystatechange",o),window.attachEvent("onload",n)),c=!0)))}}("wpBruiserDocReady",window);
			(function(){var wpbrLoader = (function(){var g=document,b=g.createElement('script'),c=g.scripts[0];b.async=1;b.src='https://www.cnx-software.com/?gdbc-client=3.1.43-'+(new Date()).getTime();c.parentNode.insertBefore(b,c);});wpBruiserDocReady(wpbrLoader);window.onunload=function(){};window.addEventListener('pageshow',function(event){if(event.persisted){(typeof window.WPBruiserClient==='undefined')?wpbrLoader():window.WPBruiserClient.requestTokens();}},false);})();
</script><link rel='stylesheet' id='urvanov_syntax_highlighter-css'  href='https://www.cnx-software.com/wp-content/plugins/urvanov-syntax-highlighter/css/min/urvanov_syntax_highlighter.min.css' media='all' />
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://www.cnx-software.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css' media='all' />
<script defer src='https://www.cnx-software.com/wp-content/cache/wpo-minify/1642305197/assets/wpo-minify-footer-32c50591.min.js' id='wpo_min-footer-0-js'></script>
<script id='wpo_min-footer-1-js-extra'>
var wpdiscuzAjaxObj = {"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_comment_edit_not_possible":"Sorry, this comment no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_spoiler_title":"","wc_cannot_rate_again":"","wc_not_allowed_to_rate":"","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":"","commentListLoadType":"3","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"0","wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"","commentTextMaxLength":"0","replyTextMaxLength":"0","commentTextMinLength":"1","replyTextMinLength":"1","storeCommenterData":"100000","socialLoginAgreementCheckbox":"1","enableFbLogin":"0","fbUseOAuth2":"0","enableFbShare":"0","facebookAppID":"","facebookUseOAuth2":"0","enableGoogleLogin":"0","googleClientID":"","googleClientSecret":"","cookiehash":"124a715c5ade83307a762f41f6b1909d","isLoadOnlyParentComments":"0","scrollToComment":"1","commentFormView":"expanded","enableDropAnimation":"1","isNativeAjaxEnabled":"1","enableBubble":"0","bubbleLiveUpdate":"0","bubbleHintTimeout":"45","bubbleHintHideTimeout":"10","cookieHideBubbleHint":"wpdiscuz_hide_bubble_hint","bubbleShowNewCommentMessage":"1","bubbleLocation":"content_left","firstLoadWithAjax":"0","wc_copied_to_clipboard":"","inlineFeedbackAttractionType":"blink","loadRichEditor":"1","wpDiscuzReCaptchaSK":"","wpDiscuzReCaptchaTheme":"light","wpDiscuzReCaptchaVersion":"2.0","wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","wpDiscuzIsShowOnSubscribeForm":"0","wmuEnabled":"1","wmuInput":"wmu_files","wmuMaxFileCount":"1","wmuMaxFileSize":"2097152","wmuPostMaxSize":"8388608","wmuIsLightbox":"1","wmuMimeTypes":{"jpg":"image\/jpeg","jpeg":"image\/jpeg","jpe":"image\/jpeg","gif":"image\/gif","png":"image\/png","bmp":"image\/bmp","tiff":"image\/tiff","tif":"image\/tiff","ico":"image\/x-icon"},"wmuPhraseConfirmDelete":"","wmuPhraseNotAllowedFile":"","wmuPhraseMaxFileCount":" 1","wmuPhraseMaxFileSize":" 2MB","wmuPhrasePostMaxSize":" 8MB","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgPostIdNotExists":"Post ID not exists","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuKeyImages":"images","wmuSingleImageWidth":"auto","wmuSingleImageHeight":"200","version":"7.3.10","wc_post_id":"95092","isCookiesEnabled":"1","loadLastCommentId":"0","dataFilterCallbacks":[],"phraseFilters":[],"scrollSize":"32","is_email_field_required":"1","url":"https:\/\/www.cnx-software.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/www.cnx-software.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","bubbleUpdateUrl":"https:\/\/www.cnx-software.com\/wp-json\/wpdiscuz\/v1\/update","restNonce":"75137017a4","validateNonceForGuests":""};
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Are you sure you want to delete this comment?","msgConfirmCancelSubscription":"Are you sure you want to cancel this subscription?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?","additionalTab":"0"};
</script>
<script defer src='https://www.cnx-software.com/wp-content/cache/wpo-minify/1642305197/assets/wpo-minify-footer-9f6f0fbe.min.js' id='wpo_min-footer-1-js'></script>
<script defer src='https://www.cnx-software.com/wp-content/cache/wpo-minify/1642305197/assets/wpo-minify-footer-7fe908cd.min.js' id='wpo_min-footer-2-js'></script>
<script id='wpo_min-footer-3-js-extra'>
var twentyseventeenScreenReaderText = {"quote":"<svg class=\"icon icon-quote-right\" aria-hidden=\"true\" role=\"img\"> <use href=\"#icon-quote-right\" xlink:href=\"#icon-quote-right\"><\/use> <\/svg>","expand":"Expand child menu","collapse":"Collapse child menu","icon":"<svg class=\"icon icon-angle-down\" aria-hidden=\"true\" role=\"img\"> <use href=\"#icon-angle-down\" xlink:href=\"#icon-angle-down\"><\/use> <span class=\"svg-fallback icon-angle-down\"><\/span><\/svg>"};
var IvorySearchVars = {"is_analytics_enabled":"1"};
var UrvanovSyntaxHighlighterSyntaxSettings = {"version":"2.8.27","is_admin":"0","ajaxurl":"https:\/\/www.cnx-software.com\/wp-admin\/admin-ajax.php","prefix":"urvanov-syntax-highlighter-","setting":"urvanov-syntax-highlighter-setting","selected":"urvanov-syntax-highlighter-setting-selected","changed":"urvanov-syntax-highlighter-setting-changed","special":"urvanov-syntax-highlighter-setting-special","orig_value":"data-orig-value","debug":""};
var UrvanovSyntaxHighlighterSyntaxStrings = {"copy":"Copied to the clipboard","minimize":"Click To Expand Code"};
</script>
<script defer src='https://www.cnx-software.com/wp-content/cache/wpo-minify/1642305197/assets/wpo-minify-footer-b6695476.min.js' id='wpo_min-footer-3-js'></script>
<svg style="position: absolute; width: 0; height: 0; overflow: hidden;" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
<defs>
<symbol id="icon-behance" viewBox="0 0 37 32">
<path class="path1" d="M33 6.054h-9.125v2.214h9.125v-2.214zM28.5 13.661q-1.607 0-2.607 0.938t-1.107 2.545h7.286q-0.321-3.482-3.571-3.482zM28.786 24.107q1.125 0 2.179-0.571t1.357-1.554h3.946q-1.786 5.482-7.625 5.482-3.821 0-6.080-2.357t-2.259-6.196q0-3.714 2.33-6.17t6.009-2.455q2.464 0 4.295 1.214t2.732 3.196 0.902 4.429q0 0.304-0.036 0.839h-11.75q0 1.982 1.027 3.063t2.973 1.080zM4.946 23.214h5.286q3.661 0 3.661-2.982 0-3.214-3.554-3.214h-5.393v6.196zM4.946 13.625h5.018q1.393 0 2.205-0.652t0.813-2.027q0-2.571-3.393-2.571h-4.643v5.25zM0 4.536h10.607q1.554 0 2.768 0.25t2.259 0.848 1.607 1.723 0.563 2.75q0 3.232-3.071 4.696 2.036 0.571 3.071 2.054t1.036 3.643q0 1.339-0.438 2.438t-1.179 1.848-1.759 1.268-2.161 0.75-2.393 0.232h-10.911v-22.5z"></path>
</symbol>
<symbol id="icon-deviantart" viewBox="0 0 18 32">
<path class="path1" d="M18.286 5.411l-5.411 10.393 0.429 0.554h4.982v7.411h-9.054l-0.786 0.536-2.536 4.875-0.536 0.536h-5.375v-5.411l5.411-10.411-0.429-0.536h-4.982v-7.411h9.054l0.786-0.536 2.536-4.875 0.536-0.536h5.375v5.411z"></path>
</symbol>
<symbol id="icon-medium" viewBox="0 0 32 32">
<path class="path1" d="M10.661 7.518v20.946q0 0.446-0.223 0.759t-0.652 0.313q-0.304 0-0.589-0.143l-8.304-4.161q-0.375-0.179-0.634-0.598t-0.259-0.83v-20.357q0-0.357 0.179-0.607t0.518-0.25q0.25 0 0.786 0.268l9.125 4.571q0.054 0.054 0.054 0.089zM11.804 9.321l9.536 15.464-9.536-4.75v-10.714zM32 9.643v18.821q0 0.446-0.25 0.723t-0.679 0.277-0.839-0.232l-7.875-3.929zM31.946 7.5q0 0.054-4.58 7.491t-5.366 8.705l-6.964-11.321 5.786-9.411q0.304-0.5 0.929-0.5 0.25 0 0.464 0.107l9.661 4.821q0.071 0.036 0.071 0.107z"></path>
</symbol>
<symbol id="icon-slideshare" viewBox="0 0 32 32">
<path class="path1" d="M15.589 13.214q0 1.482-1.134 2.545t-2.723 1.063-2.723-1.063-1.134-2.545q0-1.5 1.134-2.554t2.723-1.054 2.723 1.054 1.134 2.554zM24.554 13.214q0 1.482-1.125 2.545t-2.732 1.063q-1.589 0-2.723-1.063t-1.134-2.545q0-1.5 1.134-2.554t2.723-1.054q1.607 0 2.732 1.054t1.125 2.554zM28.571 16.429v-11.911q0-1.554-0.571-2.205t-1.982-0.652h-19.857q-1.482 0-2.009 0.607t-0.527 2.25v12.018q0.768 0.411 1.58 0.714t1.446 0.5 1.446 0.33 1.268 0.196 1.25 0.071 1.045 0.009 1.009-0.036 0.795-0.036q1.214-0.018 1.696 0.482 0.107 0.107 0.179 0.161 0.464 0.446 1.089 0.911 0.125-1.625 2.107-1.554 0.089 0 0.652 0.027t0.768 0.036 0.813 0.018 0.946-0.018 0.973-0.080 1.089-0.152 1.107-0.241 1.196-0.348 1.205-0.482 1.286-0.616zM31.482 16.339q-2.161 2.661-6.643 4.5 1.5 5.089-0.411 8.304-1.179 2.018-3.268 2.643-1.857 0.571-3.25-0.268-1.536-0.911-1.464-2.929l-0.018-5.821v-0.018q-0.143-0.036-0.438-0.107t-0.42-0.089l-0.018 6.036q0.071 2.036-1.482 2.929-1.411 0.839-3.268 0.268-2.089-0.643-3.25-2.679-1.875-3.214-0.393-8.268-4.482-1.839-6.643-4.5-0.446-0.661-0.071-1.125t1.071 0.018q0.054 0.036 0.196 0.125t0.196 0.143v-12.393q0-1.286 0.839-2.196t2.036-0.911h22.446q1.196 0 2.036 0.911t0.839 2.196v12.393l0.375-0.268q0.696-0.482 1.071-0.018t-0.071 1.125z"></path>
</symbol>
<symbol id="icon-snapchat-ghost" viewBox="0 0 30 32">
<path class="path1" d="M15.143 2.286q2.393-0.018 4.295 1.223t2.92 3.438q0.482 1.036 0.482 3.196 0 0.839-0.161 3.411 0.25 0.125 0.5 0.125 0.321 0 0.911-0.241t0.911-0.241q0.518 0 1 0.321t0.482 0.821q0 0.571-0.563 0.964t-1.232 0.563-1.232 0.518-0.563 0.848q0 0.268 0.214 0.768 0.661 1.464 1.83 2.679t2.58 1.804q0.5 0.214 1.429 0.411 0.5 0.107 0.5 0.625 0 1.25-3.911 1.839-0.125 0.196-0.196 0.696t-0.25 0.83-0.589 0.33q-0.357 0-1.107-0.116t-1.143-0.116q-0.661 0-1.107 0.089-0.571 0.089-1.125 0.402t-1.036 0.679-1.036 0.723-1.357 0.598-1.768 0.241q-0.929 0-1.723-0.241t-1.339-0.598-1.027-0.723-1.036-0.679-1.107-0.402q-0.464-0.089-1.125-0.089-0.429 0-1.17 0.134t-1.045 0.134q-0.446 0-0.625-0.33t-0.25-0.848-0.196-0.714q-3.911-0.589-3.911-1.839 0-0.518 0.5-0.625 0.929-0.196 1.429-0.411 1.393-0.571 2.58-1.804t1.83-2.679q0.214-0.5 0.214-0.768 0-0.5-0.563-0.848t-1.241-0.527-1.241-0.563-0.563-0.938q0-0.482 0.464-0.813t0.982-0.33q0.268 0 0.857 0.232t0.946 0.232q0.321 0 0.571-0.125-0.161-2.536-0.161-3.393 0-2.179 0.482-3.214 1.143-2.446 3.071-3.536t4.714-1.125z"></path>
</symbol>
<symbol id="icon-yelp" viewBox="0 0 27 32">
<path class="path1" d="M13.804 23.554v2.268q-0.018 5.214-0.107 5.446-0.214 0.571-0.911 0.714-0.964 0.161-3.241-0.679t-2.902-1.589q-0.232-0.268-0.304-0.643-0.018-0.214 0.071-0.464 0.071-0.179 0.607-0.839t3.232-3.857q0.018 0 1.071-1.25 0.268-0.339 0.705-0.438t0.884 0.063q0.429 0.179 0.67 0.518t0.223 0.75zM11.143 19.071q-0.054 0.982-0.929 1.25l-2.143 0.696q-4.911 1.571-5.214 1.571-0.625-0.036-0.964-0.643-0.214-0.446-0.304-1.339-0.143-1.357 0.018-2.973t0.536-2.223 1-0.571q0.232 0 3.607 1.375 1.25 0.518 2.054 0.839l1.5 0.607q0.411 0.161 0.634 0.545t0.205 0.866zM25.893 24.375q-0.125 0.964-1.634 2.875t-2.42 2.268q-0.661 0.25-1.125-0.125-0.25-0.179-3.286-5.125l-0.839-1.375q-0.25-0.375-0.205-0.821t0.348-0.821q0.625-0.768 1.482-0.464 0.018 0.018 2.125 0.714 3.625 1.179 4.321 1.42t0.839 0.366q0.5 0.393 0.393 1.089zM13.893 13.089q0.089 1.821-0.964 2.179-1.036 0.304-2.036-1.268l-6.75-10.679q-0.143-0.625 0.339-1.107 0.732-0.768 3.705-1.598t4.009-0.563q0.714 0.179 0.875 0.804 0.054 0.321 0.393 5.455t0.429 6.777zM25.714 15.018q0.054 0.696-0.464 1.054-0.268 0.179-5.875 1.536-1.196 0.268-1.625 0.411l0.018-0.036q-0.411 0.107-0.821-0.071t-0.661-0.571q-0.536-0.839 0-1.554 0.018-0.018 1.339-1.821 2.232-3.054 2.679-3.643t0.607-0.696q0.5-0.339 1.161-0.036 0.857 0.411 2.196 2.384t1.446 2.991v0.054z"></path>
</symbol>
<symbol id="icon-vine" viewBox="0 0 27 32">
<path class="path1" d="M26.732 14.768v3.536q-1.804 0.411-3.536 0.411-1.161 2.429-2.955 4.839t-3.241 3.848-2.286 1.902q-1.429 0.804-2.893-0.054-0.5-0.304-1.080-0.777t-1.518-1.491-1.83-2.295-1.92-3.286-1.884-4.357-1.634-5.616-1.259-6.964h5.054q0.464 3.893 1.25 7.116t1.866 5.661 2.17 4.205 2.5 3.482q3.018-3.018 5.125-7.25-2.536-1.286-3.982-3.929t-1.446-5.946q0-3.429 1.857-5.616t5.071-2.188q3.179 0 4.875 1.884t1.696 5.313q0 2.839-1.036 5.107-0.125 0.018-0.348 0.054t-0.821 0.036-1.125-0.107-1.107-0.455-0.902-0.92q0.554-1.839 0.554-3.286 0-1.554-0.518-2.357t-1.411-0.804q-0.946 0-1.518 0.884t-0.571 2.509q0 3.321 1.875 5.241t4.768 1.92q1.107 0 2.161-0.25z"></path>
</symbol>
<symbol id="icon-vk" viewBox="0 0 35 32">
<path class="path1" d="M34.232 9.286q0.411 1.143-2.679 5.25-0.429 0.571-1.161 1.518-1.393 1.786-1.607 2.339-0.304 0.732 0.25 1.446 0.304 0.375 1.446 1.464h0.018l0.071 0.071q2.518 2.339 3.411 3.946 0.054 0.089 0.116 0.223t0.125 0.473-0.009 0.607-0.446 0.491-1.054 0.223l-4.571 0.071q-0.429 0.089-1-0.089t-0.929-0.393l-0.357-0.214q-0.536-0.375-1.25-1.143t-1.223-1.384-1.089-1.036-1.009-0.277q-0.054 0.018-0.143 0.063t-0.304 0.259-0.384 0.527-0.304 0.929-0.116 1.384q0 0.268-0.063 0.491t-0.134 0.33l-0.071 0.089q-0.321 0.339-0.946 0.393h-2.054q-1.268 0.071-2.607-0.295t-2.348-0.946-1.839-1.179-1.259-1.027l-0.446-0.429q-0.179-0.179-0.491-0.536t-1.277-1.625-1.893-2.696-2.188-3.768-2.33-4.857q-0.107-0.286-0.107-0.482t0.054-0.286l0.071-0.107q0.268-0.339 1.018-0.339l4.893-0.036q0.214 0.036 0.411 0.116t0.286 0.152l0.089 0.054q0.286 0.196 0.429 0.571 0.357 0.893 0.821 1.848t0.732 1.455l0.286 0.518q0.518 1.071 1 1.857t0.866 1.223 0.741 0.688 0.607 0.25 0.482-0.089q0.036-0.018 0.089-0.089t0.214-0.393 0.241-0.839 0.17-1.446 0-2.232q-0.036-0.714-0.161-1.304t-0.25-0.821l-0.107-0.214q-0.446-0.607-1.518-0.768-0.232-0.036 0.089-0.429 0.304-0.339 0.679-0.536 0.946-0.464 4.268-0.429 1.464 0.018 2.411 0.232 0.357 0.089 0.598 0.241t0.366 0.429 0.188 0.571 0.063 0.813-0.018 0.982-0.045 1.259-0.027 1.473q0 0.196-0.018 0.75t-0.009 0.857 0.063 0.723 0.205 0.696 0.402 0.438q0.143 0.036 0.304 0.071t0.464-0.196 0.679-0.616 0.929-1.196 1.214-1.92q1.071-1.857 1.911-4.018 0.071-0.179 0.179-0.313t0.196-0.188l0.071-0.054 0.089-0.045t0.232-0.054 0.357-0.009l5.143-0.036q0.696-0.089 1.143 0.045t0.554 0.295z"></path>
</symbol>
<symbol id="icon-search" viewBox="0 0 30 32">
<path class="path1" d="M20.571 14.857q0-3.304-2.348-5.652t-5.652-2.348-5.652 2.348-2.348 5.652 2.348 5.652 5.652 2.348 5.652-2.348 2.348-5.652zM29.714 29.714q0 0.929-0.679 1.607t-1.607 0.679q-0.964 0-1.607-0.679l-6.125-6.107q-3.196 2.214-7.125 2.214-2.554 0-4.884-0.991t-4.018-2.679-2.679-4.018-0.991-4.884 0.991-4.884 2.679-4.018 4.018-2.679 4.884-0.991 4.884 0.991 4.018 2.679 2.679 4.018 0.991 4.884q0 3.929-2.214 7.125l6.125 6.125q0.661 0.661 0.661 1.607z"></path>
</symbol>
<symbol id="icon-envelope-o" viewBox="0 0 32 32">
<path class="path1" d="M29.714 26.857v-13.714q-0.571 0.643-1.232 1.179-4.786 3.679-7.607 6.036-0.911 0.768-1.482 1.196t-1.545 0.866-1.83 0.438h-0.036q-0.857 0-1.83-0.438t-1.545-0.866-1.482-1.196q-2.821-2.357-7.607-6.036-0.661-0.536-1.232-1.179v13.714q0 0.232 0.17 0.402t0.402 0.17h26.286q0.232 0 0.402-0.17t0.17-0.402zM29.714 8.089v-0.438t-0.009-0.232-0.054-0.223-0.098-0.161-0.161-0.134-0.25-0.045h-26.286q-0.232 0-0.402 0.17t-0.17 0.402q0 3 2.625 5.071 3.446 2.714 7.161 5.661 0.107 0.089 0.625 0.527t0.821 0.67 0.795 0.563 0.902 0.491 0.768 0.161h0.036q0.357 0 0.768-0.161t0.902-0.491 0.795-0.563 0.821-0.67 0.625-0.527q3.714-2.946 7.161-5.661 0.964-0.768 1.795-2.063t0.83-2.348zM32 7.429v19.429q0 1.179-0.839 2.018t-2.018 0.839h-26.286q-1.179 0-2.018-0.839t-0.839-2.018v-19.429q0-1.179 0.839-2.018t2.018-0.839h26.286q1.179 0 2.018 0.839t0.839 2.018z"></path>
</symbol>
<symbol id="icon-close" viewBox="0 0 25 32">
<path class="path1" d="M23.179 23.607q0 0.714-0.5 1.214l-2.429 2.429q-0.5 0.5-1.214 0.5t-1.214-0.5l-5.25-5.25-5.25 5.25q-0.5 0.5-1.214 0.5t-1.214-0.5l-2.429-2.429q-0.5-0.5-0.5-1.214t0.5-1.214l5.25-5.25-5.25-5.25q-0.5-0.5-0.5-1.214t0.5-1.214l2.429-2.429q0.5-0.5 1.214-0.5t1.214 0.5l5.25 5.25 5.25-5.25q0.5-0.5 1.214-0.5t1.214 0.5l2.429 2.429q0.5 0.5 0.5 1.214t-0.5 1.214l-5.25 5.25 5.25 5.25q0.5 0.5 0.5 1.214z"></path>
</symbol>
<symbol id="icon-angle-down" viewBox="0 0 21 32">
<path class="path1" d="M19.196 13.143q0 0.232-0.179 0.411l-8.321 8.321q-0.179 0.179-0.411 0.179t-0.411-0.179l-8.321-8.321q-0.179-0.179-0.179-0.411t0.179-0.411l0.893-0.893q0.179-0.179 0.411-0.179t0.411 0.179l7.018 7.018 7.018-7.018q0.179-0.179 0.411-0.179t0.411 0.179l0.893 0.893q0.179 0.179 0.179 0.411z"></path>
</symbol>
<symbol id="icon-folder-open" viewBox="0 0 34 32">
<path class="path1" d="M33.554 17q0 0.554-0.554 1.179l-6 7.071q-0.768 0.911-2.152 1.545t-2.563 0.634h-19.429q-0.607 0-1.080-0.232t-0.473-0.768q0-0.554 0.554-1.179l6-7.071q0.768-0.911 2.152-1.545t2.563-0.634h19.429q0.607 0 1.080 0.232t0.473 0.768zM27.429 10.857v2.857h-14.857q-1.679 0-3.518 0.848t-2.929 2.134l-6.107 7.179q0-0.071-0.009-0.223t-0.009-0.223v-17.143q0-1.643 1.179-2.821t2.821-1.179h5.714q1.643 0 2.821 1.179t1.179 2.821v0.571h9.714q1.643 0 2.821 1.179t1.179 2.821z"></path>
</symbol>
<symbol id="icon-twitter" viewBox="0 0 30 32">
<path class="path1" d="M28.929 7.286q-1.196 1.75-2.893 2.982 0.018 0.25 0.018 0.75 0 2.321-0.679 4.634t-2.063 4.437-3.295 3.759-4.607 2.607-5.768 0.973q-4.839 0-8.857-2.589 0.625 0.071 1.393 0.071 4.018 0 7.161-2.464-1.875-0.036-3.357-1.152t-2.036-2.848q0.589 0.089 1.089 0.089 0.768 0 1.518-0.196-2-0.411-3.313-1.991t-1.313-3.67v-0.071q1.214 0.679 2.607 0.732-1.179-0.786-1.875-2.054t-0.696-2.75q0-1.571 0.786-2.911 2.161 2.661 5.259 4.259t6.634 1.777q-0.143-0.679-0.143-1.321 0-2.393 1.688-4.080t4.080-1.688q2.5 0 4.214 1.821 1.946-0.375 3.661-1.393-0.661 2.054-2.536 3.179 1.661-0.179 3.321-0.893z"></path>
</symbol>
<symbol id="icon-facebook" viewBox="0 0 19 32">
<path class="path1" d="M17.125 0.214v4.714h-2.804q-1.536 0-2.071 0.643t-0.536 1.929v3.375h5.232l-0.696 5.286h-4.536v13.554h-5.464v-13.554h-4.554v-5.286h4.554v-3.893q0-3.321 1.857-5.152t4.946-1.83q2.625 0 4.071 0.214z"></path>
</symbol>
<symbol id="icon-github" viewBox="0 0 27 32">
<path class="path1" d="M13.714 2.286q3.732 0 6.884 1.839t4.991 4.991 1.839 6.884q0 4.482-2.616 8.063t-6.759 4.955q-0.482 0.089-0.714-0.125t-0.232-0.536q0-0.054 0.009-1.366t0.009-2.402q0-1.732-0.929-2.536 1.018-0.107 1.83-0.321t1.679-0.696 1.446-1.188 0.946-1.875 0.366-2.688q0-2.125-1.411-3.679 0.661-1.625-0.143-3.643-0.5-0.161-1.446 0.196t-1.643 0.786l-0.679 0.429q-1.661-0.464-3.429-0.464t-3.429 0.464q-0.286-0.196-0.759-0.482t-1.491-0.688-1.518-0.241q-0.804 2.018-0.143 3.643-1.411 1.554-1.411 3.679 0 1.518 0.366 2.679t0.938 1.875 1.438 1.196 1.679 0.696 1.83 0.321q-0.696 0.643-0.875 1.839-0.375 0.179-0.804 0.268t-1.018 0.089-1.17-0.384-0.991-1.116q-0.339-0.571-0.866-0.929t-0.884-0.429l-0.357-0.054q-0.375 0-0.518 0.080t-0.089 0.205 0.161 0.25 0.232 0.214l0.125 0.089q0.393 0.179 0.777 0.679t0.563 0.911l0.179 0.411q0.232 0.679 0.786 1.098t1.196 0.536 1.241 0.125 0.991-0.063l0.411-0.071q0 0.679 0.009 1.58t0.009 0.973q0 0.321-0.232 0.536t-0.714 0.125q-4.143-1.375-6.759-4.955t-2.616-8.063q0-3.732 1.839-6.884t4.991-4.991 6.884-1.839zM5.196 21.982q0.054-0.125-0.125-0.214-0.179-0.054-0.232 0.036-0.054 0.125 0.125 0.214 0.161 0.107 0.232-0.036zM5.75 22.589q0.125-0.089-0.036-0.286-0.179-0.161-0.286-0.054-0.125 0.089 0.036 0.286 0.179 0.179 0.286 0.054zM6.286 23.393q0.161-0.125 0-0.339-0.143-0.232-0.304-0.107-0.161 0.089 0 0.321t0.304 0.125zM7.036 24.143q0.143-0.143-0.071-0.339-0.214-0.214-0.357-0.054-0.161 0.143 0.071 0.339 0.214 0.214 0.357 0.054zM8.054 24.589q0.054-0.196-0.232-0.286-0.268-0.071-0.339 0.125t0.232 0.268q0.268 0.107 0.339-0.107zM9.179 24.679q0-0.232-0.304-0.196-0.286 0-0.286 0.196 0 0.232 0.304 0.196 0.286 0 0.286-0.196zM10.214 24.5q-0.036-0.196-0.321-0.161-0.286 0.054-0.25 0.268t0.321 0.143 0.25-0.25z"></path>
</symbol>
<symbol id="icon-bars" viewBox="0 0 27 32">
<path class="path1" d="M27.429 24v2.286q0 0.464-0.339 0.804t-0.804 0.339h-25.143q-0.464 0-0.804-0.339t-0.339-0.804v-2.286q0-0.464 0.339-0.804t0.804-0.339h25.143q0.464 0 0.804 0.339t0.339 0.804zM27.429 14.857v2.286q0 0.464-0.339 0.804t-0.804 0.339h-25.143q-0.464 0-0.804-0.339t-0.339-0.804v-2.286q0-0.464 0.339-0.804t0.804-0.339h25.143q0.464 0 0.804 0.339t0.339 0.804zM27.429 5.714v2.286q0 0.464-0.339 0.804t-0.804 0.339h-25.143q-0.464 0-0.804-0.339t-0.339-0.804v-2.286q0-0.464 0.339-0.804t0.804-0.339h25.143q0.464 0 0.804 0.339t0.339 0.804z"></path>
</symbol>
<symbol id="icon-google-plus" viewBox="0 0 41 32">
<path class="path1" d="M25.661 16.304q0 3.714-1.554 6.616t-4.429 4.536-6.589 1.634q-2.661 0-5.089-1.036t-4.179-2.786-2.786-4.179-1.036-5.089 1.036-5.089 2.786-4.179 4.179-2.786 5.089-1.036q5.107 0 8.768 3.429l-3.554 3.411q-2.089-2.018-5.214-2.018-2.196 0-4.063 1.107t-2.955 3.009-1.089 4.152 1.089 4.152 2.955 3.009 4.063 1.107q1.482 0 2.723-0.411t2.045-1.027 1.402-1.402 0.875-1.482 0.384-1.321h-7.429v-4.5h12.357q0.214 1.125 0.214 2.179zM41.143 14.125v3.75h-3.732v3.732h-3.75v-3.732h-3.732v-3.75h3.732v-3.732h3.75v3.732h3.732z"></path>
</symbol>
<symbol id="icon-linkedin" viewBox="0 0 27 32">
<path class="path1" d="M6.232 11.161v17.696h-5.893v-17.696h5.893zM6.607 5.696q0.018 1.304-0.902 2.179t-2.42 0.875h-0.036q-1.464 0-2.357-0.875t-0.893-2.179q0-1.321 0.92-2.188t2.402-0.866 2.375 0.866 0.911 2.188zM27.429 18.714v10.143h-5.875v-9.464q0-1.875-0.723-2.938t-2.259-1.063q-1.125 0-1.884 0.616t-1.134 1.527q-0.196 0.536-0.196 1.446v9.875h-5.875q0.036-7.125 0.036-11.554t-0.018-5.286l-0.018-0.857h5.875v2.571h-0.036q0.357-0.571 0.732-1t1.009-0.929 1.554-0.777 2.045-0.277q3.054 0 4.911 2.027t1.857 5.938z"></path>
</symbol>
<symbol id="icon-quote-right" viewBox="0 0 30 32">
<path class="path1" d="M13.714 5.714v12.571q0 1.857-0.723 3.545t-1.955 2.92-2.92 1.955-3.545 0.723h-1.143q-0.464 0-0.804-0.339t-0.339-0.804v-2.286q0-0.464 0.339-0.804t0.804-0.339h1.143q1.893 0 3.232-1.339t1.339-3.232v-0.571q0-0.714-0.5-1.214t-1.214-0.5h-4q-1.429 0-2.429-1t-1-2.429v-6.857q0-1.429 1-2.429t2.429-1h6.857q1.429 0 2.429 1t1 2.429zM29.714 5.714v12.571q0 1.857-0.723 3.545t-1.955 2.92-2.92 1.955-3.545 0.723h-1.143q-0.464 0-0.804-0.339t-0.339-0.804v-2.286q0-0.464 0.339-0.804t0.804-0.339h1.143q1.893 0 3.232-1.339t1.339-3.232v-0.571q0-0.714-0.5-1.214t-1.214-0.5h-4q-1.429 0-2.429-1t-1-2.429v-6.857q0-1.429 1-2.429t2.429-1h6.857q1.429 0 2.429 1t1 2.429z"></path>
</symbol>
<symbol id="icon-mail-reply" viewBox="0 0 32 32">
<path class="path1" d="M32 20q0 2.964-2.268 8.054-0.054 0.125-0.188 0.429t-0.241 0.536-0.232 0.393q-0.214 0.304-0.5 0.304-0.268 0-0.42-0.179t-0.152-0.446q0-0.161 0.045-0.473t0.045-0.42q0.089-1.214 0.089-2.196 0-1.804-0.313-3.232t-0.866-2.473-1.429-1.804-1.884-1.241-2.375-0.759-2.75-0.384-3.134-0.107h-4v4.571q0 0.464-0.339 0.804t-0.804 0.339-0.804-0.339l-9.143-9.143q-0.339-0.339-0.339-0.804t0.339-0.804l9.143-9.143q0.339-0.339 0.804-0.339t0.804 0.339 0.339 0.804v4.571h4q12.732 0 15.625 7.196 0.946 2.393 0.946 5.946z"></path>
</symbol>
<symbol id="icon-youtube" viewBox="0 0 27 32">
<path class="path1" d="M17.339 22.214v3.768q0 1.196-0.696 1.196-0.411 0-0.804-0.393v-5.375q0.393-0.393 0.804-0.393 0.696 0 0.696 1.196zM23.375 22.232v0.821h-1.607v-0.821q0-1.214 0.804-1.214t0.804 1.214zM6.125 18.339h1.911v-1.679h-5.571v1.679h1.875v10.161h1.786v-10.161zM11.268 28.5h1.589v-8.821h-1.589v6.75q-0.536 0.75-1.018 0.75-0.321 0-0.375-0.375-0.018-0.054-0.018-0.625v-6.5h-1.589v6.982q0 0.875 0.143 1.304 0.214 0.661 1.036 0.661 0.857 0 1.821-1.089v0.964zM18.929 25.857v-3.518q0-1.304-0.161-1.768-0.304-1-1.268-1-0.893 0-1.661 0.964v-3.875h-1.589v11.839h1.589v-0.857q0.804 0.982 1.661 0.982 0.964 0 1.268-0.982 0.161-0.482 0.161-1.786zM24.964 25.679v-0.232h-1.625q0 0.911-0.036 1.089-0.125 0.643-0.714 0.643-0.821 0-0.821-1.232v-1.554h3.196v-1.839q0-1.411-0.482-2.071-0.696-0.911-1.893-0.911-1.214 0-1.911 0.911-0.5 0.661-0.5 2.071v3.089q0 1.411 0.518 2.071 0.696 0.911 1.929 0.911 1.286 0 1.929-0.946 0.321-0.482 0.375-0.964 0.036-0.161 0.036-1.036zM14.107 9.375v-3.75q0-1.232-0.768-1.232t-0.768 1.232v3.75q0 1.25 0.768 1.25t0.768-1.25zM26.946 22.786q0 4.179-0.464 6.25-0.25 1.054-1.036 1.768t-1.821 0.821q-3.286 0.375-9.911 0.375t-9.911-0.375q-1.036-0.107-1.83-0.821t-1.027-1.768q-0.464-2-0.464-6.25 0-4.179 0.464-6.25 0.25-1.054 1.036-1.768t1.839-0.839q3.268-0.357 9.893-0.357t9.911 0.357q1.036 0.125 1.83 0.839t1.027 1.768q0.464 2 0.464 6.25zM9.125 0h1.821l-2.161 7.125v4.839h-1.786v-4.839q-0.25-1.321-1.089-3.786-0.661-1.839-1.161-3.339h1.893l1.268 4.696zM15.732 5.946v3.125q0 1.446-0.5 2.107-0.661 0.911-1.893 0.911-1.196 0-1.875-0.911-0.5-0.679-0.5-2.107v-3.125q0-1.429 0.5-2.089 0.679-0.911 1.875-0.911 1.232 0 1.893 0.911 0.5 0.661 0.5 2.089zM21.714 3.054v8.911h-1.625v-0.982q-0.946 1.107-1.839 1.107-0.821 0-1.054-0.661-0.143-0.429-0.143-1.339v-7.036h1.625v6.554q0 0.589 0.018 0.625 0.054 0.393 0.375 0.393 0.482 0 1.018-0.768v-6.804h1.625z"></path>
</symbol>
<symbol id="icon-dropbox" viewBox="0 0 32 32">
<path class="path1" d="M7.179 12.625l8.821 5.446-6.107 5.089-8.75-5.696zM24.786 22.536v1.929l-8.75 5.232v0.018l-0.018-0.018-0.018 0.018v-0.018l-8.732-5.232v-1.929l2.625 1.714 6.107-5.071v-0.036l0.018 0.018 0.018-0.018v0.036l6.125 5.071zM9.893 2.107l6.107 5.089-8.821 5.429-6.036-4.821zM24.821 12.625l6.036 4.839-8.732 5.696-6.125-5.089zM22.125 2.107l8.732 5.696-6.036 4.821-8.821-5.429z"></path>
</symbol>
<symbol id="icon-instagram" viewBox="0 0 27 32">
<path class="path1" d="M18.286 16q0-1.893-1.339-3.232t-3.232-1.339-3.232 1.339-1.339 3.232 1.339 3.232 3.232 1.339 3.232-1.339 1.339-3.232zM20.75 16q0 2.929-2.054 4.982t-4.982 2.054-4.982-2.054-2.054-4.982 2.054-4.982 4.982-2.054 4.982 2.054 2.054 4.982zM22.679 8.679q0 0.679-0.482 1.161t-1.161 0.482-1.161-0.482-0.482-1.161 0.482-1.161 1.161-0.482 1.161 0.482 0.482 1.161zM13.714 4.75q-0.125 0-1.366-0.009t-1.884 0-1.723 0.054-1.839 0.179-1.277 0.33q-0.893 0.357-1.571 1.036t-1.036 1.571q-0.196 0.518-0.33 1.277t-0.179 1.839-0.054 1.723 0 1.884 0.009 1.366-0.009 1.366 0 1.884 0.054 1.723 0.179 1.839 0.33 1.277q0.357 0.893 1.036 1.571t1.571 1.036q0.518 0.196 1.277 0.33t1.839 0.179 1.723 0.054 1.884 0 1.366-0.009 1.366 0.009 1.884 0 1.723-0.054 1.839-0.179 1.277-0.33q0.893-0.357 1.571-1.036t1.036-1.571q0.196-0.518 0.33-1.277t0.179-1.839 0.054-1.723 0-1.884-0.009-1.366 0.009-1.366 0-1.884-0.054-1.723-0.179-1.839-0.33-1.277q-0.357-0.893-1.036-1.571t-1.571-1.036q-0.518-0.196-1.277-0.33t-1.839-0.179-1.723-0.054-1.884 0-1.366 0.009zM27.429 16q0 4.089-0.089 5.661-0.179 3.714-2.214 5.75t-5.75 2.214q-1.571 0.089-5.661 0.089t-5.661-0.089q-3.714-0.179-5.75-2.214t-2.214-5.75q-0.089-1.571-0.089-5.661t0.089-5.661q0.179-3.714 2.214-5.75t5.75-2.214q1.571-0.089 5.661-0.089t5.661 0.089q3.714 0.179 5.75 2.214t2.214 5.75q0.089 1.571 0.089 5.661z"></path>
</symbol>
<symbol id="icon-flickr" viewBox="0 0 27 32">
<path class="path1" d="M22.286 2.286q2.125 0 3.634 1.509t1.509 3.634v17.143q0 2.125-1.509 3.634t-3.634 1.509h-17.143q-2.125 0-3.634-1.509t-1.509-3.634v-17.143q0-2.125 1.509-3.634t3.634-1.509h17.143zM12.464 16q0-1.571-1.107-2.679t-2.679-1.107-2.679 1.107-1.107 2.679 1.107 2.679 2.679 1.107 2.679-1.107 1.107-2.679zM22.536 16q0-1.571-1.107-2.679t-2.679-1.107-2.679 1.107-1.107 2.679 1.107 2.679 2.679 1.107 2.679-1.107 1.107-2.679z"></path>
</symbol>
<symbol id="icon-tumblr" viewBox="0 0 19 32">
<path class="path1" d="M16.857 23.732l1.429 4.232q-0.411 0.625-1.982 1.179t-3.161 0.571q-1.857 0.036-3.402-0.464t-2.545-1.321-1.696-1.893-0.991-2.143-0.295-2.107v-9.714h-3v-3.839q1.286-0.464 2.304-1.241t1.625-1.607 1.036-1.821 0.607-1.768 0.268-1.58q0.018-0.089 0.080-0.152t0.134-0.063h4.357v7.571h5.946v4.5h-5.964v9.25q0 0.536 0.116 1t0.402 0.938 0.884 0.741 1.455 0.25q1.393-0.036 2.393-0.518z"></path>
</symbol>
<symbol id="icon-dockerhub" viewBox="0 0 24 28">
<path class="path1" d="M1.597 10.257h2.911v2.83H1.597v-2.83zm3.573 0h2.91v2.83H5.17v-2.83zm0-3.627h2.91v2.829H5.17V6.63zm3.57 3.627h2.912v2.83H8.74v-2.83zm0-3.627h2.912v2.829H8.74V6.63zm3.573 3.627h2.911v2.83h-2.911v-2.83zm0-3.627h2.911v2.829h-2.911V6.63zm3.572 3.627h2.911v2.83h-2.911v-2.83zM12.313 3h2.911v2.83h-2.911V3zm-6.65 14.173c-.449 0-.812.354-.812.788 0 .435.364.788.812.788.447 0 .811-.353.811-.788 0-.434-.363-.788-.811-.788"></path>
<path class="path2" d="M28.172 11.721c-.978-.549-2.278-.624-3.388-.306-.136-1.146-.91-2.149-1.83-2.869l-.366-.286-.307.345c-.618.692-.8 1.845-.718 2.73.063.651.273 1.312.685 1.834-.313.183-.668.328-.985.434-.646.212-1.347.33-2.028.33H.083l-.042.429c-.137 1.432.065 2.866.674 4.173l.262.519.03.048c1.8 2.973 4.963 4.225 8.41 4.225 6.672 0 12.174-2.896 14.702-9.015 1.689.085 3.417-.4 4.243-1.968l.211-.4-.401-.223zM5.664 19.458c-.85 0-1.542-.671-1.542-1.497 0-.825.691-1.498 1.541-1.498.849 0 1.54.672 1.54 1.497s-.69 1.498-1.539 1.498z"></path>
</symbol>
<symbol id="icon-dribbble" viewBox="0 0 27 32">
<path class="path1" d="M18.286 26.786q-0.75-4.304-2.5-8.893h-0.036l-0.036 0.018q-0.286 0.107-0.768 0.295t-1.804 0.875-2.446 1.464-2.339 2.045-1.839 2.643l-0.268-0.196q3.286 2.679 7.464 2.679 2.357 0 4.571-0.929zM14.982 15.946q-0.375-0.875-0.946-1.982-5.554 1.661-12.018 1.661-0.018 0.125-0.018 0.375 0 2.214 0.786 4.223t2.214 3.598q0.893-1.589 2.205-2.973t2.545-2.223 2.33-1.446 1.777-0.857l0.661-0.232q0.071-0.018 0.232-0.063t0.232-0.080zM13.071 12.161q-2.143-3.804-4.357-6.75-2.464 1.161-4.179 3.321t-2.286 4.857q5.393 0 10.821-1.429zM25.286 17.857q-3.75-1.071-7.304-0.518 1.554 4.268 2.286 8.375 1.982-1.339 3.304-3.384t1.714-4.473zM10.911 4.625q-0.018 0-0.036 0.018 0.018-0.018 0.036-0.018zM21.446 7.214q-3.304-2.929-7.732-2.929-1.357 0-2.768 0.339 2.339 3.036 4.393 6.821 1.232-0.464 2.321-1.080t1.723-1.098 1.17-1.018 0.67-0.723zM25.429 15.875q-0.054-4.143-2.661-7.321l-0.018 0.018q-0.161 0.214-0.339 0.438t-0.777 0.795-1.268 1.080-1.786 1.161-2.348 1.152q0.446 0.946 0.786 1.696 0.036 0.107 0.116 0.313t0.134 0.295q0.643-0.089 1.33-0.125t1.313-0.036 1.232 0.027 1.143 0.071 1.009 0.098 0.857 0.116 0.652 0.107 0.446 0.080zM27.429 16q0 3.732-1.839 6.884t-4.991 4.991-6.884 1.839-6.884-1.839-4.991-4.991-1.839-6.884 1.839-6.884 4.991-4.991 6.884-1.839 6.884 1.839 4.991 4.991 1.839 6.884z"></path>
</symbol>
<symbol id="icon-skype" viewBox="0 0 27 32">
<path class="path1" d="M20.946 18.982q0-0.893-0.348-1.634t-0.866-1.223-1.304-0.875-1.473-0.607-1.563-0.411l-1.857-0.429q-0.536-0.125-0.786-0.188t-0.625-0.205-0.536-0.286-0.295-0.375-0.134-0.536q0-1.375 2.571-1.375 0.768 0 1.375 0.214t0.964 0.509 0.679 0.598 0.714 0.518 0.857 0.214q0.839 0 1.348-0.571t0.509-1.375q0-0.982-1-1.777t-2.536-1.205-3.25-0.411q-1.214 0-2.357 0.277t-2.134 0.839-1.589 1.554-0.598 2.295q0 1.089 0.339 1.902t1 1.348 1.429 0.866 1.839 0.58l2.607 0.643q1.607 0.393 2 0.643 0.571 0.357 0.571 1.071 0 0.696-0.714 1.152t-1.875 0.455q-0.911 0-1.634-0.286t-1.161-0.688-0.813-0.804-0.821-0.688-0.964-0.286q-0.893 0-1.348 0.536t-0.455 1.339q0 1.643 2.179 2.813t5.196 1.17q1.304 0 2.5-0.33t2.188-0.955 1.58-1.67 0.589-2.348zM27.429 22.857q0 2.839-2.009 4.848t-4.848 2.009q-2.321 0-4.179-1.429-1.375 0.286-2.679 0.286-2.554 0-4.884-0.991t-4.018-2.679-2.679-4.018-0.991-4.884q0-1.304 0.286-2.679-1.429-1.857-1.429-4.179 0-2.839 2.009-4.848t4.848-2.009q2.321 0 4.179 1.429 1.375-0.286 2.679-0.286 2.554 0 4.884 0.991t4.018 2.679 2.679 4.018 0.991 4.884q0 1.304-0.286 2.679 1.429 1.857 1.429 4.179z"></path>
</symbol>
<symbol id="icon-foursquare" viewBox="0 0 23 32">
<path class="path1" d="M17.857 7.75l0.661-3.464q0.089-0.411-0.161-0.714t-0.625-0.304h-12.714q-0.411 0-0.688 0.304t-0.277 0.661v19.661q0 0.125 0.107 0.018l5.196-6.286q0.411-0.464 0.679-0.598t0.857-0.134h4.268q0.393 0 0.661-0.259t0.321-0.527q0.429-2.321 0.661-3.411 0.071-0.375-0.205-0.714t-0.652-0.339h-5.25q-0.518 0-0.857-0.339t-0.339-0.857v-0.75q0-0.518 0.339-0.848t0.857-0.33h6.179q0.321 0 0.625-0.241t0.357-0.527zM21.911 3.786q-0.268 1.304-0.955 4.759t-1.241 6.25-0.625 3.098q-0.107 0.393-0.161 0.58t-0.25 0.58-0.438 0.589-0.688 0.375-1.036 0.179h-4.839q-0.232 0-0.393 0.179-0.143 0.161-7.607 8.821-0.393 0.446-1.045 0.509t-0.866-0.098q-0.982-0.393-0.982-1.75v-25.179q0-0.982 0.679-1.83t2.143-0.848h15.857q1.696 0 2.268 0.946t0.179 2.839zM21.911 3.786l-2.821 14.107q0.071-0.304 0.625-3.098t1.241-6.25 0.955-4.759z"></path>
</symbol>
<symbol id="icon-wordpress" viewBox="0 0 32 32">
<path class="path1" d="M2.268 16q0-2.911 1.196-5.589l6.554 17.946q-3.5-1.696-5.625-5.018t-2.125-7.339zM25.268 15.304q0 0.339-0.045 0.688t-0.179 0.884-0.205 0.786-0.313 1.054-0.313 1.036l-1.357 4.571-4.964-14.75q0.821-0.054 1.571-0.143 0.339-0.036 0.464-0.33t-0.045-0.554-0.509-0.241l-3.661 0.179q-1.339-0.018-3.607-0.179-0.214-0.018-0.366 0.089t-0.205 0.268-0.027 0.33 0.161 0.295 0.348 0.143l1.429 0.143 2.143 5.857-3 9-5-14.857q0.821-0.054 1.571-0.143 0.339-0.036 0.464-0.33t-0.045-0.554-0.509-0.241l-3.661 0.179q-0.125 0-0.411-0.009t-0.464-0.009q1.875-2.857 4.902-4.527t6.563-1.67q2.625 0 5.009 0.946t4.259 2.661h-0.179q-0.982 0-1.643 0.723t-0.661 1.705q0 0.214 0.036 0.429t0.071 0.384 0.143 0.411 0.161 0.375 0.214 0.402 0.223 0.375 0.259 0.429 0.25 0.411q1.125 1.911 1.125 3.786zM16.232 17.196l4.232 11.554q0.018 0.107 0.089 0.196-2.25 0.786-4.554 0.786-2 0-3.875-0.571zM28.036 9.411q1.696 3.107 1.696 6.589 0 3.732-1.857 6.884t-4.982 4.973l4.196-12.107q1.054-3.018 1.054-4.929 0-0.75-0.107-1.411zM16 0q3.25 0 6.214 1.268t5.107 3.411 3.411 5.107 1.268 6.214-1.268 6.214-3.411 5.107-5.107 3.411-6.214 1.268-6.214-1.268-5.107-3.411-3.411-5.107-1.268-6.214 1.268-6.214 3.411-5.107 5.107-3.411 6.214-1.268zM16 31.268q3.089 0 5.92-1.214t4.875-3.259 3.259-4.875 1.214-5.92-1.214-5.92-3.259-4.875-4.875-3.259-5.92-1.214-5.92 1.214-4.875 3.259-3.259 4.875-1.214 5.92 1.214 5.92 3.259 4.875 4.875 3.259 5.92 1.214z"></path>
</symbol>
<symbol id="icon-stumbleupon" viewBox="0 0 34 32">
<path class="path1" d="M18.964 12.714v-2.107q0-0.75-0.536-1.286t-1.286-0.536-1.286 0.536-0.536 1.286v10.929q0 3.125-2.25 5.339t-5.411 2.214q-3.179 0-5.42-2.241t-2.241-5.42v-4.75h5.857v4.679q0 0.768 0.536 1.295t1.286 0.527 1.286-0.527 0.536-1.295v-11.071q0-3.054 2.259-5.214t5.384-2.161q3.143 0 5.393 2.179t2.25 5.25v2.429l-3.482 1.036zM28.429 16.679h5.857v4.75q0 3.179-2.241 5.42t-5.42 2.241q-3.161 0-5.411-2.223t-2.25-5.366v-4.786l2.339 1.089 3.482-1.036v4.821q0 0.75 0.536 1.277t1.286 0.527 1.286-0.527 0.536-1.277v-4.911z"></path>
</symbol>
<symbol id="icon-digg" viewBox="0 0 37 32">
<path class="path1" d="M5.857 5.036h3.643v17.554h-9.5v-12.446h5.857v-5.107zM5.857 19.661v-6.589h-2.196v6.589h2.196zM10.964 10.143v12.446h3.661v-12.446h-3.661zM10.964 5.036v3.643h3.661v-3.643h-3.661zM16.089 10.143h9.518v16.821h-9.518v-2.911h5.857v-1.464h-5.857v-12.446zM21.946 19.661v-6.589h-2.196v6.589h2.196zM27.071 10.143h9.5v16.821h-9.5v-2.911h5.839v-1.464h-5.839v-12.446zM32.911 19.661v-6.589h-2.196v6.589h2.196z"></path>
</symbol>
<symbol id="icon-spotify" viewBox="0 0 27 32">
<path class="path1" d="M20.125 21.607q0-0.571-0.536-0.911-3.446-2.054-7.982-2.054-2.375 0-5.125 0.607-0.75 0.161-0.75 0.929 0 0.357 0.241 0.616t0.634 0.259q0.089 0 0.661-0.143 2.357-0.482 4.339-0.482 4.036 0 7.089 1.839 0.339 0.196 0.589 0.196 0.339 0 0.589-0.241t0.25-0.616zM21.839 17.768q0-0.714-0.625-1.089-4.232-2.518-9.786-2.518-2.732 0-5.411 0.75-0.857 0.232-0.857 1.143 0 0.446 0.313 0.759t0.759 0.313q0.125 0 0.661-0.143 2.179-0.589 4.482-0.589 4.982 0 8.714 2.214 0.429 0.232 0.679 0.232 0.446 0 0.759-0.313t0.313-0.759zM23.768 13.339q0-0.839-0.714-1.25-2.25-1.304-5.232-1.973t-6.125-0.67q-3.643 0-6.5 0.839-0.411 0.125-0.688 0.455t-0.277 0.866q0 0.554 0.366 0.929t0.92 0.375q0.196 0 0.714-0.143 2.375-0.661 5.482-0.661 2.839 0 5.527 0.607t4.527 1.696q0.375 0.214 0.714 0.214 0.518 0 0.902-0.366t0.384-0.92zM27.429 16q0 3.732-1.839 6.884t-4.991 4.991-6.884 1.839-6.884-1.839-4.991-4.991-1.839-6.884 1.839-6.884 4.991-4.991 6.884-1.839 6.884 1.839 4.991 4.991 1.839 6.884z"></path>
</symbol>
<symbol id="icon-soundcloud" viewBox="0 0 41 32">
<path class="path1" d="M14 24.5l0.286-4.304-0.286-9.339q-0.018-0.179-0.134-0.304t-0.295-0.125q-0.161 0-0.286 0.125t-0.125 0.304l-0.25 9.339 0.25 4.304q0.018 0.179 0.134 0.295t0.277 0.116q0.393 0 0.429-0.411zM19.286 23.982l0.196-3.768-0.214-10.464q0-0.286-0.232-0.429-0.143-0.089-0.286-0.089t-0.286 0.089q-0.232 0.143-0.232 0.429l-0.018 0.107-0.179 10.339q0 0.018 0.196 4.214v0.018q0 0.179 0.107 0.304 0.161 0.196 0.411 0.196 0.196 0 0.357-0.161 0.161-0.125 0.161-0.357zM0.625 17.911l0.357 2.286-0.357 2.25q-0.036 0.161-0.161 0.161t-0.161-0.161l-0.304-2.25 0.304-2.286q0.036-0.161 0.161-0.161t0.161 0.161zM2.161 16.5l0.464 3.696-0.464 3.625q-0.036 0.161-0.179 0.161-0.161 0-0.161-0.179l-0.411-3.607 0.411-3.696q0-0.161 0.161-0.161 0.143 0 0.179 0.161zM3.804 15.821l0.446 4.375-0.446 4.232q0 0.196-0.196 0.196-0.179 0-0.214-0.196l-0.375-4.232 0.375-4.375q0.036-0.214 0.214-0.214 0.196 0 0.196 0.214zM5.482 15.696l0.411 4.5-0.411 4.357q-0.036 0.232-0.25 0.232-0.232 0-0.232-0.232l-0.375-4.357 0.375-4.5q0-0.232 0.232-0.232 0.214 0 0.25 0.232zM7.161 16.018l0.375 4.179-0.375 4.393q-0.036 0.286-0.286 0.286-0.107 0-0.188-0.080t-0.080-0.205l-0.357-4.393 0.357-4.179q0-0.107 0.080-0.188t0.188-0.080q0.25 0 0.286 0.268zM8.839 13.411l0.375 6.786-0.375 4.393q0 0.125-0.089 0.223t-0.214 0.098q-0.286 0-0.321-0.321l-0.321-4.393 0.321-6.786q0.036-0.321 0.321-0.321 0.125 0 0.214 0.098t0.089 0.223zM10.518 11.875l0.339 8.357-0.339 4.357q0 0.143-0.098 0.241t-0.241 0.098q-0.321 0-0.357-0.339l-0.286-4.357 0.286-8.357q0.036-0.339 0.357-0.339 0.143 0 0.241 0.098t0.098 0.241zM12.268 11.161l0.321 9.036-0.321 4.321q-0.036 0.375-0.393 0.375-0.339 0-0.375-0.375l-0.286-4.321 0.286-9.036q0-0.161 0.116-0.277t0.259-0.116q0.161 0 0.268 0.116t0.125 0.277zM19.268 24.411v0 0zM15.732 11.089l0.268 9.107-0.268 4.268q0 0.179-0.134 0.313t-0.313 0.134-0.304-0.125-0.143-0.321l-0.25-4.268 0.25-9.107q0-0.196 0.134-0.321t0.313-0.125 0.313 0.125 0.134 0.321zM17.5 11.429l0.25 8.786-0.25 4.214q0 0.196-0.143 0.339t-0.339 0.143-0.339-0.143-0.161-0.339l-0.214-4.214 0.214-8.786q0.018-0.214 0.161-0.357t0.339-0.143 0.33 0.143 0.152 0.357zM21.286 20.214l-0.25 4.125q0 0.232-0.161 0.393t-0.393 0.161-0.393-0.161-0.179-0.393l-0.107-2.036-0.107-2.089 0.214-11.357v-0.054q0.036-0.268 0.214-0.429 0.161-0.125 0.357-0.125 0.143 0 0.268 0.089 0.25 0.143 0.286 0.464zM41.143 19.875q0 2.089-1.482 3.563t-3.571 1.473h-14.036q-0.232-0.036-0.393-0.196t-0.161-0.393v-16.054q0-0.411 0.5-0.589 1.518-0.607 3.232-0.607 3.482 0 6.036 2.348t2.857 5.777q0.946-0.393 1.964-0.393 2.089 0 3.571 1.482t1.482 3.589z"></path>
</symbol>
<symbol id="icon-codepen" viewBox="0 0 32 32">
<path class="path1" d="M3.857 20.875l10.768 7.179v-6.411l-5.964-3.982zM2.75 18.304l3.446-2.304-3.446-2.304v4.607zM17.375 28.054l10.768-7.179-4.804-3.214-5.964 3.982v6.411zM16 19.25l4.857-3.25-4.857-3.25-4.857 3.25zM8.661 14.339l5.964-3.982v-6.411l-10.768 7.179zM25.804 16l3.446 2.304v-4.607zM23.339 14.339l4.804-3.214-10.768-7.179v6.411zM32 11.125v9.75q0 0.732-0.607 1.143l-14.625 9.75q-0.375 0.232-0.768 0.232t-0.768-0.232l-14.625-9.75q-0.607-0.411-0.607-1.143v-9.75q0-0.732 0.607-1.143l14.625-9.75q0.375-0.232 0.768-0.232t0.768 0.232l14.625 9.75q0.607 0.411 0.607 1.143z"></path>
</symbol>
<symbol id="icon-twitch" viewBox="0 0 32 32">
<path class="path1" d="M16 7.75v7.75h-2.589v-7.75h2.589zM23.107 7.75v7.75h-2.589v-7.75h2.589zM23.107 21.321l4.518-4.536v-14.196h-21.321v18.732h5.821v3.875l3.875-3.875h7.107zM30.214 0v18.089l-7.75 7.75h-5.821l-3.875 3.875h-3.875v-3.875h-7.107v-20.679l1.946-5.161h26.482z"></path>
</symbol>
<symbol id="icon-meanpath" viewBox="0 0 27 32">
<path class="path1" d="M23.411 15.036v2.036q0 0.429-0.241 0.679t-0.67 0.25h-3.607q-0.429 0-0.679-0.25t-0.25-0.679v-2.036q0-0.429 0.25-0.679t0.679-0.25h3.607q0.429 0 0.67 0.25t0.241 0.679zM14.661 19.143v-4.464q0-0.946-0.58-1.527t-1.527-0.58h-2.375q-1.214 0-1.714 0.929-0.5-0.929-1.714-0.929h-2.321q-0.946 0-1.527 0.58t-0.58 1.527v4.464q0 0.393 0.375 0.393h0.982q0.393 0 0.393-0.393v-4.107q0-0.429 0.241-0.679t0.688-0.25h1.679q0.429 0 0.679 0.25t0.25 0.679v4.107q0 0.393 0.375 0.393h0.964q0.393 0 0.393-0.393v-4.107q0-0.429 0.25-0.679t0.679-0.25h1.732q0.429 0 0.67 0.25t0.241 0.679v4.107q0 0.393 0.393 0.393h0.982q0.375 0 0.375-0.393zM25.179 17.429v-2.75q0-0.946-0.589-1.527t-1.536-0.58h-4.714q-0.946 0-1.536 0.58t-0.589 1.527v7.321q0 0.375 0.393 0.375h0.982q0.375 0 0.375-0.375v-3.214q0.554 0.75 1.679 0.75h3.411q0.946 0 1.536-0.58t0.589-1.527zM27.429 6.429v19.143q0 1.714-1.214 2.929t-2.929 1.214h-19.143q-1.714 0-2.929-1.214t-1.214-2.929v-19.143q0-1.714 1.214-2.929t2.929-1.214h19.143q1.714 0 2.929 1.214t1.214 2.929z"></path>
</symbol>
<symbol id="icon-pinterest-p" viewBox="0 0 23 32">
<path class="path1" d="M0 10.661q0-1.929 0.67-3.634t1.848-2.973 2.714-2.196 3.304-1.393 3.607-0.464q2.821 0 5.25 1.188t3.946 3.455 1.518 5.125q0 1.714-0.339 3.357t-1.071 3.161-1.786 2.67-2.589 1.839-3.375 0.688q-1.214 0-2.411-0.571t-1.714-1.571q-0.179 0.696-0.5 2.009t-0.42 1.696-0.366 1.268-0.464 1.268-0.571 1.116-0.821 1.384-1.107 1.545l-0.25 0.089-0.161-0.179q-0.268-2.804-0.268-3.357 0-1.643 0.384-3.688t1.188-5.134 0.929-3.625q-0.571-1.161-0.571-3.018 0-1.482 0.929-2.786t2.357-1.304q1.089 0 1.696 0.723t0.607 1.83q0 1.179-0.786 3.411t-0.786 3.339q0 1.125 0.804 1.866t1.946 0.741q0.982 0 1.821-0.446t1.402-1.214 1-1.696 0.679-1.973 0.357-1.982 0.116-1.777q0-3.089-1.955-4.813t-5.098-1.723q-3.571 0-5.964 2.313t-2.393 5.866q0 0.786 0.223 1.518t0.482 1.161 0.482 0.813 0.223 0.545q0 0.5-0.268 1.304t-0.661 0.804q-0.036 0-0.304-0.054-0.911-0.268-1.616-1t-1.089-1.688-0.58-1.929-0.196-1.902z"></path>
</symbol>
<symbol id="icon-periscope" viewBox="0 0 24 28">
<path class="path1" d="M12.285,1C6.696,1,2.277,5.643,2.277,11.243c0,5.851,7.77,14.578,10.007,14.578c1.959,0,9.729-8.728,9.729-14.578 C22.015,5.643,17.596,1,12.285,1z M12.317,16.551c-3.473,0-6.152-2.611-6.152-5.664c0-1.292,0.39-2.472,1.065-3.438 c0.206,1.084,1.18,1.906,2.352,1.906c1.322,0,2.393-1.043,2.393-2.333c0-0.832-0.447-1.561-1.119-1.975 c0.467-0.105,0.955-0.161,1.46-0.161c3.133,0,5.81,2.611,5.81,5.998C18.126,13.94,15.449,16.551,12.317,16.551z"></path>
</symbol>
<symbol id="icon-get-pocket" viewBox="0 0 31 32">
<path class="path1" d="M27.946 2.286q1.161 0 1.964 0.813t0.804 1.973v9.268q0 3.143-1.214 6t-3.259 4.911-4.893 3.259-5.973 1.205q-3.143 0-5.991-1.205t-4.902-3.259-3.268-4.911-1.214-6v-9.268q0-1.143 0.821-1.964t1.964-0.821h25.161zM15.375 21.286q0.839 0 1.464-0.589l7.214-6.929q0.661-0.625 0.661-1.518 0-0.875-0.616-1.491t-1.491-0.616q-0.839 0-1.464 0.589l-5.768 5.536-5.768-5.536q-0.625-0.589-1.446-0.589-0.875 0-1.491 0.616t-0.616 1.491q0 0.911 0.643 1.518l7.232 6.929q0.589 0.589 1.446 0.589z"></path>
</symbol>
<symbol id="icon-vimeo" viewBox="0 0 32 32">
<path class="path1" d="M30.518 9.25q-0.179 4.214-5.929 11.625-5.946 7.696-10.036 7.696-2.536 0-4.286-4.696-0.786-2.857-2.357-8.607-1.286-4.679-2.804-4.679-0.321 0-2.268 1.357l-1.375-1.75q0.429-0.375 1.929-1.723t2.321-2.063q2.786-2.464 4.304-2.607 1.696-0.161 2.732 0.991t1.446 3.634q0.786 5.125 1.179 6.661 0.982 4.446 2.143 4.446 0.911 0 2.75-2.875 1.804-2.875 1.946-4.393 0.232-2.482-1.946-2.482-1.018 0-2.161 0.464 2.143-7.018 8.196-6.821 4.482 0.143 4.214 5.821z"></path>
</symbol>
<symbol id="icon-reddit-alien" viewBox="0 0 32 32">
<path class="path1" d="M32 15.107q0 1.036-0.527 1.884t-1.42 1.295q0.214 0.821 0.214 1.714 0 2.768-1.902 5.125t-5.188 3.723-7.143 1.366-7.134-1.366-5.179-3.723-1.902-5.125q0-0.839 0.196-1.679-0.911-0.446-1.464-1.313t-0.554-1.902q0-1.464 1.036-2.509t2.518-1.045q1.518 0 2.589 1.125 3.893-2.714 9.196-2.893l2.071-9.304q0.054-0.232 0.268-0.375t0.464-0.089l6.589 1.446q0.321-0.661 0.964-1.063t1.411-0.402q1.107 0 1.893 0.777t0.786 1.884-0.786 1.893-1.893 0.786-1.884-0.777-0.777-1.884l-5.964-1.321-1.857 8.429q5.357 0.161 9.268 2.857 1.036-1.089 2.554-1.089 1.482 0 2.518 1.045t1.036 2.509zM7.464 18.661q0 1.107 0.777 1.893t1.884 0.786 1.893-0.786 0.786-1.893-0.786-1.884-1.893-0.777q-1.089 0-1.875 0.786t-0.786 1.875zM21.929 25q0.196-0.196 0.196-0.464t-0.196-0.464q-0.179-0.179-0.446-0.179t-0.464 0.179q-0.732 0.75-2.161 1.107t-2.857 0.357-2.857-0.357-2.161-1.107q-0.196-0.179-0.464-0.179t-0.446 0.179q-0.196 0.179-0.196 0.455t0.196 0.473q0.768 0.768 2.116 1.214t2.188 0.527 1.625 0.080 1.625-0.080 2.188-0.527 2.116-1.214zM21.875 21.339q1.107 0 1.884-0.786t0.777-1.893q0-1.089-0.786-1.875t-1.875-0.786q-1.107 0-1.893 0.777t-0.786 1.884 0.786 1.893 1.893 0.786z"></path>
</symbol>
<symbol id="icon-whatsapp" viewBox="0 0 32 32">
<path d="M15.968 2.003a14.03 13.978 0 0 0-14.03 13.978 14.03 13.978 0 0 0 2.132 7.391L1.938 29.96l6.745-2.052a14.03 13.978 0 0 0 7.285 2.052 14.03 13.978 0 0 0 14.03-13.978 14.03 13.978 0 0 0-14.03-13.978z" stroke-width=".2000562"/>
<path d="M10.454 8.236a2.57 3.401 51.533 0 0-1.475 3.184v.015c.01 2.04 4.045 10.076 10.017 12.688l.017-.013a2.57 3.401 51.533 0 0 3.454-.706 2.57 3.401 51.533 0 0 1.064-4.129 2.57 3.401 51.533 0 0-4.262.103 2.57 3.401 51.533 0 0-.505.473c-1.346-.639-2.952-1.463-4.168-2.98-.771-.962-1.257-2.732-1.549-4.206a2.57 3.401 51.533 0 0 .605-.403 2.57 3.401 51.533 0 0 1.064-4.129 2.57 3.401 51.533 0 0-4.262.103z" stroke-width=".372"/>
</symbol>
<symbol id="icon-telegram" viewBox="0 0 32 32">
<path d="M30.8,2.2L0.6,13.9c-0.8,0.3-0.7,1.3,0,1.6l7.4,2.8l2.9,9.2c0.2,0.6,0.9,0.8,1.4,0.4l4.1-3.4 c0.4-0.4,1-0.4,1.5,0l7.4,5.4c0.5,0.4,1.2,0.1,1.4-0.5L32,3.2C32.1,2.5,31.4,1.9,30.8,2.2z M25,8.3l-11.9,11 c-0.4,0.4-0.7,0.9-0.8,1.5l-0.4,3c-0.1,0.4-0.6,0.4-0.7,0.1l-1.6-5.5c-0.2-0.6,0.1-1.3,0.6-1.6l14.4-8.9C25,7.7,25.3,8.1,25,8.3z"/>
</symbol>
<symbol id="icon-hashtag" viewBox="0 0 32 32">
<path class="path1" d="M17.696 18.286l1.143-4.571h-4.536l-1.143 4.571h4.536zM31.411 9.286l-1 4q-0.125 0.429-0.554 0.429h-5.839l-1.143 4.571h5.554q0.268 0 0.446 0.214 0.179 0.25 0.107 0.5l-1 4q-0.089 0.429-0.554 0.429h-5.839l-1.446 5.857q-0.125 0.429-0.554 0.429h-4q-0.286 0-0.464-0.214-0.161-0.214-0.107-0.5l1.393-5.571h-4.536l-1.446 5.857q-0.125 0.429-0.554 0.429h-4.018q-0.268 0-0.446-0.214-0.161-0.214-0.107-0.5l1.393-5.571h-5.554q-0.268 0-0.446-0.214-0.161-0.214-0.107-0.5l1-4q0.125-0.429 0.554-0.429h5.839l1.143-4.571h-5.554q-0.268 0-0.446-0.214-0.179-0.25-0.107-0.5l1-4q0.089-0.429 0.554-0.429h5.839l1.446-5.857q0.125-0.429 0.571-0.429h4q0.268 0 0.446 0.214 0.161 0.214 0.107 0.5l-1.393 5.571h4.536l1.446-5.857q0.125-0.429 0.571-0.429h4q0.268 0 0.446 0.214 0.161 0.214 0.107 0.5l-1.393 5.571h5.554q0.268 0 0.446 0.214 0.161 0.214 0.107 0.5z"></path>
</symbol>
<symbol id="icon-chain" viewBox="0 0 30 32">
<path class="path1" d="M26 21.714q0-0.714-0.5-1.214l-3.714-3.714q-0.5-0.5-1.214-0.5-0.75 0-1.286 0.571 0.054 0.054 0.339 0.33t0.384 0.384 0.268 0.339 0.232 0.455 0.063 0.491q0 0.714-0.5 1.214t-1.214 0.5q-0.268 0-0.491-0.063t-0.455-0.232-0.339-0.268-0.384-0.384-0.33-0.339q-0.589 0.554-0.589 1.304 0 0.714 0.5 1.214l3.679 3.696q0.482 0.482 1.214 0.482 0.714 0 1.214-0.464l2.625-2.607q0.5-0.5 0.5-1.196zM13.446 9.125q0-0.714-0.5-1.214l-3.679-3.696q-0.5-0.5-1.214-0.5-0.696 0-1.214 0.482l-2.625 2.607q-0.5 0.5-0.5 1.196 0 0.714 0.5 1.214l3.714 3.714q0.482 0.482 1.214 0.482 0.75 0 1.286-0.554-0.054-0.054-0.339-0.33t-0.384-0.384-0.268-0.339-0.232-0.455-0.063-0.491q0-0.714 0.5-1.214t1.214-0.5q0.268 0 0.491 0.063t0.455 0.232 0.339 0.268 0.384 0.384 0.33 0.339q0.589-0.554 0.589-1.304zM29.429 21.714q0 2.143-1.518 3.625l-2.625 2.607q-1.482 1.482-3.625 1.482-2.161 0-3.643-1.518l-3.679-3.696q-1.482-1.482-1.482-3.625 0-2.196 1.571-3.732l-1.571-1.571q-1.536 1.571-3.714 1.571-2.143 0-3.643-1.5l-3.714-3.714q-1.5-1.5-1.5-3.643t1.518-3.625l2.625-2.607q1.482-1.482 3.625-1.482 2.161 0 3.643 1.518l3.679 3.696q1.482 1.482 1.482 3.625 0 2.196-1.571 3.732l1.571 1.571q1.536-1.571 3.714-1.571 2.143 0 3.643 1.5l3.714 3.714q1.5 1.5 1.5 3.643z"></path>
</symbol>
<symbol id="icon-thumb-tack" viewBox="0 0 21 32">
<path class="path1" d="M8.571 15.429v-8q0-0.25-0.161-0.411t-0.411-0.161-0.411 0.161-0.161 0.411v8q0 0.25 0.161 0.411t0.411 0.161 0.411-0.161 0.161-0.411zM20.571 21.714q0 0.464-0.339 0.804t-0.804 0.339h-7.661l-0.911 8.625q-0.036 0.214-0.188 0.366t-0.366 0.152h-0.018q-0.482 0-0.571-0.482l-1.357-8.661h-7.214q-0.464 0-0.804-0.339t-0.339-0.804q0-2.196 1.402-3.955t3.17-1.759v-9.143q-0.929 0-1.607-0.679t-0.679-1.607 0.679-1.607 1.607-0.679h11.429q0.929 0 1.607 0.679t0.679 1.607-0.679 1.607-1.607 0.679v9.143q1.768 0 3.17 1.759t1.402 3.955z"></path>
</symbol>
<symbol id="icon-arrow-left" viewBox="0 0 43 32">
<path class="path1" d="M42.311 14.044c-0.178-0.178-0.533-0.356-0.711-0.356h-33.778l10.311-10.489c0.178-0.178 0.356-0.533 0.356-0.711 0-0.356-0.178-0.533-0.356-0.711l-1.6-1.422c-0.356-0.178-0.533-0.356-0.889-0.356s-0.533 0.178-0.711 0.356l-14.578 14.933c-0.178 0.178-0.356 0.533-0.356 0.711s0.178 0.533 0.356 0.711l14.756 14.933c0 0.178 0.356 0.356 0.533 0.356s0.533-0.178 0.711-0.356l1.6-1.6c0.178-0.178 0.356-0.533 0.356-0.711s-0.178-0.533-0.356-0.711l-10.311-10.489h33.778c0.178 0 0.533-0.178 0.711-0.356 0.356-0.178 0.533-0.356 0.533-0.711v-2.133c0-0.356-0.178-0.711-0.356-0.889z"></path>
</symbol>
<symbol id="icon-arrow-right" viewBox="0 0 43 32">
<path class="path1" d="M0.356 17.956c0.178 0.178 0.533 0.356 0.711 0.356h33.778l-10.311 10.489c-0.178 0.178-0.356 0.533-0.356 0.711 0 0.356 0.178 0.533 0.356 0.711l1.6 1.6c0.178 0.178 0.533 0.356 0.711 0.356s0.533-0.178 0.711-0.356l14.756-14.933c0.178-0.356 0.356-0.711 0.356-0.889s-0.178-0.533-0.356-0.711l-14.756-14.933c0-0.178-0.356-0.356-0.533-0.356s-0.533 0.178-0.711 0.356l-1.6 1.6c-0.178 0.178-0.356 0.533-0.356 0.711s0.178 0.533 0.356 0.711l10.311 10.489h-33.778c-0.178 0-0.533 0.178-0.711 0.356-0.356 0.178-0.533 0.356-0.533 0.711v2.311c0 0.178 0.178 0.533 0.356 0.711z"></path>
</symbol>
<symbol id="icon-play" viewBox="0 0 22 28">
<path d="M21.625 14.484l-20.75 11.531c-0.484 0.266-0.875 0.031-0.875-0.516v-23c0-0.547 0.391-0.781 0.875-0.516l20.75 11.531c0.484 0.266 0.484 0.703 0 0.969z"></path>
</symbol>
<symbol id="icon-pause" viewBox="0 0 24 28">
<path d="M24 3v22c0 0.547-0.453 1-1 1h-8c-0.547 0-1-0.453-1-1v-22c0-0.547 0.453-1 1-1h8c0.547 0 1 0.453 1 1zM10 3v22c0 0.547-0.453 1-1 1h-8c-0.547 0-1-0.453-1-1v-22c0-0.547 0.453-1 1-1h8c0.547 0 1 0.453 1 1z"></path>
</symbol>
</defs>
</svg>
<!-- Sticker banner -->
<div class="gxmas gxmas-22"><div class="gxmas-single axmas-130"><div class='fixeddbar jhfdiuh0' id='fixeddbar'> <div class='fixeddbar-close' onclick='document.getElementById(&quot;fixeddbar&quot;).style.display=&quot;none&quot;'><svg viewBox='0 0 512 512' xmlns='http://www.w3.org/2000/svg'><path d='M278.6 256l68.2-68.2c6.2-6.2 6.2-16.4 0-22.6-6.2-6.2-16.4-6.2-22.6 0L256 233.4l-68.2-68.2c-6.2-6.2-16.4-6.2-22.6 0-3.1 3.1-4.7 7.2-4.7 11.3 0 4.1 1.6 8.2 4.7 11.3l68.2 68.2-68.2 68.2c-3.1 3.1-4.7 7.2-4.7 11.3 0 4.1 1.6 8.2 4.7 11.3 6.2 6.2 16.4 6.2 22.6 0l68.2-68.2 68.2 68.2c6.2 6.2 16.4 6.2 22.6 0 6.2-6.2 6.2-16.4 0-22.6L278.6 256z'/></svg></div>

<div class='fixeddbar-content'> <div style="margin: 0 auto;text-align:center"><a target="_blank" href="https://www.miotsolutions.com/?utm_source=cnx_software&utm_medium=banner&utm_campaign=cnx_software" rel="nofollow noopener"><img src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 728 90'%3E%3C/svg%3E" width="728" height="90" border="0" alt="MIOT IoT modules" data-src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/MIOT-IoT-modules.gif?lossy=1&ssl=1" class="lazyload" data-eio-rwidth="728" data-eio-rheight="90" /><noscript><img src="https://eji4evk5kxx.exactdn.com/wp-content/uploads/2021/12/MIOT-IoT-modules.gif?lossy=1&ssl=1" width="728" height="90" border="0" alt="MIOT IoT modules" data-eio="l" /></noscript></a> </div> </div></div></div></body>
</html>
<!--
Performance optimized by Redis Object Cache. Learn more: https://wprediscache.com

Retrieved 31864 objects (2 MB) from Redis using PhpRedis (v5.3.5).
-->
<!-- Easy IO processing time: 0.17807579040527 seconds -->
<!-- Dynamic page generated in 0.501 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2022-01-16 11:01:56 -->

<!-- Compression = gzip -->