Review & Quick Start Guide for Khadas Vim Pro Development Board with Ubuntu 16.04

Khadas Vim is the only Amlogic S905X development board I’m aware of. There are 4 or 5 versions of the board, but currently only two models are sold: Khadas Vim with 8GB flash and single band WiFi + BLE 4.0, and Khadas VIM Pro with 16GB flash, and dual band WiFi + BLE 4.2. SZWesion, the company behind the board, has sent Khadas Vim Pro for evaluation. Today, I’ll take a few pictures of the board and its accessories, and report my experience playing with Ubuntu 16.04.2 on the board. They’ve also released Android, LibreELEC, and dual boot Android/Ubuntu (for Vim Pro only) images, which you can find in the firmware resources page.

Khadas Vim Pro Unboxing and Photos

My parcel included Khadas package that looks like a book, an HDMI cable, and the same IR remote control sent with GeekBox, the first board made by the company, and powered by a Rockchip RK3368 processor.


You can indeed open the package like a book, and you’ll find the board and a USB to USB type C cable inside, as well as some basic specifications.

Click to Enlarge

You can verify you’ve got the right model on that back of the package which shows the memory and storage, in my case 2 GB + 16 GB.

The board comes with a neat acrylic case with openings for headers and ports. The top of the board features a 40-pin header, the Amlogic S905X processor (no heatsink), two RAM chips, the eMMC flash, the wireless module (AP6255), and most ports with two USB 2.0 ports, a USB type C port, HDMI 2.0a, and Fast Ethernet. There’s also a separate header close to the USB-C port giving access to Vin in case you don’t want to power your board through USB.

Click to Enlarge

There’s also 2-pin battery connector on the left of the board for the real-time clock (RTC). The bottom side of the board includes two more RAM chips, and the micro SD slot.

Click to Enlarge

Power, “function” and reset buttons can also be found on the side of the board, and there’s an IR receiver on the right of the 40-pin header.

Click to Enlarge

Ubuntu 16.04 on Khadas Vim (Pro)

While you can download the firmware on the “Firmware Resources” page, I recommend you check the Announcements & News section on the forums, as they normally include a changelog and some tips to configure your board. An Ubuntu 16.04 + XFCE image was released last month, but the company uploaded a Ubuntu 16.04.2 server image yesterday, so that’s the one I’m going to use today. A new Ubuntu 16.04 + XFCE image with better graphics support will be released sometimes next week.

My plan is to do the update in my Linux computer. The firmware is distributed through Mediafire, so you’ll have to download it through your web browser. I also downloaded  Vim_Uboot_170121.7z on the Firmware Resources pge since it’s needed for the SD card update method. Once we’ve got the firmware and U-boot binaries we can extract them with 7z.


Now insert the micro SD card inside your computer, find the device with lsblk, and check if it has more than one partition. Replace /dev/sdX with your own device.


If it has no partition or more than one, you’ll need to change the partition table using tools like fdisk, or gparted. The instructions provided on Khadas website are basically the same as I wrote in the post “How to Create a Bootable Recovery SD Card for Amlogic TV Boxes“.


Mount the partition, for example by removing and re-inserting the micro SD card into your computer, and copy two files needed for update:


Eject the micro SD card:


Now connect your board with the cables would want to use (e.g. Ethernet, HDMI, etc…), and possibly connect a USB to TTL debug board to access the serial console in case of errors. I also connect a USB hub with my RF dongles for the air mouse and a USB keyboard.

Click to Enlarge

The board comes pre-loaded with Android 6.0.1 with Linux 3.14, so you can connect the power first to make sure the board is working properly. Note that you’ll need to provide your own USB power supply. I used a 5V power supply, and not a fast charger found in some phones and starting at 12V. Now we can insert the micro SD card we’ve just prepared into the board, and boot into Upgrade Mode by keeping pressing on the power button (closest to the 40-pin header), pressing a short time on the reset button (closest to the USB port), and releasing the power button two or three seconds later. At this point, you should get a firmware upgrade interface on the HDMI display with a green progress bar, and once completed you’ll get a “Successful Android” logo.

This is what it looks like in the serial console during the update:


So I pressed Control-C in the serial console (if you have not set it up just reboot the board), and it failed to boot with the multiple error messages:


I contacted SZWesion about the issue, and they told me the SD card method did not work despite being documented on their website, and I had to use Amlogic USB Burning Tool in Windows instead. So I fired up a Windows 7 virtual machine, and I had no problem (for once) flashing the “update.img” file extract from Vim_Ubuntu-server-16.04_V170211.7z to the board.

Click to Enlarge

This time it works and the board booted properly. Here’s the complete boot log for reference.

Once the boot is complete, you’ll be presented with a boot prompt on the HDMI monitor and the serial console:


After login with root / khadas crendentials, we can check some of the system details:


As expected we have a quad core Cortex A53 processor, about 14GB storage available fromthe 16 GB eMMC flash, 1.7 GB free for Linux, a Linux 3.14 kernel, and Ubuntu 16.04.2 LTS.

Normally, you don’t really want to login as root for all your tasks, so we’re being asked to create a new khadas user manually:


I would have expected this to be done by default in the image… I’ll keep using root in the rest of the instructions below.

The link status LED is on on my Ethernet switch, but let’s see if the network is up:


Again, I would have expected the network to start automatically, so we’d have to set that up ourselves as instructed in the release notes:


I could get an IP from my router:


Good. Now let’s check loaded modules and GPIO:


GPIOs are enabled, but we’d have to export the pin to use them, and I could not find specific documentation yet, except the GPIO pinout.

We can however control the LED on the board using one the states listed below


So we can want to turn off the red LED:


or make it blink depending on activity on the eMMC flash:


The Mali driver is loaded, but I’ve been told the drivers in the server image only works with non-X programs. I tried to install mesa-utils-extra for es2gears, and glmark-es2, but neither packages are available. That’s because several repositories are not enabled by default (e.g. multiverse and universe), but it’s easy to change:


Now I use install both packages:


But to test those we need grphics support. An easy way to enable support is to install a desktop environment such as Ubuntu MATE (2.4GB extra used on disk):


I could run both sample, but the message “LibEGL warning: DRI2: authentication failed” probably means we are using software rendering instead.

Click to Enlarge

This was expected as I’ve been old that the “current server built-in the Mali & DRM Linux driver, but the user-space binary driver is for non-X version(Desktop with Xorg should with X version)”, so next week, we may get an image with working 3D graphics acceleration. Note that for most applications it’s not that important to have OpenGL ES support, as most 3D desktop apps require OpenGL.

The release notes also mentions we can install Gnome mplayer to play some videos, so that’s what I did:


I played a Big Buck Bunny 1080p60 H.264 video from a SAMBA share, and then copy the video to the internal storage to try again. The results were the same: audio playing fine but the video is playing in slow motion, with a low frame rate (1 second video takes about 5 seconds to play). So if you plan on using the platform as a media player, you’d better install the LibreELEC image, while the platform is just not ready for applications like digital signage, where you may need text, photos and videos playing at the same time.

I also installed iozone3 in order to test the eMMC flash performance after updating /etc/apt/sources.list with more multiverse lines.


Results:


Read performance @ 121 MB/s is pretty good, and write performance is more limited at up to 36 MB/s. Random IO performance looks OK.

Khadas developers have made a working Ubuntu image, but as you can see from my experience, there’s still work to do to make it a “flash and play” Linux board… It’s quite possible the Android image works better, but then you have a lot of other choices with Amlogic S905X TV boxes. Both boards can be purchased on GearBest with Khadas Vim board with 8GB flash going for $49.99, and Khadas Vim Pro board, reviewed here, selling for $64.99. Note that the remote control and HDMI cable I received with the board are sold separately for respectively $4.59 and  $2.68.

Share this:

Support CNX Software! Donate via PayPal or cryptocurrencies, become a Patron on Patreon, or buy review samples

37 Replies to “Review & Quick Start Guide for Khadas Vim Pro Development Board with Ubuntu 16.04”

  1. es2_info might work from console (not X11), and see what mali driver is included. i also think es2gears has a dri version, so u can try running it from console too…

  2. your iozone paste got cut, but if one will look more closely 4k block read/write is 12/4 MB/s. also, this board REQUIRES heatsink and at least low speed fan to operate without overheating/throttling

  3. @cnxsoft:
    Thanks for the eMMC numbers. Module used looks quite capable even if sequential write speeds are somewhat low but 4K random IOPS are multiple times higher than ‘A1 performance profile’ would require (part of new SD5.1 specs and maybe worth an own blog post to educate your readers about both ‘Android Adoptable storage’ and the importance of random IO): https://forum.armbian.com/index.php/topic/954-sd-card-performance/?p=25272

    S905X without heatsink ‘makes perfectly sense’ so at least peak CPU performance will be limited to a few seconds before throttling jumps in.

    The AP6255 WiFi-/BT modules looks interesting (dual band and not just 2.4GHz) unless you dig deeper. It’s BCM43455 used here (1×1 HT80 802.11ac, 2.4GHz and 5GHz, 433 Mbps PHY rate / 80MHz channel bandwidth) so while the PHY rate looks pretty nice real-world numbers will be way below even in 5GHz band and maybe the module will already be bottlenecked by SDIO bus? Are you able to do some tests with 802.11n/ac in 5GHz band?

    BTW: Is there a second application available making use of OpenGL/ES apart from this es2gears thingie? I mean I always see rotating objects garnished with fps numbers but where is a real application that could make use of this?

  4. @zoobab
    I’ve really no idea that’s why I’m asking. Just did a web search regarding Wayland, came across a blog post called ‘Gnome Wayland on Amlogic S905 Mali 450’ and am impressed by the amount/complexity of problems and the lack of any solution.

    1. What that post doesn’t say is that wayland drivers require DRM, and amlogic does not have a drm driver neither in 3.14 or 4.x kernel. So even if the hikey drivers could work on s905, wayland still won’t work.

  5. “You can also power the board with a battery via the 2-pin connector on the left of the board.”

    There is no battery management, that two pin connector is only for RTC battery. The 4 pin connector behind USB-C port can be used to power the Vim, but again, no battery management. So while a battery(power pack) could be used to power the Vim, the battery will have to be managed/maintained elsewhere.

    Great little box, I have had a lot of fun with it. Khadas support team has been very responsive and productive so far. The Khadas forum is growing in both users and content.

    Triple-booting is coming, Android and Ubuntu from NAND, OpenElec/LibreELEC from SD card/Flash drive.

    The box could benefit from heatsink, fan, or both. Khadas will be offering a fan kit with new case top section within days.

    Thanks for the nice review.

  6. @kc
    On the fan and heatsink issue, you can treat this like a very small TV box and just use a large metal plate. I opened my Alfawise s912 ( Amlogic s912 soc ) the other day. There is a square of heat sink putty and a metal plate is fixed to the case top section.
    Those who have used air cooled heat sinks, with no fan, video cards will understand .

    * I am not a trained electrician or in electronics * With that out of the way, I can power my Khadas Vim by plugging the supplied power cable in a usb port of my Alfawise s912. It is up to you to ensure if safe or not to do. I am not responsible for any damage done or not done.

  7. I have been working with a Khasas VIM for several months now, trying to set it up as the basis for a product we plan to offer; a headless linux server running our application software. I love this device in many ways and have been getting great support from Gouwa (unlike the (lack of) support I got from BananaPi), but there are a few issues I still have with it:

    1. Need to get Docker working on it (Gouwa claims this is coming.)
    2. Need to get USB OTG to provide a TCP/IP connection (Gouwa claims this is coming.)
    3. Using Ubuntu the monitor is not turned on until it is fully booted (Gouwa claims this is coming.)
    4. Using Ubuntu the LEDs do not give any indication other than power connected (Gouwa claims this is coming.)

    5. I really, really wish is supported an M.2 2242 for SSD. If so, they could have option to drop eMMC. More on why below.
    6. Wish it had a heat sink (but not a fan. Want it to be quite with no moving parts.)
    7. Wish it had better power supply options, but that would make it larger so I am on the fence about that.

    8. Wish they offered an optional top plate that did not have the holes for GPIO, RTC battery and extra power port.
    9. Wish they offered a fully enclosed case, the same size as this case with holes for GPIO, RTC battery and extra power port filled in but able to be punched out if needed (we don’t need the holes.)
    10. With is had a battery charger and an optional larger case to support the battery.

    11. Option to drop HDMI and replace with a micro USB for serial console access
    12. To support #11, switch one (or both) of the USB A ports to Micro USB

    If Khadas addressed all the above for w/no eMMC but an M.2 SATA, this would be a perfect platform for building a consumer product. There is currently nothing I have been able to find that is turnkey hardware to support the ability to build a headless Linux server at a low enough price point and with a pre-made case; a future Khadas product could be just that.

    BTW, my biggest roadblock is the super slow MySQL performance when running off on an SD card. I have not tried eMMC yet but am concerned both about corruption and that its performance won’t be enough better than the SD card. I am currently working on a way to move SQL data to 1.0GB of tmpfs RAM disk to make performance acceptable but I have not yet verified that we can somehow keep that data from being lost when power is removed but I have several approaches I plan to try. If anyone is interested in what I come up with, ping me at mike @ newclarity.net and I’ll be happy to follow up.

    Also, I LOVE that all the Khadas VIM ports are on one side of the board. That is much better as the basis for a product.

  8. @Paul M
    Some 4K Blu-ray rips may be over that. I’ve had people told me they wanted to play 13.5MB/s (That’s Megabytes/second) videos over WiFi. That’s higher than Fast Ethernet capabilities.
    Now if you want to stream 4K videos from the web, then the bitrate will be much lower than that.

  9. @Mike Schinkel
    I’d recommend you try the eMMC flash for your slow MySQL queries. Most SD cards are much slower than eMMC flash for this type of task. The 16GB eMMC flash in Khadas VIM Pro should be a little faster than the 8GB one in Khadas VIM, as usually performance increases with size for parts from the same “family”.

    Amlogic S905X does not support SATA, so they would have had to use a USB to SATA bridge.

  10. @Memeka
    Both DRM and Mali driver is available for S905X, you can check Khadas Github for the source code:
    https://github.com/khadas/android_hardware_arm_gpu

    Amlogic provide the drivers for both Android & Buildroot separately with linux kernel, and Khadas team will built-in the drivers into linux kernel and release in this week after more testing.

    And as the mainline linux, there also some users have ported to VIM, you can check Martin’s Github for the info(Martin is a upstream Linux kernel developer):
    https://github.com/xdarklight

  11. @Mike Schinkel
    Mr Schinkel the Khadas Vim case comes a part so you could replace the top yourself, or just make a top, stick on plate, to attach to the top.

    Many Amlogic s905 – s912 TV boxes, already are running and being used with no fan!. Go look at the Mi Box review here on CNX-software dated 12th Feb 2017. On the teardown photo, on the left of the photo is the inside of the Mi box and you can see a large passive heatsink with the marks of the Silicone thermal pad still on it.

    If anyone is interested in messing around, Gnuroot Debian by Corbin Champion ( for non rooted devices ) will install from Google Play.

    It is Debian Jessie and reports a few comments when apt-get update and upgrade are used. Limited in use I know but thought I would mention it.

    I have neither a spare sdcard or been mad enough, to try seeing how far Linux deploy by meefik, on Google Play, runs before having problems.

  12. @Gouwa
    Ah, good to know Armbian build system can be used with Khadas Vim (Pro) already 🙂

    Just a small note: we all should stop recommending dd and other uncapable tools to write OS images to storage. There are better alternatives available and people should know that they must check their SD cards and USB thumb drives (flash storage in general) directly after purchase: https://docs.armbian.com/User-Guide_Getting-Started/#how-to-prepare-a-sd-card

    I had numerous occurences where dd ‘burned’ OS images to SD card that failed later where Etcher reported media errors either immediately or at verify stage.

  13. I just received a VIM Pro, thanks to @Gouwa.

    Has anybody a mainline kernel 4.9 (or later) running on the VIM Pro and could share his kernel repo? Or has already included AUFS in the standard 3.14.29 kernel? I’m just asking because these are the both options to get container support (aka Docker) for the VIM and VIM Pro.

  14. @tkaiser

    Hi, tkaiser:
    I’m not quite understand what you mean about:
    “Just a small note: we all should stop recommending dd and other uncapable tools to write OS images to storage.”

    I’ve read the link you posted and found that same ‘dd’ approach too write OS images to storage was used.

  15. @Gouwa
    Thanks for the heads up. I removed the dd examples now (will be updated soon on official doc site) since it saves a lot of time only recommending Etcher any more.

  16. 50 MB application to write SD card? And what is wrong with dd? Newer saw it fail. And in this case verify confirms data integrity.

  17. Peter :
    what is wrong with dd?

    It works only based on the assumption it operates on storage without failures which is obviously not the case with many SD cards. Since I do a lot of testing I came across four SD cards over the years that are defective. With dd I can burn OS images to all four of them without getting any notification. Symptoms later vary: with the worst one (cheap ‘class 4’ crap) fortunately even first boot might fail so you get a clear indication that’s something’s wrong, with the three others it’s different and symptoms always look like software failures instead (errors when updating a lot of software for example or failure to adjust settings and weird stuff like that).

    Another issue is that even if SD card is fine sometimes burning process fails (overheating card reader when connected to USB3 ports, not properly shielded USB cables so burning on PC’s USB front ports corrupts data while not on PCB connected back ports).

    Etcher catches all these errors, some even at the burning stage, the others at verification. Saves a lot of time if you have to deal with user support since so many ‘software issues’ are just the result of broken burning processes. Experienced users who know the problem and are able to verify storage media might still use dd but for the average user something like Etcher is way better (or any other burning tool that provides verify by default, I know only of some patched/outdated Win32Diskimager version made by ODROID folks to save them time dealing with these stuppid hardware issues that users aren’t aware of)

  18. @tkaiser
    I normally get “I/O error” messages when I dd to a defective SD card. But I don’t have as much experience as you do flashing many different type of cards. I’m using Linux, I wonder if the behavior might be different in Mac OS ?

    Changing subject… I prefer programs installed through apt, since they get updates automatically, while the download page does not mention it, they have setup a repo for it as indicated in github @ https://github.com/resin-io/etcher#debian-and-ubuntu-based-package-repository-gnulinux-x86x64:

    etcher-electron is the GUI version. There’s also a command line version that can be installed with npm: https://github.com/resin-io/etcher/blob/master/docs/CLI.md

  19. @cnxsoft
    I got the same behaviour on Linux too. My Armbian build host is an amd64 box where I flashed OS images automagically with dd before. There I experienced first failure of the internal card reader and then also USB front ports (most probably both due to bad cabling) and checked a few months back with 2 of the defective SD cards. Not a single complain with dd but image on SD card was always corrupted. That was a crucial experience and now I’m always verifying since I wasted too much time hunting non-existing bugs.

    Thanks for mentioning the repo and CLI version 🙂

  20. @Gouwa
    I have mixed feelings about it. It’s good for open source community. On other hand…
    I’m figting with Amlogic since 2012 for their legally obtained sources then some good Samaritan from China uploads almost up to date latest sdk to github with no questions asked?

Leave a Reply

Your email address will not be published.

Advertisement
Advertisement