NanoPi R2S Dual GbE IoT Board and Gateway Launched for $22 and Up

We first covered NanoPi R2S SBC back in mid-January 2020. Specifically designed for headless and IoT application the board features a Rockchip RK3328 processor combined with 1GB RAM, and contrary to most competing platforms on the market such as Orange Pi R1 or NanoPi R1S, R2S comes with two true Gigabit Ethernet ports.

At the time, the board was not available for sale, but now FriendlyELEC has started to take orders for just $22.00, and adding a yellow case adds $3 to the total. This is around $5 extra compared to NanoPi R1S gateway which was expected with extra RAM (1GB) and true dual GbE connectivity.

But in the age of COVID-19, nothing runs quite as smoothly as it used to and the company expects shipping delays:

Because of the epidemic, postal services in a lot of countries get delayed. Customers who need orders urgently need to choose DHL. EU customers who need DHL service to deliver orders need to email us before place orders.

Buy NanoPi R2S Dual Gigabit Ethernet SBCHere’s a quite reminder of the board’s specifications:

  • SoC – Rockchip RK3328 quad-core Cortex-A53 @ 1.5 GHz with Arm Mali-450MP2
  • System Memory – 1GB DDR4 RAM
  • Storage – MicroSD Slot, SPI flash footprint
  • Connectivity
    • 1x Gigabit Ethernet (WAN) up to 941 Mbps (measured)
    • 1x Gigabit Ethernet (LAN) up to 941 Mbps (measured) via Realtek RTL8153 USB 3.0 to Ethernet controller
    • 802.11b/g/n WiFi 4 with IPX-I antenna connector
  • USB – 1x USB Type-A host port, 1x micro USB port (power + slave)
  • Debugging – 3-pin 2.54mm pitch header for serial console
  • Expansion – 10-pin GPIO header with GPIOs, I2C, UART, IR_Rx, 5V, 3.3V and GND
  • Misc – 3x LEDs (WAN, LAN, SYS), K1 reset button, fan header
  • Power Supply – 5VDC/3A via micro USB port
  • Dimensions – 55.6 x 52mm
  • Temperature Range – -20 to 70

NanoPi R2S SPI Flash Footprint

As noted in our previous if you need WiFi with your board, you’ll need to connect a USB WiFi dongle, but besides dual Gigabit Ethernet connectivity, you’ll also get access to a 10-pin GPIO header which was not present in NanoPi R1S. Supported operating systems include FriendlyWrt (OpenWrt) and FriendlyCore (Ubuntu 18.04 Core) with all details available in the Wiki in English or Chinese.

NanoPi R2S RouterThanks to theguyuk for the tip.

Share this:
FacebookTwitterHacker NewsSlashdotRedditLinkedInPinterestFlipboardMeWeLineEmailShare

Support CNX Software! Donate via cryptocurrencies, become a Patron on Patreon, or purchase goods on Amazon or Aliexpress

ROCK 5 ITX RK3588 mini-ITX motherboard

32 Replies to “NanoPi R2S Dual GbE IoT Board and Gateway Launched for $22 and Up”

  1. another awesome geeky thing is that it comes with kernel 5.4
    and about shipping it seems DHL (expedite) is 25$ 🙁 and regular post 8-10$ to Europe 🙁

    1. Hi Jean-Luc – and all – OpenWrt and the R2S – welll, as you know I’m a long tiw aupporter of FriendlyArm, but I’m failing to see the point of OpenWrt and this device – iwthout WIFI it seems that the mANGO router is a better bet. FA DO apparenrtly supporrt one WIFI USB dongle- but NOT the one most commonly available, certainly in the UK. So much as I would liek to support FA in this, unless they release a binary supporting the adaptor, I’m finding it difficult. – right now the software definitely does not yet support the popular rtl718188eus and I think asking people to recompile OpenWrt for that is asking a lot.



      1. > right now the software definitely does not yet support the popular rtl718188eus and I think asking people to recompile OpenWrt for that is asking a lot.

        I guess you’re talking about 8188EU, right? Driver is provided so maybe it’s just missing firmware:
        opkg install rtl8188eu-firmware.

        Though no idea why anyone would want to use those crappy USB dongles in an access point scenario…

        1. Oh, hello Tkaiser. Ok, I’ll give it a shot? Why would anyone eant to ue a cheap WiFi dongle in a cheap router? Fairly obviously as it is cheap and widely available. I tried purchasing one of the more expensive WiFi dongles – the one supported, just to properly test the R2S – but certainly in the UK not only is the price much higher but my package has (not entirely unsurprisingly) not arrived. I have several other routers ranging from the Mango, through Draytek and others. My job here was just to see if the R2S was worth purchasing.

          1. > Why would anyone eant to ue a cheap WiFi dongle in a cheap router? Fairly obviously as it is cheap and widely available

            Those things are not suitable for the access point use case due to crippled firmware (breaking if more than n clients connect), no real antenna(s), no MIMO, no beamforming. But sure, if it’s just about a really horrible wireless experience even an antenna-less 8188EU will do the job with one or two clients connected to it.

            BTW: No idea whether installing the rtl8188eu-firmware package will do the trick. Maybe your cheap dongle is based on another chip. Usually lsusb and dmesg will tell what’s going on. But since OpenWRT is modular and the exact opposite of bloated by design usually you need to install those packages, e.g. opkg install dmesg first.

            Of course something that bloated as Raspbian contains all imaginable device firmware packages by default and requires an install media several GB in size. OpenWRT is designed to live in a few MB of space and as such it will not ship with hundreds MB of firmware for each and every USB device out there.

          2. Cant install either lsusb or dmesg at root command line – this is going downhill fast. Got dmesg in web interface though. “installing…” “Configuring…” then nothing 5 minutes later – still saying configuring. Life is too short… Back to my Mango.

          3. this is what we got on Pete’s device, once connected the friendlyarm suggested dongle rtl8821CU
            it’s in lsusb, but i see errors in some sort of db and iw commands do not report anything usable…

            [ 13.506919] kmodloader: loading kernel modules from /etc/modules.d/*
            [ 13.558425] usbcore: registered new interface driver r8152
            [ 13.647465] cfg80211: Loading compiled-in X.509 certificates for regulatory database
            [ 13.750355] usb 5-1: reset SuperSpeed Gen 1 USB device number 2 using xhci-hcd
            [ 13.786094] r8152 5-1:1.0 (unnamed net_device) (uninitialized): DT mac addr 66:ac:f2:4f:48:e2
            [ 13.821105] r8152 5-1:1.0 eth1: v1.10.11
            [ 14.083169] cfg80211: Loaded X.509 cert ‘sforshee: 00b28ddf47aef9cea7’
            [ 14.087492] platform regulatory.0: Direct firmware load for regulatory.db.p7s failed with error -2
            [ 14.088329] platform regulatory.0: Falling back to sysfs fallback for: regulatory.db.p7s
            [ 14.149931] rtl8821CU: loading out-of-tree module taints kernel.
            [ 14.286768] usbcore: registered new interface driver rtl8821cu
            [ 14.303015] NET: Registered protocol family 8
            [ 14.303712] NET: Registered protocol family 20
            [ 14.356811] NET: Registered protocol family 15
            [ 14.383044] tun: Universal TUN/TAP device driver, 1.6
            [ 14.482227] l2tp_core: L2TP core driver, V2.0
            [ 14.493309] l2tp_netlink: L2TP netlink interface
            [ 14.533907] gre: GRE over IPv4 demultiplexor driver
            [ 14.545626] ip_gre: GRE over IPv4 tunneling driver
            [ 14.823247] Mirror/redirect action on
            [ 14.897353] u32 classifier
            [ 14.897642] input device check on
            [ 14.897977] Actions configured
            [ 15.079022] usbcore: registered new interface driver cdc_ncm
            [ 15.303060] PPP MPPE Compression module registered
            [ 15.305421] NET: Registered protocol family 24
            [ 15.307942] PPTP driver version 0.8.5
            [ 15.371691] xt_time: kernel timezone is -0000
            [ 15.400284] usbcore: registered new interface driver brcmfmac
            [ 15.418163] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
            [ 15.422052] usbcore: registered new interface driver cdc_mbim
            [ 15.430877] l2tp_ppp: PPPoL2TP kernel driver, V2.0
            [ 15.438396] Bridge firewalling registered
            [ 15.445044] kmodloader: done loading kernel modules from /etc/modules.d/*
            [ 16.623174] cfg80211: loaded regulatory.db is malformed or signature is missing/invalid

        2. “opkg install rtl8188eu-firmware”
          “Package rtl8188eu-formware installed is up to date” – so no further forward I’m afraid. So that’s not it…

          1. Well, I would do an dmesg -w then (re)insert the dongle to see what’s going on. Usually that gives some hints which device this is and what’s happening (e.g. the kernel built by FriendlyElec containing hard-coded but wrong paths for firmware files so even if the firmware is present it won’t load). If dmesg is not available it should be just an opkg install dmesg away. 🙂

          2. Do dmesg is in there – I ran it – HORRENDOUS amounts of unrelated output – so much so that comparing before and after dongle insertion isnt doing me any good… some windows style colour0coding would help immensely.. AFTER…. last few lines..

            [14127.831149] usb 2-1: new high-speed USB device number 3 using ehci-platform
            [14127.860460] usb 2-1: New USB device found, idVendor=0bda, idProduct=8179, bcdDevice= 0.00
            [14127.861254] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
            [14127.861918] usb 2-1: Product: 802.11n NIC
            [14127.862296] usb 2-1: Manufacturer: Realtek
            [14127.862687] usb 2-1: SerialNumber: 0092CC018599

          3. It looks like many people have trouble making your WiFi dongle work with OpenWrt. You may have to install kmod-rtl8xxxu.

          4. *Edited

            The driver is missing in the FriendlyWrt Image.
            Once you or someone else build the image with this kernel config
            then it will work.
            This **SHOULD** be the correct driver to make your wifi dongle work properly.

      2. Get not so popular 8811AU or 8822BU and enjoy good performance. With Armbian … no idea what they bake into the OpenWrt … which you might rather run as a docker container on top of the Armbian.

  2. 2020 and STILL no cheaply available usb3/gigabit combo boards. But at least this is a step in the right direction, dual gigabit ports can be quite useful.

        1. yeah, but including shipping and import costs and comes even more expensive than rpi4 with lesser specs.

          1. Then it’s not “no cheaply available usb3/gigabit combo boards”, it’s just that none matches your needs and/or budget. Because between NanoPi-Neo4, RPi4, various RockPis, EspressoBin, the choices are quite large at very low prices, so you need to be more specific about what you’re looking for.

          2. something that has gigabit lan and usb3, but comes lower than 22€ pricing wise, so no import duties, taxes and processing fees. Because thats what kills a 30-40$ board over here in europe. Just ends up too expensive to something, that can be sourced locally (like raspberry pi).

    1. But if you only need one Ethernet port, a Raspberry Pi or countless others would do the job. In my test scenario, I use the WAN port connected to my network and the LAN port connected to a PC which needs to be on it’s own private network provided by the R2S – but to be genuinely useful it also needs support for WiFi – hence my issue with only one kind of WiFi USB dongle (apparently) being supported – and NOT the most widely avalable one. I generally would use a MANGO for this but of course the R2S + OpenWrt has more resources.. just need that WiFi issue cracking to make ir worthwhile.

    2. Nope, usb3 is shared with the second Ethernet connection, as that chipset only has a single gigabit mac.

  3. Friendlyelec now offer their own cnc metal case $6 option when bought with board. Sales page also now has heat cooling graph for cooling options.

Leave a Reply

Your email address will not be published. Required fields are marked *

Khadas VIM4 SBC
Khadas VIM4 SBC