ODROID-C2 Amlogic S905 Development Board is in the Works

Hardkernel ODROID-C1 and later ODROID-C1+ boards, both based on Amlogic S805 SoC, have been a popular alternatives to Raspberry Pi 2 board this year. But now that Amlogic S905 quad core 64-bit ARM Cortex A53 processor has been available for a few months, people have been wondering whether the Korean company would launch an Amlogic S905 board, and it looks like ODROID-C2 might not be too far off based on firmware files on odroid.in website.

Picture of ODROID-C1+ (Not ODROID-C2 pic yet)
Picture of ODROID-C1+ (No ODROID-C2 pic yet)

The firmware includes a device tree file, which combined with other files give some clues about ODROID-C2 specifications:

  • SoC – Amlogic S905 quad core Cortex A53 processor @ up to 2.0 GHz with penta-core (3+2) Mali-450MP GPU
  • System Memory – 1GB RAM (in doc), 2GB RAM (in Device tree)
  • Storage – 1x micro SD card
  • Video Output – 1x HDMI out
  • USB – 1x USB hub, 1x USB OTG

I don’t have much more information about the platform.

Buildroot menuconfig with ODROID-C2 config file
Buildroot menuconfig with ODROID-C2 config file

You can also find some ODROID-C2 or “odroidc2” references it in the latest Amlogic buildroot, and for example to build a bootable image based on Linux 3.14.29 for ODROID-C2, you can run:


I guess we’ll have to wait a little longer to find out exactly whether ODROID-C2 is based on the same form factor as ODROID-C1+ board, or closer to ODROID-C0 concept. If you’ve been trying to run Linux on Amlogic S905 devices, using the latest kernel may help fixed some of the issues we’ve had in the past. I have not tried it yet.

Support CNX Software - Donate via PayPal or become a Patron on Patreon

5
Leave a Reply

avatar
5 Comment threads
0 Thread replies
0 Followers
 
Most reacted comment
Hottest comment thread
5 Comment authors
Capt. HerpDerpkuchocnxsoftStane1983Steven Lin Recent comment authors
  Subscribe  
newest oldest most voted
Notify of
Steven Lin
Guest

[email protected] {
device_type = “memory”;
linux,usable-memory = ;
};

Looks like it has 2GB of memory compare to other s905 dts.

Stane1983
Member

Odroidc2 build wont work. If you check actual defconfig, you will see that kernel (and some other stuff maybe, don’t remember) are downloaded from Korean git server. When I tried to sync, I got permission denied (git+ssh). But indeed, uboot also does have odroidc2 configuration.

kucho
Guest
kucho

they have to improve their support to the platform. there is very little community…

Capt. HerpDerp
Guest
Capt. HerpDerp

@kucho
Their community has grown A LOT since the C1 came out. I’ve notice there are a lot more community images as well as images from groups like Lakka, Arch, ect.

I would be really disappointed to see a 64bit board paired with only 1Gb or RAM. I know Hardkernel confirmed with a date the C0, I wonder if this is still in R&D slated for a summer release?