Debian on DragonBoard 410c Development Board

I purchased Qualcomm DragonBoard 410c development board last year, and first tested it and run some benchmark on the 96Boards compliant hardware with Android. I found that it was still work-in-progress, and decided to wait before trying Debian on the board. I’ve now done so, and will report by experience installing Debian Linux, playing with the board, and running Phoronix benchmarks to compare it to other ARM Linux boards.

Installing Debian on DragonBoard 410c

The first challenge is to navigate through the documentation that is not always clear or up-to-date. I eventually ended up on DragonBoard 410c Wiki on Github.

DragonBoard_410c_Debian_Android_Opearting_SystemsYou then have to decided which image you want. While there are two official operating systems with Android and Debian, you can three “entities” releasiong their own images. For Debian specifically, you have the Linaro image, and Reference Platform Build (RPB) image. I could not find any changelog or known issues with the former, but the latter as its own Wiki with the latest release being RPB 16.03 (March 2016), and the next one scheduled to be RPB 16.06 in June.

That’s the current list of known issues

  • bug 285 USB host doesn’t detect any plugged devices
  • bug 121 [RPB] Cannot soft power off or shutdown db410c
  • bug 284 [RPB] Dragon board Display sleep not working
  • bug 289 [RPB] USB devices don’t work after reboot
  • bug 207 [RPB] Bluetooth does not work on Dragon board debian
  • bug 153 [RPB] Missing information about hwpack usage

USB host not working did not inspire confidence, so I first tested the Linaro image. The (other) Wiki points to the “latest version”, but the link would point to Linaro Debian 16.02 release, while I could find a more recent Linaro Debian 16.04 which I downloaded in a terminal:

I used a micro SD card to install it. If you use Windows, simply use Win32DiskImager, but in computer running Linux or in Windows via Windows subsystem for Linux, you may want to do it in the terminal. First check the SD card device with lsblk. Mine was /dev/sdb, but your may be different, and I use /dev/sdX in the command below tp flash the Debian installer to a micro SD card:

Now remove the micro SD card from your computer and insert it in to the board, set the jumper to boot from SD card on the DragonBoard 410c, and connect the power. I could see LED 1 blinking, but nothing on my HDMI TV. Last time, I did not  manage to make the serial console (requiring a 1.8V USB to TTL board or cable) using Hardkernel ODROID board, so I went to the support forums, and after several minutes of reading, I found that the RPB image is recommended, as well as a clear explanation between the Linaro and RPB images:

Use the Reference Platform Build instead of the Linaro release. The Reference Platform is an integrated build with support for multiple boards, and that is where all engineering effort is going. The Linaro build is the old single-platform image that we’re not working on anymore.

The reference platform will run on all 96boards CE (Consumer Edition) and EE (Enterprise Edition), while the Linaro image is built specifically for a given board, and they are not really working on it. [Update: This answer was specific to Hikey board, and for DragonBoard 410c there are two images provided by Qualcomm Landing Team and the Reference Platform team]

So let’s start again from scratch using the RPB image, and download the bootloader, Linux kernel and rootfs to my Ubuntu computer:

Now find a micro USB to USB cable to connect to DragonBoard 410c, install fastboot…

.. and check the device is detected:

Good. After making sure the jumper switch is set to 0000 on the board again, we can  extract the three files, and install Debian as follows:

That was a lot of commands to install the operating system… Now you can unplug the board, remove the micro USB cable, and connect the power again. After a few seconds, you should see the kernel log, and eventually LXDE desktop environment.

Click to Original Size
Click to Original Size

You’ll be asked to configure WiFi, and you’re basically done.

DragonBoard 410c Debian System Info

I’ve then run a few command to learn more about the image and system:

One of the main advantage of 96Boards should be recent Linux version,and that’s exactly what we have here with Linux 4.4 running on the board. Out of a total of 866MB reported RAM, 64MB is free, and the 6.9GB rootfs has 4.8 GB available to the user. Snapdragon 410 SoC is correctly reported as being a quad core Cortex A53 (0xd03) processor.

I used file utility to make sure a 64-bit rootfs is being used here:

Finally, there’s a bunch of modules pre-loaded on the board:

Testing Debian on DragonBoard 410c

The thing that often do not work on ARM Linux board are 3D graphics and hardware video decoding, so I’ve specifically tested these two, and also played with the pre-installed Chromium browser.

If I understand correctly the debian image comes with Freedreno open source graphics driver, and if that’s the case I have the first ever platform with working open source 3D graphics drivers:

So that means both framebuffer and X11 3D graphics acceleration are working. Nice !

I also tried to play Tuxracer as it was part of the board’s test results provided by Linaro.

It works, but it’s so slow that it’s barely playable (see video below).

I installed VLC to play 1080op h.264 videos, but based on the CPU usage the system is clearly using software decoding, and there’s no audio via HDMI. I’ve asked about those two issues on the forums about 24 hours ago, but I have yet to get a reply.

Chromium loads OK, but I did notice some freezes during use, and YouTube will struggle at full screen at 1080p, in similar way to many other low end ARM Linux platforms.

DragonBoard 410c Linux Benchmarks

Let’s install the latest version of Phoronix…

…and run some benchmarks to compare against other development boards:

After over 3 hours the results are in. Bear in mind that the board does not have heatsink, just a metallic shield, and this may affects the performance. It’s also running an OS with a 64-bit ARM rootfs, while platforms like Raspberry Pi 3 features a 64-bit processor running 32-bit code.

Click to Enlarge
Click to Enlarge

I like to check John the Ripper for multi-threaded performance.

DragonBoard_410c_Phoronix_John_The_RipperWhile FLAC audio encoding is nice to single threaded performance.


In theory the CPU performance of Snapdragon 410 and Broadcom BCM2837 (as found in RPi 3) should be equal since both are quad core Cortex A53 processors @ 1.2 GHz, but for some reasons DragonBoard 410c is a little slower in the multi-threaded benchmark, and quite faster during FLAC audio encoding likely due to software differences (Aarch64 vs Aarch32).

You can find the full results @

Share this:
FacebookTwitterHacker NewsSlashdotRedditLinkedInPinterestFlipboardMeWeLineEmailShare

Support CNX Software! Donate via cryptocurrencies, become a Patron on Patreon, or purchase goods on Amazon or Aliexpress

33 Replies to “Debian on DragonBoard 410c Development Board”

  1. Excellent review, looks like the end-user experience could use some documentation and workflow cleanup, but seems like the software itself is maturing and coming along nicely.

  2. Excellent review indeed! This part in particular brought a tear to my eye:

    ‘If I understand correctly the debian image comes with Freedreno open source graphics driver, and if that’s the case I have the first ever platform with working open source 3D graphics drivers’

    I thought I’d never live to see the day. Upstream kernels and OSS GL stacks – the way those devices were meant to be run. /raises teacup

    @cnxsoft, can you comment on the heat dissipation of the board – does it come with a sink, and do the CPU cores throttle notably?

  3. @blu
    You can see what the board looks like @

    So no proper heatsink. I think it’s throttling a little based on John the Ripper results, but I have not checked it formally. RPI monitor would be a nice thing to run, but I’m not sure it supports that board.

    I did try to check the temp with an IR thermometer, and temp was only about 45 C, but the metallic shield is a bit shiny, so it may have skewed the results.

  4. Sorry for the confusion at the documentation side, it’s a lot better but still not perfect. The RPB is a general effort that Linaro is doing for the multiple boards we support, in a way to exercise the idea of a common kernel and rootfs, which is why we recommend it.

    On the other side, we also have another Debian build for DB410c, which is maintained by the Qcom Landing Team. That build can be found at The message in the forum recommending RPB and saying that the Linaro build is not supported was only for HiKey, for DB410c that build is still active.

    I know it is confusing, but currently we have 2 Debian builds for DB410c, one maintained by the Qcom Landing Team and the other part of the Reference Platform Project (which consumes a lot from what the Qcom Landing Team also provides, but tries to make it general and common across other boards).

    And thanks a lot for your post, really nice to see the results (and we expect performance to improve quite a bit with the next releases).

  5. Regarding the huge amount of commands to flash, that is only required for a clean flash (or when switching between Debian and Android). After that is done, you can keep updating only the boot and rootfs images (via fastboot).

  6. @cnxsoft
    If /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq is available RPi-Monitor will already graph throttling behaviour. My first steps when trying to support a new board to get thermal and voltage values if available are then as follows:

  7. I’ve been asked to test Retroarch game emulator:

    But it won’t build:

  8. FFmpeg is needed to record or live streaming video you can disable it for now by adding –disable-ffmpeg

    ./configure –enable-kms –enable-egl –disable-ffmpeg && make -j4

    Thank you for your test.

  9. @cnxsoft
    Yes it compiled fine on other ARM platform.

    Can you git pull to get last update because there was buildfix for compiling without ffmpeg just 3 hours ago 😉

    git pull
    make clean
    ./configure –enable-kms –enable-egl –disable-ffmpeg && make -j4

  10. @gouchi
    Accessing the Core Updater does nothing. The other part Core Info Files, Assets, etc… can all be downloaded. But since I can’t load any cores I’m stuck.

  11. @cnxsoft
    I see.

    Can you try to compile test gl core ?
    cd RetroArch/cores/libretro-test-gl
    make -j2

    Then you can Load the core ( and then Start core to see if it is working.

  12. @gouchi
    I’ve built it but it won’t show in the list of cores.

    Yes, I had already tried that image, but it would not boot at all.
    That’s hack has a massive heatsink, even bigger than the board. 🙂

    I’ve moved on to other boards right now, so I’m not sure when I’ll be able to do further tests.

  13. @cnxsoft

    The default path for the cores is ~/.config/retroarch/cores so you need to copy to this path. You can load it with Load Core then start it with Start Core.

  14. @blu

  15. @cnxsoft

    Can you try to launch it with :
    retroarch –verbose -L ~/.config/retroarch/cores/ > /tmp/log.txt 2>&1

    And paste the log.txt to hastebin ?

    Thank you very much for your tests.

  16. @Beta-Pictoris
    Both boards have about the same performance, so if RPi 3 is acceptable as a mini Desktop PC to you, Dragonboard will be too.

    If you are used to faster machines, the user experience may still be frustrating at times.

  17. Has anyone gotten gamepads/joysticks to work on the Dragonboard? I’m porting my SmartGear multi-system emulator to it and the code runs fine, but the system won’t recognize any USB gamepads or bluetooth gamepads. If someone would like to test my game emulator, please let me know (bitbank@pobox.com0

Leave a Reply

Your email address will not be published. Required fields are marked *

Khadas VIM4 SBC
Khadas VIM4 SBC